Autore Topic: Immagini e link  (Letto 3560 volte)

Offline gmassolo

  • Esploratore
  • **
  • Post: 86
    • Mostra profilo
Immagini e link
« il: 24 Feb 2015, 18:49:12 »
Se inserisco immagini con sfondo trasparente ho uno sgradevole effetto di a hover
http://lnx.liceogiovio.gov.it/sito/it/
vedi prima immagine logo Moodle nel modulo html di sinistra
C'è un modo semplice per rimuoverlo?
GRAZIE:)






Offline maicolstaip

  • Global Moderator
  • Instancabile
  • ********
  • Post: 17623
  • Sesso: Maschio
    • Mostra profilo
    • https://www.hoteledelweiss.net/
Re:Immagini e link
« Risposta #1 il: 24 Feb 2015, 18:53:25 »
Ciao,
dovrebbe essere
sito/templates/accessiblepro/css/BlueBeigeFlat_theme.min.css

linea 2

background-color: #001b72;
Non si risponde a PM tecnici. Postate sul forum. Grazie.

Offline gmassolo

  • Esploratore
  • **
  • Post: 86
    • Mostra profilo
Re:Immagini e link
« Risposta #2 il: 24 Feb 2015, 18:57:31 »
Grazie:)
Ma non c'è modo meno brutale che modificare il css?




ad es posso sperare in un aggiornamento del template che rimuova tale effetto per le immagini con collegamento?
« Ultima modifica: 24 Feb 2015, 18:59:07 da gmassolo »

Offline maicolstaip

  • Global Moderator
  • Instancabile
  • ********
  • Post: 17623
  • Sesso: Maschio
    • Mostra profilo
    • https://www.hoteledelweiss.net/
Re:Immagini e link
« Risposta #3 il: 24 Feb 2015, 19:15:11 »
Scusa ma più semplice di così, non c'è.
poi aspetta qualcun altro che magari ha una soluzione migliore ;)
Ciao!
Non si risponde a PM tecnici. Postate sul forum. Grazie.

Offline maicolstaip

  • Global Moderator
  • Instancabile
  • ********
  • Post: 17623
  • Sesso: Maschio
    • Mostra profilo
    • https://www.hoteledelweiss.net/
Re:Immagini e link
« Risposta #4 il: 24 Feb 2015, 19:18:53 »
Ma la seconda immagine come l'hai inserita?
Lì non c'è l'effetto

Edited: ok sfondo bianco sulla seconda
trasparente sulla prima
« Ultima modifica: 24 Feb 2015, 19:20:42 da maicolstaip »
Non si risponde a PM tecnici. Postate sul forum. Grazie.

Offline gmassolo

  • Esploratore
  • **
  • Post: 86
    • Mostra profilo
Re:Immagini e link
« Risposta #5 il: 24 Feb 2015, 19:27:01 »
Esatto!


Offline elpaso66

  • Moderator
  • Appassionato
  • *****
  • Post: 489
  • Sesso: Maschio
  • Sviluppo siti web e applicazioni
    • Mostra profilo
    • ItOpen.it
Re:Immagini e link
« Risposta #6 il: 25 Feb 2015, 08:10:06 »
Scusa ma più semplice di così, non c'è.
poi aspetta qualcun altro che magari ha una soluzione migliore ;)
Ciao!

Prima di tutto ci va una regola CSS con priorità maggiore sul tag a:hover.

Poi ci sono almeno tre soluzioni migliori:

1. usare un foglio di stile custom e metterci la regola dentro
2. (solo versione PRO) mettere la regola nel form per i CSS personalizzati disponibile nelle opzioni del template
3. se è in un modulo HTML custom mettere la regola come stile inline

... e non verrà corretto in quanto non è un errore. È uno stile applicato a tutti i tag A.

Per lo stile inline:

Codice: [Seleziona]
style="background-color:transparent !important;"
Per la regole override CSS andrebbe messa una classe sul modulo e poi la regola va applicata al tag a:hover.

Offline gmassolo

  • Esploratore
  • **
  • Post: 86
    • Mostra profilo
Re:Immagini e link
« Risposta #7 il: 19 Apr 2015, 21:40:37 »
Scusate se torno sull'argomento, ma ogni volta che inserisco un'immagine con un collegamento ho l'evidenziazione del link anche se non inserisco nessuno spazio tra immagine e immagine.
Visto che vorrei affidare la gestione del sito a personale che non deve preoccuparsi del problema dello sfondo delle immagini (trasparente, bianco o colorato)....chiedo se devo proprio intervenire sul codice.
Grazie comunque a tutti!


Allego immagine
e questo il codice
<div style="background: white;"><a href="http://www.istruzione.lombardia.gov.it/" target="_blank" rel="alternate"><img src="images/loghi/logo_USR_Lombardia.jpg" alt="" width="168" height="109" /><a href="http://www.istruzione.it" target="_blank" rel="alternate"><img src="images/loghi/logo_nuovo-miur.gif" alt="" width="193" height="41" /><a href="http://www.regione.lombardia.it" target="_blank" rel="alternate"><img src="images/loghi/regione_Lombardia.png" alt="" width="139" height="67" /><a href="http://cercalatuascuola.istruzione.it/cercalatuascuola/" target="_blank" rel="alternate"><img src="images/loghi/scuola-in-chiaro.png" alt="" />
« Ultima modifica: 19 Apr 2015, 21:50:08 da gmassolo »

 

Torna su