Joomla.it Forum

Joomla! 3 => Installazione, migrazione e aggiornamento => Topic aperto da: antoniog - 03 Feb 2017, 07:43:25

Titolo: L'accesso Amministratore non avviene
Inserito da: antoniog - 03 Feb 2017, 07:43:25
Ho appena installato Joomla 3.6.5 su spazio web pulito e con nuovo db che Ŕ Maria DB e PHP Ŕ la versione 5.5.32.
Durante l'installazione ho notato che Display Errors era On invece di Off ma l'installazione Ŕ avvenuta senza mostrare alcun errore.
Dopo la cancellazione di /installation ho effettuato l'accesso al back-end ma sembra che il form non sia collegato al db e di conseguenza i miei Username e Password Amministratore non vengono accettati e mi appare il seguente messaggio di errore:

Attenzione Nome utente e password non corretti o non hai ancora un account.


 
Titolo: Re:L'accesso Amministratore non avviene
Inserito da: antoniog - 03 Feb 2017, 07:51:34
Maria DB versione 10.0.29
Titolo: Re:L'accesso Amministratore non avviene
Inserito da: alexred - 03 Feb 2017, 08:44:51
Ciao    antoniog,
puoi tentare di reimpostare i dati di accesso seguendo questa guida:
http://www.joomla.it/articoli-community-16-e-17-tab/7383-come-recuperare-i-dati-di-accesso-al-sito-in-joomla.html

ma se avevi appena installato ti conviene forse cancellare tutto e ripetere l'installazione.
Titolo: Re:L'accesso Amministratore non avviene
Inserito da: antoniog - 03 Feb 2017, 08:57:54
Ciao AlexRed,
purtroppo ho giÓ ripetuto l'installazione.
Prover˛ a leggere l'argomento che mi hai passato.
Titolo: Re:L'accesso Amministratore non avviene
Inserito da: antoniog - 03 Feb 2017, 09:18:07
Ho letto il tuo post ed ho impostato la password indicata ma non funziona.
Avevo notato che le tabelle della precedente installazione non sono state eliminate mentre avevo impostato tale opzione durante l'installazione per ambedue le volte che l'ho eseguita.
Mi Ŕ venuto un dubbio.
Ho installato il sito in modalitÓ fuori servizio.
E' possibile che tale modalitÓ in qualche modo mi possa lasciare fuori anche me come Amministratore considerato che non riesco a logarmi nemmeno nel front-end?
Titolo: Re:L'accesso Amministratore non avviene
Inserito da: antoniog - 03 Feb 2017, 09:42:16
Ho installato nuovamente e per la terza volta Joomla 3.6.5, stavolta in modalitÓ sito pubblicato, ma il problema di non riuscire ad avere l'autenticazione persiste sia lato back-end che lato front-end.
Sembra che il problema si la mancata connessione del modulo di login con il database (Maria DB 10.0.29).
Titolo: Re:L'accesso Amministratore non avviene
Inserito da: antoniog - 03 Feb 2017, 09:58:26
Forse ho risolto.
Il problema sembra proprio Maria DB.
Ho riscontrato che la versione stabile adesso Ŕ 10.1 ed ho chiesto al mio provider di spazio web di eseguire il suo aggiornamento.
Per mettere risolto prover˛ prima ad effettuare il login con Maria Db aggiornato.
Titolo: Re:L'accesso Amministratore non avviene
Inserito da: antoniog - 03 Feb 2017, 14:42:03
Il tecnico del mio provider di hosting mi ha chiesto se ho cambiato il SALT nel file di configurazione.
Ovviamente ho risposto che il file di configurazione non l'ho modificato ed Ŕ vero.
Quindi il problema sembra essere il file di configurazione con SALT errato per la criptazione della password Amministratore.
Qualche volenteroso sa come aiutarmi? Devo pubblicare il sito aziendale altrimenti passo ad altro csm!