Visualizza post

Questa sezione ti permette di visualizzare tutti i post inviati da questo utente. N.B: puoi vedere solo i post relativi alle aree dove hai l'accesso.


Topics - Iluvee

Pagine: [1]
1
Joomla! 3 / Problemi stili css con Google Chrome [RISOLTO!]
« il: 05 Gen 2018, 09:23:10 »
Salve a tutti, dopo essere impazzito per 2 ore e oltre, ho provato a visualizzare la pagina del sito che sto lavorando con Firefox e magicamente funzionava tutto, mentre su Chrome a quanto pare la classe css che ho assegnato proprio non gli piace.
Volevo sapere se c'e' una qualche formula specifica per Chrome per assegnare le classi css.

末末末末末末末末
Per scrupolo, dato che uso Mac Os El Capitan e Google Chrome 63.0.3239.108, ho provato ad aprir la pagina sempre con Chrome su un PC con Winodws 10 e funziona tutto. Quindi a sto punto e' una questione di Chrome sul Mac. Qualcuno ne sa niente o cancello il post e provo a chiedere in un forum Apple, che probabilmente non saro' - credo - il solo ad avere avuto questo "simpatico" problema ?
末末末末末末末末末

Questo il css:

Codice: [Seleziona]
.cont1hsx {
  max-width: 28%;
  margin: 40px;
}


Questo l'html:

Codice: [Seleziona]
<p align="center"><a href="index.php?option=com_content&amp;view=article&amp;id=51&amp;Itemid=155"><img src="images/Lucio/01_home/home3/h02a.gif" alt="Marketing" class="cont1hsx" style="margin-right: 20px; margin-bottom: 10px;" title="Marketing" onmouseover="this.src='images/Lucio/01_home/home3/h02b.gif';" onmouseout="this.src='images/Lucio/01_home/home3/h02a.gif';" onmouseout="this.src='images/Lucio/01_home/home3/h02a.gif';" onmouseover="this.src='images/Lucio/01_home/home3/h02b.gif';" />[/url]</p>

Spero sia una sciocchezza.

Grazie anticipatamente
Lucio


AGGIUNGO QUI IN FONDO LA SOLUZIONE DOVESSE CAPITARE AD ALTRI.
Nel primo menu in alto di Chrome: "Cancella dati di navigazione". Poi riaggiornare la pagina. Evidentemente Chrome e' un po' duro d'orecchi e nonostante il ricaricamento della pagina e' evidente che si tiene "caro" una serie di dati che a mio avviso dovrebbe cestinare nel momento del refresh, boh. Comunque risolto. Se i moderatori ritengono inutile questo post, lo cancello o non so eliminatelo tranquillamente ecco.

2
Salve a tutti, premesso che ho gia' usato diverse volte un file personal.css in altri siti con versioni meno recenti di Joomla, l'ho sempre richiamato come dalla guida "Mini-guida alla personalizzazione del template Protostar" inserendo nell'index.php in riga 51 (ex riga 42) il richiamo:


Codice: [Seleziona]
$doc->addStyleSheet('templates/'.$this->template.'/css/personal.css');

in modo tale risulta:

Codice: [Seleziona]
49   // Add Stylesheets
50   JHtml::_('stylesheet', 'template.css', array('version' => 'auto', 'relative' => true));

51   $doc->addStyleSheet('templates/'.$this->template.'/css/personal.css');




nel file personal.css ho creato una classe molto semplice per fare una prova:
Codice: [Seleziona]
.luciofont {
font-size: 36px;
}


proprio minimale per vedere se funzionava.


ho creato un articolo in cui alla scritta "prova" ho assegnato la classe "luciofont" (provato sia con <p class="luciofont"> sia con <div class="luciofont">


niente.


copiata la classe "luciofont" nel file template.css funziona.
Al che mi sembra ovvio che non carica il file personal.css


Ho visto che in riga 85 c'e' un altro richiamo:

Codice: [Seleziona]
85   // Check for a custom CSS file
86   JHtml::_('stylesheet', 'user.css', array('version' => 'auto', 'relative' => true));


ho copiato anche in riga 87 la stringa
Codice: [Seleziona]
87  $doc->addStyleSheet('templates/'.$this->template.'/css/personal.css');
niente.

Poi leggendo qua e la' in qualche articolo si dice di usare user.css perche' e' gia' integrato e una volta creato lo vede in automatico.

Ho provato con:

user.css
custom.css

niente.

Ho anche inserito all'interno del tag <head> la stringa
Codice: [Seleziona]
<link rel="stylesheet" href="/css/personal.css" type="text/css">
(anche con il percorso completo http:// ecc.)

niente

Qualcuno saprebbe dirmi dove sbaglio?

Pare che veda solo template.css

3
Salve a tutti, ho questo problema che non riesco a risolvere. Ho una serie di articoli che hanno la stessa identica larghezza, ma altezze diverse. Devo visualizzarli in un Blog a 3 colonne. (uso come Template Protostar)
Sia con Ordinamento Verticale sia con Ordinamento Orizzontale il risultato non cambia.
In pratica la prima riga allinea i primi 3 articoli in alto, poi la seconda riga allinea i successivi 3 articoli di nuovo tra loro creando cosi' spazi diversi.
L'effetto che voglio ottenere in pratica e' che, a seconda dell'altezza dell'Articolo, quello che segue vada di seguito e NON si allinei a niente.

Riporto solo come esempio l'allineamento che vorrei ottenere:
http://demo.joomlaplates.com/#BW

Riporto altresi' il codice di esempio di un articolo che ho impostato; ai vari DIV ho assegnato delle classi css per impostare spaziature e colori.

------------codice articolo-----------

<div class="articoliBox_L" style="margin: 0 auto;">
<div class="boxFoto_L" style="width: 180px; height: 120px; margin: 0 auto;"><img src="images/Foto/Ridotte/mosaic-01r.jpg" alt="mosaic 01r" class="zoom1" /></div>
<table border="0" style="margin-top: 5px; width: 180px; height: 94px;" align="center">
<tbody>
<tr>
<td style="text-align: left;">
<div class="testoarticoli_L">Lorem ipsum dolor sit amet, consectetur adipisicing elit, sed do eiusmod tempor&hellip;&nbsp;</div>
</td>
</tr>
</tbody>
</table>
</div>

-------------fine codice-------------

Se qualcuno gentilmente potesse darmi qualche dritta gli saro' molto grato.

Lucio

Pagine: [1]

Torna su