Visualizza post

Questa sezione ti permette di visualizzare tutti i post inviati da questo utente. N.B: puoi vedere solo i post relativi alle aree dove hai l'accesso.


Topics - WhiteTiger

Pagine: [1] 2 3 4 5
1
Joomla! 3 / Un parere sulle voci di Menu
« il: 06 Lug 2016, 09:30:00 »
Un paio di consigli / pareri:

C'è una voce di menu ed un suo sotto menu. Ad esempio:
-Articoli
--- Lista degli Articoli
--- Descrizione di un Articolo in promozione
--- Condizioni Commerciali

Secondo voi, dal punto di vista funzionale/pratico (quindi dal punto di vista dell'utente medio), è meglio che la voce nel menu principale sia:
  • del tipo "Separatore testuale" (e quindi inattiva)
  • alias (nell'esempio alla Lista degli Articoli)
  • Sia essa stessa la Lista (che non appare perciò nel sotto menu)
La seconda domanda è in qualche modo correlata a questa.
Come fate voi con la versione per smartphone? Io ho in automatico la classica iconcina con i tre trattini che apre il menu, ma se fanno tutti come me, non verrà mai aperto. In questo caso nessuno si accorgerà mai che oltre alla voce "Home" c'è ben altro.
Però tutto un menu racchiuso in una iconcina è una gran complicazione.
Grazie in anticipo per i consigli

2
SEO / Problemi con aggiornamento OSMap
« il: 27 Giu 2016, 12:18:54 »
Vi risulta che con l'ultimo aggiornamento di OSMap vi siano dei problemi?

Passando alla 4.0.x (adesso si è aggiornata alla 4.0.3)
  • Sono spariti i plugin, c'è solo quello per il content joomla
  • È sparita la pagina per la descrizione che permetteva così di abbellire la mappa HTML pubblicata sul sito
  • Se il sito è in una cartella, tutti gli URL presenti nel componente (in Edit Link) sono sballati perché viene duplicata la cartella (da dominio/cartella siamo passati a dominio/cartella/cartella)
  • Sempre in questo caso il link XML da passare a Google è sbagliato due volte perché viene duplicata anche la slash iniziale (da dominio/cartella/percorso-osmap siamo passati a dominio/cartella//cartella/percorso-osmap)
Ho provato a disinstallarla ed installarla, ma senza cambiamenti.
Ho provato anche ad installare la versione 3.4.1, ma va in errore sia in backend che in frontend. Probabilmente è cambiata anche la libreria.

Qual'è l'ultima versione prima della 4.0.0?

3
SEO / Inibire indicizzazione ricerche
« il: 27 Giu 2016, 11:27:31 »
In un sito non ci sono nelle pagine moduli per effettuare delle ricerche, eppure Google mi fa la scansione di link del tipo:
 .../component/search/?searchword=FRASE-CERCATA&searchphrase=exact&ordering=newest
 
 Ho controllato e non ci sono neppure moduli per tags o funzionalità simili
I tags vengono usati per classificare gli articoli, ma non c'è alcun modulo pubblicato per visualizzarli, quindi dovrebbero essere visibili solo nel backend.

L'unico punto in cui è permessa la ricerca è in JEvents (non saprei come disattivarla), ma tutte le ricerche riportate da Google nulla hanno a che fare con gli eventi e perciò non credo sia questa la causa.

 Che cosa dunque potrebbe generare questa ricerca?
 
 Dato che questi link mi vengono riportati come duplicati, vorrei eliminare la possibilità che venga effettuata la scansione.
 Pensavo ad esempio ad inserire in robot.txt una stringa con disallow /component/search/?*
 
Oppure disabilitare del tutto le funzioni di ricerca, ma non vorrei che il sistema le utilizzi per altre cose, visto che sono estensioni preinstallate.

 Grazie

4
Joomla! 3 / Ruotare articoli (no slide)
« il: 23 Feb 2015, 08:16:53 »
Devo far ruotare degli articoli in Home Page, non con le classiche estensioni slide, ma l'articolo vero e proprio.


Si tratta di tabelle della medesima altezza, in due colonne ed in ciascuna c'è una immagine con sotto del testo.


Di estensioni per slide ne ho viste e testate a decine, alcune molto carine, ma alla fine fanno sempre la stessa cosa.
Pubblicano una immagine ed una porzione del testo.


Io invece devo mantenere l'impaginazione.
Trasformare le tabelle in immagini è un casino perché quando si rimpiccioliscono il testo viene deformato.


C'è un modo di far ruotare dei moduli?


Grazie in anticipo.

5
Joomla! 3 / Visualizzare Mappe già presenti in rete
« il: 18 Gen 2015, 21:54:26 »
Dovrei visualizzare (in J 3.3.6) una Google Maps di pubblico dominio con già presenti differenti indicatori riferiti a diversi servizi censiti sulla mappa stessa. Per essere chiari non mi riferisco alla Google Maps vera e propria, ma a mappe che si basano su Google Maps, ma già personalizzate e presenti ad altri indirizzi.

Le estensioni che ho visto mi permettono di creare delle mappe, eventualmente aggiungendo i dati dei diversi indicatori, ma non ho trovato nulla che mi permetta di visualizzare una mappa già esistente.

Possibilmente dovrei poter collegare la mappa a dei campi dove digitare l'indirizzo così da centrare subito la località.

Grazie per l'aiuto.

6
Joomla! 3 / Favicon diverse per pagine
« il: 14 Gen 2015, 09:48:34 »
Mamma mia, non mi ricordo più nulla.
Come si fa a mettere favicon diverse per pagine diverse, meglio se per categorie diverse?


C'era un sistema o una estensione, non ricordo bene, per non smanettare con il codice.


Grazie

7
Joomla! 3 / [RISOLTO]Manca lingua Italiana
« il: 14 Gen 2015, 09:07:26 »
Ciao,
Ho installato per la prima volta una versione 3.3.6 direttamente tra i package forniti dal provider.
Joomla mi viene proposto già con la lingua Italiana, infatti tutti i menu sono in Italiano.
Però la lingua dei contenuti è ancora in Inglese.


La devo scaricare ed installare io, o devo aggiungere la lingua nella apposita sezione?


Grazie

8
Joomla! 3 / Accesso utente Publisher ad area amministrativa
« il: 17 Ott 2014, 13:04:15 »

Scusate, ma con la 3.3.6 che diritti bisogna avere per accedere all'area amministrativa?
Devo creare due utenti Author" e "Publisher" che però devono lavorare dal pannello senza ovviamente accedere alla gestione di componenti e così via.


Sono in un ambiente di test nella configurazione standard e quindi con i permessi originari.
Ho fatto diverse prove sui diritti utente e degli articoli, ma al login continuo ad avere il messaggio: "Attenzione. Non hai accesso alla sezione amministrativa di questo sito.
Mi viene il dubbio che stia lavorando su una sezione sbagliata

9
Non so quanti di voi usino CB Connect per il login attraverso i socialnetwork e come abbiano risolto il problema, ma sembrerebbe che si debba necessariamente disattivare il captcha altrimenti si blocca quando si tenta di registrare un nuovo utente.


A questo punto chiedo:
1) C'è qualche altra valida alternativa per far sì che le persone si registrino utilizzando i propri profili su Facebook, Linkedin, ecc. ?
2) C'è qualche altro modo efficace di bloccare la registrazione di bot senza usare il captcha?


Grazie in anticipo

10
Non saprei bene come descrivere il modulo che sto cercando.


Sapete certamente che ci sono delle estensioni che permettono di mostrare più informazioni attraverso tabs oppure attraverso tendine che si aprono in verticale.
Io ne sto cercando una che si apra in Orizzontale, da Sinistra a Destra o viceversa e quindi il titolo va mostrato in verticale.


è da collocarsi nelle posizioni "stick" ai margini della pagina, un po' come il piccolo banner qui a sinistra.
Dentro andrò a collocarci uno o più moduli.


C'è qualche altro modo per realizzare questa funzionalità?




11
Joomla! 1.6/1.7/2.5 / Errore in installazione moduli
« il: 23 Feb 2013, 11:34:49 »
Da tempo non tocco più il server, mi limito a fare gli upgrade segnalati.
Oggi vado per mettere mano ed aggiornare un po' di tutto.


Passo intanto ad aggiornare J. a 2.5.9.
Poi aggiorno il template e mi da un errore.
Siccome è commerciale, apro un ticket.


Poi installo un modulo free e l'errore mi appare lo stesso, questa volta riferito al modulo.


Ci sono dei problemi con l'ultimo aggiornamento di J.?


L'errore è:
Modulo Installa: un altro modulo sta utilizzando la cartella..


[/size]Grazie


12
Gestione utenti e community / Registrazione utenti Spam
« il: 02 Feb 2013, 12:21:32 »
Continuo a vedere registrati utenti Spam e non capisco come mai.
Ho il re-captcha abilitato sia in Joomla 2.5.8 che in CB 1.9, nella gestione utenti di J. c'è "registra=No" ed in CB sì, quindi in teoria dovrebbero tutti registrarsi attraverso CB con tanto di captcha e conferma via email, ed invece è un continuo.


O sbaglio qualcosa io o passano da qualche altra parte.

13
C'è un modo od una qualche estensione che mi permetta di elencare i membri di un gruppo?
Adesso per verificare le ACL devo aprire utente per utente e vedere a quale gruppi appartiene e segnarmeli a parte.



Grazie

14
Editor / Una curiosità su JCE
« il: 11 Set 2012, 09:18:24 »
Scusate, è solo una curiosità.


A che serve nel Gestore di immagini di JCE l'icona "Inserisci" ?
È l'ultima in basso nella colonna di destra del Gestore di Immagini, le icone accanto ai dettagli dell'immagine selezionata..


A me sembra non faccia nulla.


Per la serie: "è per le cose inutili che si perde il sonno".


Grazie

15
Joomla! 1.6/1.7/2.5 / Errori Banner
« il: 20 Lug 2012, 11:59:06 »
Ho notato che il modulo Banner non associa più il banner al tag ed ho segnalato la cosa.


Questa è la correzione suggerita in components\com_banners\models\banners.php


Codice: [Seleziona]
$query->join('LEFT', '#__categories as cat ON a.catid = cat.id');
      if ($cid) {
         $query->where('a.cid = ' . (int) $cid);
         $query->join('LEFT', '#__banner_clients AS cl ON cl.id = a.cid');
         $query->select('cl.track_impressions as client_track_impressions');
         $query->where('cl.state = 1');
      }

Il problema è che così facendo adesso non visualizzo più i banner nella posizione debug.

Un secondo problema è nel backend alla voce del menu Risultati perché quando la richiamo riporta l'errore 500 alla pagina /administrator/index.php?option=com_banners&view=tracks
La cosa strana è che a volte i risultati sono stati forniti, ma sono casi veramente rarissimi mentre per lo più ottengo l'errore.

Le due cose le ho risolte nel primo caso inserendo il codice che mi interessa visualizzare in un modulo CustomHTML ed il secondo... semplicemente tirando su di spalle ed aspettando che venga corretto il bug.

16
Scusate, ma che cosa genera questo URL?
http://www.MioDominio.it/#.UAUv-hV0l2M


Non mi ricordo se era il mod_rewrite nella configurazione generale o che cos'altro.


Grazie

17

Scusate, ma anche voi rilevate delle incongruenze con la 2.5.6?Con la 2.5.5 non ne ho rilevate forse per il solo fatto che il successivao aggiornamento è stato pressoché immediato, ma da quando ho la 2.5.6 su un sito in produzione un banner flash non viene più caricato ed un nuovo banner in rotazione con un altro non appare mai (uso il modulo standard).
Con una installazione nuova di pacca, senza altro aggiunto, in chrome se apro le opzioni (ad esempio quelle degli articoli, non mi appare la solita finestra, ma vanno a tutta pagina, il tasto annulla non funziona e se premo salva-chiudi continua a cercare il portale, ma non si chiude mai.
In Firefox non succede (ovviamente cache ripulite)

In entrambi l'anteprima delle immagini nel modulo banner riporta
JLIB_FORM_MEDIA_PREVIEW_TIP_TITLE
e se premo il pulsante per selezionare le immagini non se ne vedono da nessuna parte.
Questo accade anche nel portale in produzione.

C'è da attendere una 2.5.7?
===========
Note dell'ultima ora.

Ho provato ad installare una versione 2.5.4 ed il problema non c'è, quindi confermo che per quanto mi riguarda la 2.5.6 crea problemi nell'accesso alla libreria delle immagini.

Qualcuno mi sa dire come sia possibile fare un downgrade dalla 2.5.6 alla 2.5.4?
Non credo basti copiare i files perché qualcosa viene fatto anche a livello di DB, o sbaglio?


18
Joomla! 1.6/1.7/2.5 / Esclusione JED. Dove decidono?
« il: 27 Apr 2012, 08:30:57 »
Ho scaricato ed installato da JED una componente, tra le più quotate e popolari della sezione.
Dopo nemmeno due settimane scopro che è fuori da JED per USR9 Licensing Restriction.

Dove è che lo decidono e dove sono le motivazioni?
La segnalazione rimanda semplicemente ad una pagina generica dove, in questo caso, si raccomanda di verificare con lo sviluppatore la protezione dei diritti.
Ovviamente lui casca dalle nuvole.

Io immagino che se ne sia parlato in qualche forum pubblico, non che uno si sia svegliato alla mattina e l'abbia segato via. Tanto più che è su JED da almeno un paio d'anni.

Tra l'altro per avere tutte le funzionalità ho pagato la versione completa e la cosa mi scoccia non poco.

19
Installazione pulita, alla prima estensione installata ecco questo errore:
constant() [function.constant]: Couldn't find constant JPATH_ in /home/MIOSPAZIO/domains/MIOSITO.it/public_html/libraries/joomla/installer/adapters/module.php on line 117
Che cosa è e da che cosa dipende?
Parametri in J? L'hosting? Oppure dalla estensione?
Grazie

20
Joomla! 1.6/1.7/2.5 / Inserire script
« il: 24 Apr 2012, 12:16:45 »
Scusate, ma come si inseriscono gli script in J2.5?


Io avevo un banale script per chiudere la pagina dopo pochi secondi e non mi va, così come quello per il contatore ShiyStat in un modulo.
Ho visto la guida per installare Jumi ed ho inserito il codice qui sotto, ma non lo salva.


Sono poco propenso ad attribuire il problema al server, come mi dice Toni.

Codice: [Seleziona]

<!-- Inizio Codice ShinyStat -->
<script type="text/javascript" src="http://codice.shinystat.com/cgi-bin/getcod.cgi?USER=MioIDUser"></script>
<noscript>
<a href="http://www.shinystat.com/it" target="_top">
<img src="http://www.shinystat.com/cgi-bin/shinystat.cgi?USER=MioIDUser" alt="Statistiche" border="0" /></a>
</noscript>
<!-- Fine Codice ShinyStat -->


Il codice per la pagina è invece questo:
Codice: [Seleziona]
[left][font=courier new]<script language="javascript" type="text/javascript">[/font][/left][left][font=courier new]document.write("<META HTTP-EQUIV='Refresh' CONTENT='3;URL=http://www.MioSito.it'>");[/font][/left]

Pagine: [1] 2 3 4 5

Torna su