Visualizza post

Questa sezione ti permette di visualizzare tutti i post inviati da questo utente. N.B: puoi vedere solo i post relativi alle aree dove hai l'accesso.


Topics - Dieda12

Pagine: [1] 2
1
Ciao a tutti,

Ho acquistato un dominio (non cito il provider, ma very low cost) http://www.e-cenacchi.it con redirect su una sottocartella di un mio sito in Joomla 1.5 http://www.cenacchieditrice.it/e-cenacchi.

Il redirect funziona correttamente ma non riesco a settare il file .htaccess in modo che, quando arrivano delle richieste per la sottocartella (che contiene solo una pagina e la sua descrizione in inglese, + css e immagini, in pratica tipo landing page) l'indirizzo venga modificato
da: www.cenacchieditrice.it/e-cenacchi
a: www.e-cenacchi.it

Ho lasciato inalterato il file .htaccess nella root di Joomla e ne ho creato uno nella cartella e-cenacchi con il seguente codice:

Codice: [Seleziona]
RewriteCond %{HTTP_HOST} ^(www\.)?cenacchieditrice\.it [NC]
RewriteCond %{REQUEST_URI}!^/e-cenacchi/
RewriteRule ^(.*)$ http://e-cenacchi.it/$1 [R=301,L]

Ma ottengo solo un errore 500

Ho provato con
Codice: [Seleziona]
RewriteCond %{HTTP_HOST} ^(www\.)?cenacchieditrice\.it [NC]
RewriteRule ^(.*)$ http://e-cenacchi.it/$1 [R=301,L]

E in questo caso ottengo esattamente la trasformazione che vorrei, cioè nella barra compare www.e-cenacchi.it, ma la pagina dà errore: "Firefox ha rilevato che il server sta reindirizzando la richiesta per questa pagina in modo che non possa mai essere completata. - Questo problema spesso è causato dal blocco o dal rifiuto dei cookie.". Secondo me è perchè con la riscrittura dell'indirizzo viene forzato un nuovo redirect, con loop.

Così ho provato questo, con l'idea di fare una semplice sostituzione testuale:

Codice: [Seleziona]
RewriteCond %{HTTP_HOST} ^(www\.)?cenacchieditrice\.it [NC]
RewriteRule ^cenacchieditrce\.it\/e-cenacchi$  e-cenacchi.it [R=301,L]

Nessun errore, ma nessuna riscrittura, mi ritrovo al punto di partenza  :(

Qualcuno sa darmi una dritta su come fare?

Grazie

Elena

2
Ciao a tutti,

Sapete se è possibile impostare il modulo rosproket (quello che mi pare sia pubblicato in  home page di joomla.it) collegandolo a facebook invece che a Google+ ?

Mi piacerebbe un modulo che mostrasse gli ultimi messaggi pubblicati su facebook (solo testuali, senza foto, immagini del profilo, ecc...), ma le opzioni disponibili per lla creazione del badge fbook ufficiale sono ben poche, e non riesco a eleminare il logo facebook (lo sostituirei con una f piccolina) senza eliminare anche l'import dei messaggi.
Andrebbe bene anche un modulo collegato a twitter se non a facebook.

Sulla JED trovo moltissimi moduli sull'integrazione dei social, ma sembrano tutti orientati all'integrazione delle icone per fare sharing.

Grazie per gli eventuali suggerimenti

Elena

3
Ciao a tutti,

Sto cercando un plugin gratuito per Joomla 2.5 che apra la gallery in un finestra pop-up e consenta la rotazione (anche solo per step di 90°) e lo zoom delle singole immagini.

Per progetti più semplici (che non necessitano delle due opzioni che cerco), in genere utilizzo SigPlus e mi trovo molto bene.

Qualcuno ha suggerimenti ?

Grazie

Elena



4
Ciao a tutti,

Vorrei personalizzare la vista blog con un'ancora in corrispondenza di ciascun titolo di articolo. Sto cercando di seguire il consiglio di questo post:

http://forum.joomla.org/viewtopic.php?p=2350748

Tuttavia non riesco a recuperare il valore di keyref all'interno di blog_item.php.
Saltando il ciclo if, e inserendo prima di <h2> la seguente riga:

Codice: [Seleziona]
<a name="<?php ($this->item->params->get('keyref')) ?>"
Il browser mi restituisce:

Codice: [Seleziona]
<a name="">
Nonostante abbia inserito del testo nel campo "Reference Key" (Riferimento chiave) di tutti gli articoli.

Come si può recuperare questo valore ?

Grazie

Elena

[/code]

5
Joomla! 1.6/1.7/2.5 / Estensione Joomla! per gestione archivi
« il: 20 Set 2012, 10:53:59 »
Ciao a tutti,

Vorrei sapere se esiste un'estensione di Joomla! per la gestione degli archivi, in particolare degli archivi storici. Ho visto che nel post delle estensioni questa funzionalità non è elencata.

L'estensione dovrebbe essere in grado di mostrare i metadati delle unità documentali salvati in apposita tabella del database. Idealmente l'utente dovrebbe poter creare una nuova unità inserendo i metadati in un form che sia conforme a uno standard (ad esempio EAD), oppure fare un'operazione massiva importando un file xml dall'opportuna struttura (sempre EAD).
L'estensione dovrebbe essere dotata di un modulo-menu ad albero che mostri la struttura dell'archivio (in pratica un menu standard di Joomla! che invece che alla vista-articolo punti alla vista-elemento), un modulo di ricerca avanzata che punti sulla tabella dei metadati, e una vista-elemento (una semplice tabella con i metadati esposti ordinatamente, e con una thumbnail che eventualmente punti a una gallery per sfogliare l'elemento digitale associato, se esiste).

Idealmente dovrebbe essere possibile anche esportare la tabella di metadati in formato XML, sempre secondo lo standard scelto.

Sto testando un progetto open-source che realizza queste cose (ICA-Atom 1.3), tuttavia devo ammettere che non è semplice personalizzare il front-end e in generale il sistema (basato sul framework Symphony) non è molto user-friendly. Al momento, che io sappia, ICA Atom è l'unico progetto internazionale e open-source che vada in questa direzione.

Mi chiedevo se esista un progetto analogo per Joomla!, o se ci sia una qualche controindicazione nel cercare di utilizzare Joomla! in questo ambito, considerando che l'ampia disponibilità di template (gratuiti e non), estensioni, supporto, ecc... lo rendono secondo me lo strumento ideale per esporre dati on-line (anche quando non si tratta propriamente di "articoli per blog").

A presto

Elena


6
Ciao a tutti,

Sto utilizzando il modulo "imagemenu" per realizzare un menu a immagini, che vorrei rispecchiasse l'ordine delle voci di menu assegnato da backend.
Il codice fa una query Sql sulla tabella #_menu di tipo SELECT che termina con "ORDER by ordering".

Il problema è che, indipendentemente da come si agisca a livello di backend sull'ordine delle voci di menu (freccine, numeri inseriti manualmente, clic su icona a dischetto, ecc...), il valore "ordering" all'interno della tabella #_menu rimane sempre = 0.

Ho notato che questo accade per tutte le voci di tutti i menu, tuttavia, evidentemente, il modulo standard di Joomla! recupera l'ordinamento in modo diverso, perchè il problema si presenta solo con il menu assegnato al modulo imagemenu, che d'altronde effettua una query corretta.

Infatti:

1) Se inserisco manualmente il valore di "ordering" via phpmyAdmin, le voci di menu vengono mostrate correttamente (però è un sistema un po' scomodo).
2) Se modifico "ORDER BY ordering" con "ORDER BY title" le voci vengono mostrate correttamente in ordine alfabetico.

Quindi si tratta di un problema nella scrittura del valore "ordering" all'interno della tabella #_menu.
Qualcuno ha suggerimenti in merito ? Magari c'è una qualche patch che risolve il problema ?

Grazie

Elena

7
Ciao a tutti,

Joomla 1.7, Beez 20:  http://www.grandeslam.net

All'improvviso da un paio d'ore le colonne in home page (e solo in home page) si comportano in modo strano. La seconda colonna si sotto-divide in ulteriori due colonne. Risultato:

Settaggio home page,da menu, 2 colonne = ne risultano 3
Settaggio (di prova) home page 3 colonne = ne risultano 5 (all'interno della seconda e della terza si infilano due sottocolonne aggiuntive.

Tutto il resto del sito si comporta correttamente.

Ho provato a sovrascrivere i file contenuti in com_content/views/featured/tmpl ma niente da fare.
Non capisco se sia un virus o un malfunzionamento (strano però) dell'hosting.
Nel primo caso, quali altri file dovrei sovrascrivere per tornare alla normalità ? Ho una copia di backup ma un po' datata e preferire non sovrascrivere tutto il sito.

Grazie per eventuali suggerimenti

Elena

8
Ciao a tutti,

Utilizzo per un sito Joomla 1.7 e, per gestire i commenti, UdjaComments.
Vorrei visualizzare il numero di commenti di seguito ai parametri dell'articolo (categoria, autore, visite, ecc...) e non alla fine dei contenuti.

Premessa:

Il numero di Commenti non è un valore salvato in una tabella, ma viene ottenuto dalla funzione getNumComments presente nel file udjacomments.php (directory plugins/content/udjacomments/). La funzione fa un parsing della tabella jos_udjacomments per article_id, conta quanti commenti ha un articolo e restituisce il valore.
All'interno di udjacomments.php la funzione viene richiamata, all'interno di 

Codice: [Seleziona]
function onContentAfterDisplay($item, &$article)
e l'output è salvato nella variabile $count, richiamato in $CommentCountString e mostrato attraverso

Codice: [Seleziona]
$content = '<p class="articleMeta"><a href="'.$url.'#frmUdjaComments" class="commentCount" title="'.$commentCountString.'">'.$commentCountString.'</a></p>';
Adesso io vorrei copiare la funzione e utilizzare il valore restituito all'interno di com_content/views/category/tmpl/blog_item.php e di com_content/views/article/tmpl/default.php (la visualizzazione standard alla fine dei contenuti la posso disabilitare, per evitare di riportare il dato due volte).

Personalizzare lo stile dell'output non è un problema, ma dove posso mettere la funzione per poterla utilizzare e visualizzare i valori $count o $CommentCountString (insomma, il numero di commenti) assieme agli altri parametri ?

In alternativa, come posso fare per salvare il valore restituito dalla funzione in udjacomments.php in una variabile che sia utilizzabile anche nei file di com_content ?

Spero di essermi spiegata.
Grazie per eventuali suggerimenti.

Elena

 

9
Joomla! 1.6/1.7/2.5 / Recuperare feed rss
« il: 03 Nov 2011, 11:33:40 »
Ciao,

Ho attivato sul sito http://www.associazionegliaquiloni.it (Joomla 1.7 su joomlafree) il modulo Generatore Feed, facendo le opportune correzioni segnalate sulla Wiki (http://docs.joomla.org/1.7.0_Syndication_module_broken )perchè questo apparisse correttamente.

Se clicco sul link generato approdo alla pagina http://www.associazionegliaquiloni.joomlafree.it/index.php?format=feed&type=rss dove in effetti vedo i feed della home page.

Però, se provo a fare un abbonamento con iGoogle, non riesco a visualizzare nessuno dei feed. Ho anche provato a recuperarli su un altro sito in locale (Joomla 1.5) tramite un modulo commerciale apposito, già attivo in altre posizioni e funzionante con feed di altri siti), ma niente, in questo secondo caso mi appare il modulo vuoto (solo per i feed da Joomla 1.7, gli altri attivati in precedenza non danno problemi) e l'avviso "Errore nel caricamento dati feed".

Qualcuno sa dirmi la procedura corretta per recuperare i feed generati dal modulo ?

Grazie

Elena

10
Ciao a tutti,

Vorrei modificare il modulo "Chi è on-line" perchè mostrasse solo il numero di vistatori. Il sito www.associazionegliaquiloni.it non prevede al momento la registrazione degli utenti e quindi si visualizza sempre la scritta "Ci sono N visitatori e nessun utente on-line".

Io vorrei eliminare "e nessun utente on-line".

Dai parametri nel backend non sembra possibile dividere i due elementi (guest e user).

Ho provato a modificare il file /tmpl/default.php all'interno della cartella module/mod_whosonline ma se cambio banalmente da così:

Codice: [Seleziona]
<p><?php echo JText::sprintf('MOD_WHOSONLINE_WE_HAVE'$guest$member); ?></p>

a così:


 
Codice: [Seleziona]
<p><?php echo JText::sprintf('MOD_WHOSONLINE_WE_HAVE'$guest); ?></p>

Mi compaiono una serie di errori all'interno del modulo.

Qualcuno mi può dare una mano ?

Grazie

Elena

11
Ciao a tutti,

E' da qualche mese che non scrivo sul forum, però ho continuato a seguirlo saltuariamente e intanto mi sono impratichita un po' :-)

Di recente mi sono però imbattuta in un problema che non riesco a risolvere. Ho reso scalabile la grafica del portale che amministro www.arenasportiva.it, template Beez, ma quando aumento/diminuisco la dimensione del carattere, usando i comandi in alto a destra, il pulsante di ricerca (modulo search di default) non ne vuole sapere di scalare. Ho provato sia con il pulsante semplice che con il pulsante immagine (soluzione attuale) ma il problema persiste: pur assegnando le dimensioni in em, queste rimangono fisse mentre tutto il resto scala.

Ho anche provato a cambiare le impostazioni del file php, utilizzando un tag <button> piuttosto che il tag <input> e applicando poi le dimensioni via css, ma la situazione non cambia.

Qualcuno ha qualche suggerimento ?

Grazie anticipatamente

Elena


12
I Template di Joomla 1.5.x / Main e Main2 in Beez CSS
« il: 26 Feb 2010, 17:14:17 »
Ciao a tutti,

Scusate, qualcuno di voi che conosce il position.css di beez mi potrebbe dire che differenza c'è tra:

.main
.main2
.blog

Mi sembra che main2 sia la div che rappresenta la "colonna" centrale nella home page, ma poi nel file quando si passa ai contenuti (article_column, article_row, ecc...) la riga di commento riporta "main".

Inoltre in index.php c'è scritto:

Codice: [Seleziona]
<div id="<?php echo $showRightColumn 'main2' 'main'?>">


Che si chiude con un:


Codice: [Seleziona]
</div><!-- end main or main2 -->

Del php ho solo una conoscenza molto superficiale, in pratica sono a un livello puramente intuitivo (per ora)...e quindi non capisco la necessità di avere sia main che main2.

Il sito che descrive beez poi è molto scarno (http://www.joomla-beez.com/) e, a questo proposito, vorrei anche chiedervi se conoscete dei riferimenti per delle guide aggiuntive su questo template (anche in inglese andrebbero benissimo).

Grazie

Elena

13
Ciao a tutti,

Sono alle prese con un problema legato a un modulino Joomleague.
Quando lo abilito in posiziona left o right nel template beez del mio sito, questo mi va a spostare anche gli elementi che gli sono intorno. Ovvero:

In posizione left: tutto il contenuto delle colonne centrale e destra si sposta in basso, al livello "base" del modulino.
In posizione right: la colonna centrale rimane invariata ma i moduli sottostanti si "disassano" in qualche modo.

E' come se ci fosse qualcosa che "deborda" sulla destra e che fa spostare tutto il resto. Ho provato con firebug ma non riesco a capire cosa sia.

Ho ristretto il contenuto da codice php:

Codice: [Seleziona]
<table width="86%" align="center" border="0" cellpadding="0" cellspacing="0">
Prima era width=96% e cellpadding="3"

Ho ridotto le dimensioni delle iconcine:

Codice: [Seleziona]
echo '<img src="'.$match->away_logo.'" width="11"/>&nbsp; ';
Prima era width="21"


Il modulino è associato a una div nel file general.css così definita:

Codice: [Seleziona]
div.lastmatch{
margin-left:10px;
float:left;
}


E così facendo mi ritrovo la tabellina, rimpicciolita, correttamente posizionata in left, ma...niente da fare, tutti gli articoli centrali e i contenuti di right sono sempre spostati in basso, alla linea di base del modulino.

Al momento il modulino è disabilitato perchè la resa è proprio brutta, ma se qualcuno ha voglia di dare un'occhiata posso riabilitarlo.

Grazie per tutti i possibili suggerimenti !

Elena

14
Ciao a tutti,

Ho installatao Linkr, componente e plugin, inclusi i due rispettivi pacchetti per la traduzione in italiano.

Tutto funziona bene, ma, prima della lista di link, mi continua ad apparire "Related Articles", mentre preferirei un "Vedi anche" o simile.

Qualuno mi sa dire cosa posso fare per cambiare questa scritta ? Per ora ho provato ad aggiungere al file it-IT.ini una riga con RELATED_ARTICLES=Vedi anche (ho provato sia con underscore che senza), ma non è cambiato nulla.

Grazie per i suggerimenti

Elena

15
Sezione dedicata ai Server / [RISOLTO]Categorie Scomparse
« il: 03 Feb 2010, 10:56:09 »
Non potendo aggiornare il post precedente, vorrei solo far presente che in seguito alla segnalazione fatta al servizio di hosting, relativa al seguente errore:

Warning: Invalid argument supplied for foreach() in /components/com_content/models/category.php on line 337

Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in /libraries/joomla/database/database/mysql.php on line 344

Non ho ricevuto alcuna risposta ma adesso il sito funziona di nuovo correttamente.
Siccome cercando in Google questo errore non sono riuscita a trovarne la definizione, ed essendo coinvolto un provider a pagamento la richiesta di delucidazioni qui é stata cassata, vorrei solo far presente a chi dovesse ritrovarsi con lo stesso problema che questo non é evidentemente relativo all'installazione Joomla ma alla dinamica server/database, che, in caso di servizio hosting, non é di competenza dell'utente.

In altre parole: prima di "smanettare" sulle tabelle nel database, a rischio di errori ulteriori, meglio inviare una segnalazione ai gestori del server.

Saluti

Elena


16
Ciao a tutti,

Stasera all'improvviso, provando ad accedere alle categorie del mio sito (www.arenasportiva.it) ricevo il seguente errore:

Warning: Invalid argument supplied for foreach() in /components/com_content/models/category.php on line 337

Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in /libraries/joomla/database/database/mysql.php on line 344

Da backend tutto risulta a posto (section manager, category manager, menu). Da front-end invece dal main menu, clikkando sulle sezioni, i sotto-menu che puntano alle categorie sono scomparsi. Mi sono rimasti i link solo nell'intestazione degli articoli, e lí clikkando sulle categorie arrivo all'errore di cui sopra.

Anche la visualizzazione delle Sezioni non é quella corretta (ma almeno queste sono visibili): gli articoli appaiono ordinati in modo strano, e non in ordine di data di pubblicazione (dal piú recente), come prima (e come settato nelle corrispondenti voci di menu).

Cosa succede ?!?! Fino a stamattina funzionava tutto benissimo, e oggi non sono stati fatti cambiamenti...

Tre giorni fa ho installato il componente Event Table Edit, senza avere particolari problemi...comunque adesso ho provato a disinstallarlo ma non é cambiato nulla.

Ho anche messo su "No" le voci corrispondenti a: SEF, mod_rewrite e suffix to URL. Ma niente da fare.

Qualcuno gentilmente mi puó aiutare ? Il sito cosí é quasi completamente fuori uso...  :(

Grazie

Elena

17
Ciao a tutti,

Mi chiedevo se é possibile visualizzare il Main Menu anche in sezioni e categorie che non sono elencate nel menu.

Ho creato un menu aggiuntivo in posizione "right" della home page www.arenasportiva.it. Per ora contiene una sola voce "Video Gallery".

Clikkando su Video Gallery si arriva alla sezione corrispondente, ma nella sezione non é presente il modulo Main Menu. Nel Module Manager alla voce Menu Assignment ho selezionato "All".
Per intenderci, ho selezionato la stessa cosa per il modulo "FacebookFanPage" che infatti vedo su tutte le pagine del sito. Mentre il Main Menu...sembra legato al suo contenuto...oppure sto sbagliando qualcosa io ?

Grazie per gli eventuali suggerimenti.

Elena

18
Ciao a tutti,

Sto facendo qualche prova per personalizzare il pulsante "Commenta" alla fine degli articoli (Beez + JoomlaComment, www.arenasportiva.it).
Ho modificato l'icona e lo stile del testo (classe readon nel file layout.css)e ho tolto le scritte "Commenta" (file italian.php nella directory /language in /joscomment). Peró, ho 1 problema che non riesco a risolvere e 2 modifiche aggiuntive che non so come fare. Parto dal (penso) piú semplice:

1) Per cambiare il colore del testo e l'effetto hover ho modificato le seguenti:

#main a.readon,#main2 a.readon -> stile "Commenta" articoli in colonne

main a.readon:hover,#main2 a.readon:hover,#main a.readon:active,#main2 a.readon:active,#main a.readon:focus,#main2 a.readon:focus -> effetto hover in colonne

#main .leading .readon,#main2 .leading .readon -> stile "Commenta" articolo leading.

Ecco, peró, l'effetto hover sull'articolo leading non funziona come dovrebbe, il carattere non diventa bianco. Nel file layout .css tutti gli hover sono uguali (da testo nero sfondo bianco -> testo bianco e sfondo verde). In leading peró l'effetto hover modifica solo il background. Anche usando firebug non sono riuscita a capire perché il testo non cambi colore.

2) Vorrei che il numero di commenti apparisse senza le parentesi. Ho guardato il file comment.class.php e ho trovato il seguente codice:


Codice: [Seleziona]
/**
 * creates the write more( Number of comments) button
 * and generated the comment preview
 * @return html
 */
    function insertCountButton()
    {
        $address = $this->_comObject->linkToContent( $this->_content_id );
$number = $this->countComments();

        $html = $this->_readon;

        /* {READON_xxx} */
        $html = str_replace('{READON_LINK}', $address , $html);
$html = str_replace('{READON_WRITE_COMMENT}', _JOOMLACOMMENT_WRITECOMMENT, $html);
$html = str_replace('{READON_COUNT}', $number, $html);
$html = str_replace('{READON_COMMENTS}', $this->comments($number), $html);


Non riesco peró a capire come togliere le parentesi intorno a READON_COUNT.

3) Mi piacerebbe spostare icona e numero di commenti in alto a destra (adesso é in basso a destra), ad esempio sulla stessa linea del nome di sezione e categoria ma allineato a destra.


Qualcuno ha suggerimenti su come risolvere il punto 1 e come procedere per i punti 2 e 3 ?

Grazie 1000

Elena
 

19
Ciao a tutti,

Vorrei provare a togliere il "continua" (pur mantenendo la vista intro-text) dagli articoli sul nostro sito www.arenasportiva.it, e rendere clikkabili i titoli.

Uso "beez". Sono andata in Article Manager -> Parameters e ho impostato "Title Linkable" su Yes. Funziona in sezioni e categorie, ma non nella home page  :o

Mi sento che sará una sciocchezza...peró non la trovo...qualcuno ha suggerimenti ?

Grazie 1000

Elena

20
Ciao a tutti,

Ho installato l'estensione Facebook Fan Box sul sito dell'Arena Sportiva (www.arenasportiva.it template beez), e, tanto per cambiare, tutto funziona bene con Firefox mentre ho un problemino con Explorer 7.

Vorrei che in IE il pulsante "Diventa fan" (o "Become fan", non so perché a volte compaia in inglese e a volte in italiano, sia in Firefox che in IE) fosse della stessa larghezza che in Firefox.

Ho cercato con firebug (che peró so usare poco) e ho modificato nel css (un file dal nome strano che non so bene dove risieda) la larghezza della classe UIButton_Gray, peró IE mi ignora! Ho fatto qualche prova di "allungamento-restringimento" ma i vari width= mi vengono considerati solo da Firefox.

Qualcuno gentilmente saprebbe dirmi dove posso definire la larghezza del pulsante, cosí che anche IE la rispetti ?

Grazie 1000.

Elena


Pagine: [1] 2

Torna su