Visualizza post

Questa sezione ti permette di visualizzare tutti i post inviati da questo utente. N.B: puoi vedere solo i post relativi alle aree dove hai l'accesso.


Post - paoloholzl

Pagine: [1] 2 3 4
1
Gestione utenti e community / Captcha per Community Builder
« il: 15 Mag 2018, 09:52:58 »
Al momento della registrazione volevo immetterne uno.
Tra le varie cose che ho trovato ho trovato un post interessante:

Adding reCaptcha to Community Builder registration page:
  • First of all, you'll need to set reCaptcha Public and Private Keys in Community Builder Profile Pro Configuration. Click Options in profile types view.
    On the Configuration screen select reCAPTCHA, enter Public and Private Keys for your domain from your reCAPTCHA account and save.
  • Open the profile type you want to edit. Scroll down to registration page text area and place the cursor at the point where you want to add reCAPTCHA challenge. Click the Magic Window button at the bottom of the text editor.
  • In the Magic Window open tab CB tab, select reCaptcha in the list of elements and click Insert.
Già, cercando di capire da questa spiegazione che sintetica è dir poco, diciamo che ho un rechaptka registrato con le due chiavi.
Nei componenti vado nel 'filed management' ed aggiungo un campo text field e questo cercavo sto benedetto 'Magic Window button'. E qui mi sono arenato ...

Un altro proponeva di inerire un messaggio ad esempio 'quanti sono i sette nani' in cui rispondere con un numero, per poi testarlo con una riga di python scritta dentro ad un campo testo .. ma ovviamente senza alcun esempio.
Qualche idea?

2
Visto che mi ritrovo un sito in cui non riesco a procedere all'aggiornamento automatico e ho la 3.8.3.
Dapprima pensavo fosse un errore nella definizione della tmp e del log e relativi permessi ed invece lì non ho avuto problemi (spesso questo è il problema).
Ho provato a settare quelli di un altro sito sotto la stessa macchina che non dà problemi, cambiato niente.
L'errore che ottengo è a dir poco 'originale', ERROR: Invalid login. (di cui ho letto qualcosa)
Non posso installare 'da file' in quanto il php non mi consente di uploadare un file così grande.
A questo punto ho uploadato l'upgrade in una directory.

C'è modo di far pare l'aggiornamento a partire da lì?
Qualche altra idea? (tralascio l'ipotesi della sovrapposizione via FTP che non mi sembra più praticabile da quyello che ho letto).

3
A seguito di un disastroso aggiornamento su un server in cui i diritti sulle cartelle erano sbagliati, ho dovuto per la gran parte ricostruire un sito traslando alcuni dati tra un DB vecchio corrotto ed un nuovo.

Finalmente tutto Ok, unicamente mi ritrovo sotto la voce del back-and 'Componenti' delle voci 'balorde' che in realtà puntano a vecchi menu inesistenti.
Infatti se ci clicko su ottengo errore 500.
Volevo ripulire i record 'errati' che compongono tale menu, in che tabella del DB li trovo?

4
Joomla! 3 / SOLVED: Problema cache che non sembra scadere mai
« il: 10 Mag 2017, 10:12:31 »
Alla fine mi sono chiesto se il provider (Bluehost) magari ci metteva del suo.

L'ho contattato e mi ha detto effettivamente che gestiva lui una cache sul server.
Non oso pensare che politiche di caching avevano impostato se forzando una lettura dal browser con control-aggiorna la cache non viene aggiornata.
Dopo due giorni la cache non era ancora stata refreshata.

Bah ... ora è risolto, grazie

5
Joomla! 3 / Re:Problema cache che non sembra scadere mai
« il: 09 Mag 2017, 14:27:47 »
Cambiato il codice non è cambiato nulla.
Ho creato un nuovo articolo con il contenuto nuovo e collegato al menu quello vecchio idem.
Ho disattivato gli articoli idem con il control-aggiorna spariscono ma entrando normale rimangono.
Che ci sia una cache gestita dal provider?

6
Joomla! 3 / Re:Problema cache che non sembra scadere mai
« il: 09 Mag 2017, 07:47:26 »
Ecco inserisco il codice dell'articolo qui sotto

Codice: [Seleziona]
<p style="text-align: justify;">

<a href="images/1_Giove.pdf">
<img src="images/1_Giovedì_.jpg" alt="1 Giovedì " width="159" height="159" />
</a>

<a href="index.php/grestb">
<img src="images/Grest_2017_Icona.jpg" alt="Grest 2017 Icona" width="159" height="159" style="margin-left: 10px;" />
</a>
</p>

<div>
<a href="images/volantino_festa_comunita_2017.pdf">
<img src="images/Comunita_In_Festa_2017.jpg" alt="Comunita In Festa 2017" width="159" height="159" />
</a>&nbsp;

<a href="images/Lettera_Web_Site_2017.pdf">
   <img src="images/Sottoscrizione.jpg" alt="Sottoscrizione" width="159" height="159" style="margin: 10px;" />
</a>
</div>

<div>
<a href="https://www.facebook.com/sambefe?fref=ts">
<img src="images/Facebook%20Parr.jpg" alt="Facebook Parr" width="100" height="100" style="margin: 5px;" border="0" />
</a>

<a href="https://www.facebook.com/Oratorio-SambeFe-672459416208651/timeline/">
<img src="images/Face.jpg" alt="Face" width="100" height="100" style="margin: 5px;" border="0" />
</a>
<a href="https://www.instagram.com/"><img src="images/Instagram.jpg" alt="Instagram" width="100" height="100" style="margin: 10px 10px 5px;" />
</a>
</div>

<p>&nbsp;</p>
<p>&nbsp;</p>

7
Joomla! 3 / Re:Problema cache che non sembra scadere mai
« il: 08 Mag 2017, 19:47:31 »
Vedi messaggio successivo (ma non è possibile cancellare un post?)

8
Joomla! 3 / SOLVED: Problema cache che non sembra scadere mai
« il: 08 Mag 2017, 18:36:38 »
Non capisco perchè, sul sito www.sambefe.it se entro vedo nella home page 2 icone.
Ma se faccio control-F5 ne vedo 4 (la vera situazione aggiornata).

Pensavo che fosse questione di cache del browser, rientrando però me ne ritrovo nuovamente due.
Questo problema lo fa da browser diversi.
Dentro Joomla la cache è disabilitata.
Cosa posso fare?

9
Ho capito che bisogna scaricarsi il file, e ce l'ho  plug_language_italian ..... 2.7.1.0.0.zip
Dato che dicono non va installato come normale plugin Joomla ma va aggiunto tramite la voce di menu plugin management di
Community builder.
Non ho però nella versione 2.0.15 uno 'sfoglia' ma vedo i plugins sotto, per cui immagino vada postato via FTP in una directory che lo vede.
Se è così, come cavolo si chiama questa directory?
Ho ravanato tanto in rete e ho trovato mille spiegazioni ma non una che dicesse dove va messo.

10
Il calderone dei template / Re:td_optes_free_3.5.2
« il: 02 Set 2016, 14:35:18 »
Lo trovo un template davvero bello, le limitazioni più pesanti della versione free sono la non ridimensionabilità dello slideshow (enorme), ovviamente per me.

Anche l'indicazione a fine installazione che dice di mostrare lo slideshow solo nell header per vederlo nella prima pagina e basta, non funziona e non lo mostra da nessuna parte.
Ho quindi deciso di chiedere informazioni per acquistarlo ed avere supporto, peccato che non vi siano email diretti ma un form di registrazione che alla fine va in errore e non manda la richiesta.
Ho provato anche a scrivere a Support ma non rispondono.
A questo punto ho un po di dubbi sull'acquistare.
Qualcuno sa se dietro c'è qualcosa di serio?
Qualcuno sa su che file mettere le mani per cambiare l'altezza dello slideshow o mostrarlo solo nella prima pagina?

11
Joomla! 3 / Re:Maledetta paginazione lista categorie
« il: 01 Set 2016, 17:54:02 »
Scusa non ho capito, il filtro l'ho tolto ma la paginazione rimane.
Come posso impostare la paginazione a 30?

12
Joomla! 3 / Maledetta paginazione lista categorie
« il: 01 Set 2016, 13:07:32 »
3.6.2
Ho impostato nelle impostazioni globali limite liste predefinito 30 limite feed 30.
Ho letto da circa un ora di tutto di più sull'argomento con proposte di modifica a sorgente (non funzionanti) ed altro.
Non voglio la casella filtro e la paginazione (per 12 elementi).
Possibile che ci si deva sempre arenare su cose che dovrebbero essere di base?

13
Una piccola nota di chiarimento andrebbe aggiunta per specificare che il passo sul redirect così per come è stato descritto, non serve se come da oggetto stiamo trasferendo fra provider o anche se stiamo cambiando pure dominio. Poi ho dubbi sull'universalità del passo sul configuration.php riguardo alle variabili log e path, meglio descrivere come si ricavano provider per provider. Il resto inoltre credo sia chiaro solo a un lettore evoluto.
Il problema è che certi passaggi sono per loro natura 'delicati' vedi ad esempio quelli sul DB.
Ho cercato di semplificare il più possibile, ovviamente tutto è perfettibile.
Tenete conto che lo scopo è di dare una possibilità a chi non è arrivato in fondo con Akeeba Bakup o altro.
In quelle situazioni 'da panico' l'utente è costretto ad approfondire oppure ad appoggiarsi a tecnici.
Non potevo neanche scrivere un romanzo, già è un articolo lungo così.
Ovviamente ci sono altre mille situazioni, ad esempio se lo script viene generato con un character set differente o altro, ma non posso considerare tutte le casistiche, se risolvo la maggioranza dovrebbe essere già un buon aiuto.
Quanto al redirect non è così indispensabile e trovi in linea tantissime spiegazioni semplici su come farlo da DNS, .htaccess, html, javascript ecc. per cui non ho approfondito, un conto è il problema di riuscire a trasferire un sito (scopo dell'articolo), un conto quello di non far vedere i 'lavori in corso' per 2 o 3 giorni.
In realtà se hai un sito molto trafficato che vuoi spostare lo spostamento del dominio richiede tempi di propagazione, il redirect è immediato, per cui come soluzione provvisoria in attesa della propagazione la trovo consigliabile.

14
Non sarebbe più semplice farlo con akeeba backup? ammesso che si possa fare. Grazie
Sono daccordo, come spiegavo all'inizio, ammesso che si possa fare e che funzioni ...

16
Articoli della community / Joomla Disaster Recovery
« il: 30 Dic 2015, 21:56:05 »
Quando sembra non ci sia più nulla da fare ...

Link all'articolo: http://www.joomla.it/e-ancora/articoli-community-3x/8061-joomla-disaster-recovery.html

17
Perfetto proprio il file che mi serviva.
La cache avevo già risolto cancellando anche la temp.
Grazie

18
Joomla! 3 / Le maledette schermate bianche dopo un restore
« il: 24 Dic 2015, 16:11:54 »
A seguito di un problema ho fatto il restore di un sito versione 3.4 .
Il risultato immediato è stato la schermata bianca sia su front-end che su back-end.
Ho quindi copiato via FTP in locale il configuration.pxp impostando il controllo degli errori su maximum.
A seguito di ciò il messaggio che esce è
Cannot redeclare class JDatabaseInterface .../libraries/joomla/database/database.php on line 21
Sul database entro con phpmyadmin e ho il backup sia del sito che del db, ma con qualsiasi versione il risultato è sempre quello.
Ho provato a prendere una 3.4 e sovrapporre i files ma anche questo senza successo.
Sono andato sul DB e ho disabilitato tutti i plugins, ma niente.
Prima di installare ex novo e fare dei copia-incolla di alcune tabelle direttamente dal DB qualche idea?
Il sito è www.holzl.it

19
Salve ho un paio di siti 'intrombati', schermata bianca dopo un restore.
La prima cosa che volevo fare è azzerare la cache (ovviamente senza entrare nell'interfaccia amministrativa).
La seconda è riconoscere la versione precisa es. 3.7.1 ma lo posso fare solo quardando i files via ftp o accedendo dal database.
Qualche idea?

20
Buongiorno esco dall'ennesimo charset problema (e il problema era dove non me lo aspettavo).
Uso sempre charset=ISO-8859-1
Dopo mille e mille peripezie ho scoperto che la colpa era ... nel formato del file editato.
Mi spiego, pagine php con lo stesso charset, una va l'altra no.
Dopo mille taglia incolla cancello totalmente la prima e incollo il codice della seconda.
Una va l'altra no.
Quindi il problema era il formato del file in cui ho scritto la pagina php.
Uso Notepad++ controllo e scopro che effettivamente la stessa pagina era configurata con un charset diverso.
Cambiato quello va tutto.
Stessi problemi possono presentarsi se scrivete accenti con un copia incolla da una pagina con charset diverso.

Spero sia di aiuto ad altri.

Pagine: [1] 2 3 4

Torna su