Visualizza post

Questa sezione ti permette di visualizzare tutti i post inviati da questo utente. N.B: puoi vedere solo i post relativi alle aree dove hai l'accesso.


Post - ilnavigatore

Pagine: [1] 2 3 4 ... 9
1
Sviluppo / Re:Riscrittura url per form ricerca
« il: 02 Ago 2017, 17:20:25 »
Ciao Ahmed, no non la stessa domanda. lo stesso argomento ma la domanda diversa.
Hai altri suggerimenti? Per altro ho utilizzato alcune cose che mi avevi suggerito, grazie ancora.

2
Sviluppo / Riscrittura url per form ricerca
« il: 02 Ago 2017, 13:33:03 »
Buongiorno a tutti,
Ho un modulo che mi effettua la ricerca degli annunci sul mio sito, il problema che allo stato attuale delle cose non ho un url sef quando effettuo la ricerca.


Per ovviare al problema quando invio il form richiamo una task, la task raccoglie i campi di ricerca e i valori, crea un url e tramite Jroute lo trasforma in un url sef.
Il tutto funziona perfettamente ma per inviare tramite la task la richiesta di indirizzamento alla view di ricerca utilizzo il redirect:


Codice: [Seleziona]
$app = JFactory::getApplication();
$app->redirect( JRoute::_($link));


La mia domanda sto facendo la cosa giusta?
Ho un altro modo per inviare la richiesta al view da una task nel controller?
Qualcuno ha suggerimenti per migliorare questo passaggio?


Grazie mille a tutti

3
Alla fine ci sono riuscito, ho creato una task che ricostruisce l'url e lo invia al Jroute, il router.php lo interpreta e mediante un  [size=78%] [/size]
Codice: [Seleziona]
$app = JFactory::getApplication();
 $app->redirect(JRoute::_($link));


Vado visualizzo la ricerca con l'url come interessa a me e in caso di aggiornamento della pagina non chiede di reinviare il modulo.
Direi che perfetto cos.
Adesso manca la modifica al router e poi online!!
Grazie Ahmed per il tuo supporto.

4
Ciao Ahamed, grazie.
Si ho il mio componente, il discorso questo, il modulo di ricerca semplicemente un form che invia la richiesta al componente.
Per effettuare il submit del form, quindi per inviare la richiesta al componente di effettuare la ricerca, devo passare il link all'action, per avere un url sef il link deve essere elaborato dal JRoute.
Ed proprio per la dinamica su descritta che faccio a fatica a trovare una soluzione.
Grazie ancora.

5
Buonasera a tutti,
premetto che ormai sono in procinto di abbandonare questa idea.
Vado alla questione, ho un modulo di ricerca dal quale, selezionando i campi, possibile effettuare la ricerca dei vari annunci.
Il problema questo: non so come passare al router.php, mediante JRoute, i valori dei campi che ho selezionato in modo da creare un url sef per la ricerca.
Ho pensato di creare un plugin ma non so come:
  • prendere l'url, passarlo al JRoute e restituirlo.
  • Nel caso dovesse essere possibile il punto 1, in caso di aggiornamento della pagina non deve apparire la richiesta di reinvio del modulo.
  • Avevo pensato ad Ajax ma anche qui non ho idea di come far funzionare assieme le cose

C' qualcuno che si trovato nella mia stessa situazione?Grazie mille in anticipo a tutti. 

6
Sezione dedicata ai Server / Re:Ram server
« il: 07 Mag 2017, 15:15:07 »
Ciao Alex, il problema non la ram, ne ho. Volevo capire, anche in base alle esperienze di altri, quale potrebbe essere la configurazione ottimale. Adesso ho rimesso in dynamic ma ho modificato le impostazioni e per adesso mi sembra di aver raggiunto un buon compromesso tra ram e prestazioni. A te mai capitato di modificare questi parametri?

7
Sezione dedicata ai Server / Ram server
« il: 07 Mag 2017, 09:59:25 »
Ciao a tutti,
da un po che monitoro le prestazioni del mio server perch ho notato un consumo anomalo di RAMcon grande dispendio per nulla.
Eseguendo il comando top ho notato che circa il 60% della ram era occupata dal processo php-fpm7.0, a questo punto per fare una prova ho ammazzato il processo e l'ho fatto ripartire e la ram occupata passata da 2GB a 200 MB. Quindi certo che la maggior parte della Ram occupata da questo processo ho deciso di modificare il funzionamento, passando da Dynamic a Ondemand.
Secondo voi questo set del php-fpm pu influire sulle prestazioni?
Grazie

8
Sezione dedicata ai Server / Re:Info su Options -Indexes
« il: 16 Apr 2017, 20:25:44 »
Tutto chiarissimo, grazie mille danielecr sei stato gentilissimo!

9
Sezione dedicata ai Server / Re:Info su Options -Indexes
« il: 16 Apr 2017, 19:39:59 »
Ok , quindi ad esempio in assenza del file index google non indicizza la cartella?
Ho capito bene?

10
Buonasera,
oggi ho lavorato un po sul server e poi ho effettuato delle modifiche sul file .htaccess, mi tutto chiaro tranne a cosa serva il comando Options -Indexes, qualcuno me lo saprebbe spiegare?
Grazie.

11
Sezione dedicata ai Server / Re:Errore url sef page not found
« il: 02 Apr 2017, 20:45:50 »
Ci sono riuscito!!!!!!
Apache aveva si il mod_rewrite attivo, ma non era abilitata l'interpretazione del .htaccess nel file .conf in /etc/apache2/sites-enabled


Modificato il file e un bel riavvio di apache e tutto ha ricominciato a funzionare!
Grazie $red per la tua disponibilit!


Per chi pu avere il mio stesso problema ho solo inserito queste righe:
Codice: [Seleziona]

<Directory /home/siti/www>
Options Indexes FollowSymLinks
AllowOverride All
Order allow,deny
allow from all
</Directory>


12
Sezione dedicata ai Server / Re:Errore url sef page not found
« il: 02 Apr 2017, 20:35:31 »
Credo che sia tutto ok sul configuration. avevo verificato tutto.
Niente non so pi che fare

13
Sezione dedicata ai Server / Re:Errore url sef page not found
« il: 02 Apr 2017, 19:39:32 »
Si esatto ho fatto anche questo, nulla.
Mi venuto il dubbio che apache non tenga conto del file .htaccess e non lo interpreti.
Sto verificando il file 000-defoult.conf.
Dopo questo non so pi che inventarmi.

14
Sezione dedicata ai Server / Re:Errore url sef page not found
« il: 02 Apr 2017, 19:20:49 »
Ciao $Red,
Grazie di avermi risposto, si ho effettuato queste verifiche ma il risultato non cambia.


15
Buonasera a tutti,
ho fatto una ricerca ma non riesco a trovare niente che si sposi con il mio problema.
Ho da poco migrato su un cloud hosting, tutto funziona bene tranne quando attivo la funzione sef di Joomla.
Ovviamente la home page viene visualizzata ma quando provo a spostarmi da qualsiasi altra parte mi viene restituito l'errore:


The requested URL /esempio was not found on this server.
Apache/2.4.10 (Debian) Server at www.nomesito.net Port 80


Ho verificato il file .htaccess.
Ho verificato che sul server sia attivo il mod_rewrite.
Ma niente da fare. L'unico modo per far funzionare il sito disabilitare l'opzione Riscrivi URL SEF

il problema che con questa impostazione disabilitata nelle url viene inserito index.php
Es. http://www.nomesito.net/index.php/esempio
Qualcuno saprebbe darmi qualche indicazione su quali altre verifiche posso fare?
Grazie



16
Esperimenti e test / Re:problemi con require_once
« il: 09 Ott 2016, 19:11:45 »
Alla fine sono riuscito a risolvere inserendo nel controller:


Codice: [Seleziona]

 JModelLegacy::addIncludePath(JPATH_ROOT . '/administrator/components/com_altrocom/models','AltroComModel');
$ms = JModelLegacy::getInstance('Message', 'AltroComModel');

17
Ciao,


sto cercando di richiamare questa funzione getConfiguration(), ma mi viene restituito l'errore in oggetto.
Qualcuno sa di cosa si tratta e come risolvere?


Grazie mille.

18
Esperimenti e test / Re:problemi con require_once
« il: 07 Ott 2016, 21:14:37 »
Ciao map,
purtroppo esito negativo.
il
Codice: [Seleziona]
require_once JPATH_ADMINISTRATOR . 'components/com_altrocom/models/message.php';mi da problemi, non capisco perch. se lo inserisco mi viene restituita la pagina di errore 500.

19
Esperimenti e test / [RISOLTO]problemi con require_once
« il: 06 Ott 2016, 21:30:31 »
Buonsera,
ho sviluppato un mio componente per la gestione e l'invio di email agli utenti.
Ora vorrei utilizzare delle funzioni, presenti in un altro componente all'interno del mio sito, che mi gestirebbero il template della email.


Ho provato con
Codice: [Seleziona]

require_once(JPATH_ADMINISTRATOR.'/components/com_altrocom/models/message.php');
$ms = new AltroComModelMessage();


ma quando provo a richiamare la funzione mi viene resituito err 500
Sinceramente non sto riuscendo ad uscirne fuori.
Grazie

20
Sviluppo / Re:Verifica email
« il: 15 Apr 2016, 13:50:22 »
Ciao giovi,
grazie mille il documento che hai inserito mi da tutte le risposte!!
Grazie ancora


Pagine: [1] 2 3 4 ... 9

Torna su