Visualizza post

Questa sezione ti permette di visualizzare tutti i post inviati da questo utente. N.B: puoi vedere solo i post relativi alle aree dove hai l'accesso.


Post - salvosound

Pagine: [1] 2 3
1
Sviluppo / [RISOLTO - In teoria ] - Componente con Multi DB
« il: 08 Nov 2018, 17:31:36 »
Riapro un nuovo Topic con un approfondimento.
il doc https://docs.joomla.org/Connecting_to_an_external_database
permette di dare istruzioni per poter collegare al componente un database esterno.
Peccato che quando metto in pratica qualcosa non funziona e allora ho da chiedervi se vi è capitato una cosa simile a voi.


Il database in questione è un db di oracle sulla porta 1521 con accesso di utente e password.
inserisco tale funzione _construct nel file del Model


quando però inserisco i dati l'errore che mi torna è questo:

Could not connect to PDO: could not find driver
Could not connect to PDO: could not find driver

I dati del driver di "oracle" c'è nella libreria di Joomla.
Sapete quale altra cosa bisogna caricare o modificare?


Vi ringrazio.




2
Sviluppo / CRUD e funzione Delete
« il: 17 Lug 2018, 15:02:43 »
Salve a tutti
ho un chiarimento in merito alla logica CRUD nello sviluppo dei componenti per joomla.


Sto riferendomi in particolare alla guida allo sviluppo dei componenti con paradigma MVC.
in particolare sono arrivato al punto della lezione 10


Lo sviluppo del componente è arrivato alla parziale gestione del recupero dei dati dalla tabella, edit, update, ma non funziona il delete.
Cercando nelle classi di joomla sembra di capire che esse non gestiscono il delete del record nel DB.
Infatti inserendo una funzione "finta"
Codice: [Seleziona]
function delete($cid)
        {
           
         return TRUE;
        }


il componente non mi da errore.
se tolgo questa finta funzione viene fuori l'errore :
 Call to undefined method Joomla\CMS\MVC\Model\ListModel::delete()

Quindi manca il metodo all'interno delle librerie joomla

Qualcuno sa il perchè? e se ha qualche dritta di una generica funzione delete in merito.

Vi ringrazio.

3
Sviluppo / Re:[RISOLTO] - Redirect sviluppo nuovo componente
« il: 16 Lug 2018, 08:46:56 »
è uno sviluppo in locale. ho tutto su un server in azienda per testare la funzionalità del nuovo componente.
Quindi diciamo che è a scopo didattico.


4
Sviluppo / Re:[RISOLTO] - Redirect sviluppo nuovo componente
« il: 05 Lug 2018, 14:12:51 »
Mi rispondo da solo visto che ho trovato, credo, una soluzione:


In pratica partendo dall'istanza e chiamandola con il nome del componente ho risolto la cosa, e quindi di conseguenza vanno modificate le varie assegnazioni delle classi. quindi sostituendo Start_autisti al posto di StartAutisti si risolve.


Mi rimane sempre un dubbio: Posso usare solo un istanza? non posso avere altre istanze?
ciao


5
Sviluppo / [RISOLTO] - Redirect sviluppo nuovo componente
« il: 05 Lug 2018, 12:59:55 »
Cari Amici
sto seguendo piano piano la guida alla programmazione del semplice " HELLO WORLD" component tramite la guida joomla
Sono arrivato alla parte del backend in cui si parla della vista singola e multipla e delle azioni.
L'uso del componente HelloWord dopo un po' crea molta confusione perchè in alcune parti non da modo di distinguere fra Istanze, e altri tipi logici. ( magari appena termino il lavoro provo a riscrivere qualche articolo di approfondimento )


Ora vengo al dunque:
il componente si chiama com_start_autisti, le due viste come da prassi si chiamano "start_autisti" e " start_autistis"
Partiamo dall'entryPoint che si chiama come è giusto che sia "start_autisti.php" dove all'interno creo l'istanza
Codice: [Seleziona]
$controller = JControllerLegacy::getInstance('StartAutisti');Creo le varie classi del Model. La seguente è la classe del Models/start_autisti ( quindi vista singola )
Codice: [Seleziona]
class StartAutistiModelstart_autisti extends JModelAdminZippo tutto e carico il componente su joomla e la lista viene fuori, cioè la vista multipla ( start_autistis ) funziona.
Se vado a cliccare su una voce dell'elenco, ad esempio per modificarlo, il server da errore 404 come componente non trovato.


Guardando attentamente la riga dell'indirizzo viene fuori il seguente LINK


Codice: [Seleziona]
administrator/index.php?option=com_startautisti&view=start_autisti&layout=edit&id=1

Riporto la parte interessata:
da notare che il nome del componente è errato.


Codice: [Seleziona]
option=com_startautisti&view

Se modifico a mano il nome del componente, funziona tutto, viene fuori il form corretto e registro nel db correttamente.


Quindi la domanda viene spontanea: Chi è responsabile del redirect e da dove prende il nome del componente?


Vi ringrazio.



6
Sviluppo / Re:Componente con Multi DB
« il: 29 Giu 2018, 10:57:18 »
Perfetto Grazie Mille
era quello che cercavo

7
Sviluppo / [RISOLTO] - Componente con Multi DB
« il: 29 Giu 2018, 10:12:41 »
Salve a tutti,
vi chiedo una domanda tecnica per chi conosce bene la programmazione.
In joomla sapete se è possibile sviluppare un componente che abbia la possibilità di prendere i dati da vari database, sparsi lungo la rete aziendale?
Esempio, devo prelevare dei dati di anagrafica del personale che sta in un server X poi li devo mettere assieme ai turni di lavoro che stanno sul server Y. Potrei avere anche la necessità di contattare un Db Z per avere dettagli in merito a disposizioni o regole aziendali.

vi è mai capitato qualcosa del genere?
vi ringrazio.

8
Grazie Berry
L'ho cancellato, in quanto faceva un override di quello che era stato scritto prima.

9
Salve a tutti
Vi spego brevemente:
Ho il seguente sito www.progettiscorta.it aggiornato da 2.5 a joomla 3.4.1
Premetto che il template è quello della versione vecchia, ma per ora sembra funzionare.
Oggi ho aggiunto un articolo, e mi ritrovo che il titolo risulta visualizzato molto piccolo, rispetto a quello che dovrebbe. Se si scorre l'articolo successivo, inserito con la vecchia versione, è corretto.
Ho guardato al codice html, ed entrambi hanno un tag di tipo "<h2>"( h2 ).
solo che il primo viene visualizzato in modo errato, mentre il secondo è ok.
Qualcuno ha mai avuto un problema del genere? pensate sia dovuto alla versione vecchia del template?
Vi ringrazio.

10
Joomla! 3 / Re:mi consigliano di non usare joomla.. ?
« il: 08 Mar 2015, 10:36:21 »
Se posso permettermi, la società che gestirà il booking non vuole sbattersi per implementare altra roba visto che ha già qualcosa su wordpress.


quindi cercherà di indirizzarti verso quella strada, se per te è indifferente usa wordpress.


ciao

11
Sviluppo / Developing a Basic Component
« il: 08 Mar 2015, 10:26:46 »
 :o :o :o

12
Confermo la procedura delle sotto cartelle già da me verificato e con database diversi.
Spesso lo uso come prewiev per i clienti.

13
Joomladay / Re:Associazione Joomla Romagna
« il: 12 Set 2014, 11:38:43 »
BHe sembra che pian piano siamo sempre di più.
Forza se facciamo un bel gruppetto possiamo metterci tutti assieme e fare grandi cose.
ciao

14
Joomla! 1.6/1.7/2.5 / Re:display errors su on come risolvere
« il: 29 Nov 2013, 10:51:38 »
Oltre alle modifice gia descritte ho trovato anche questa che ha portato alla risoluzione del problema

sempre nel file php.ini modificare la riga:

error_reporting = E_ALL  | E_STRICT

con questa

error_reporting = E_ALL | E_DEPRECATED

Ciao



15
Joomla! 1.6/1.7/2.5 / Re:Filtri HTML
« il: 18 Ott 2013, 14:53:09 »
Nessuno ha idea di come trovara la giusta correzione?



16
Joomla! 1.6/1.7/2.5 / Filtri HTML editor TinyCE
« il: 15 Ott 2013, 15:23:28 »
Salve a tutti
Riformulo la domanda:

Ho due siti joomla entrambi aggiornati alla 2.5.14

Su entrambi uso lo stesso editor tinyCE

Su uno non riesco ad inserire righe di codice in html all'interno dell'articolo. nell'altro si.

oltre alla soluzione di impiantare un nuovo componente con un nuovo editor, Sapete se esiste un parametro in tabella da verificare che attivi realmente i filtri html dell'editor o li elimini del tutto?

Grazie



17
Joomladay / Re:Associazione Joomla Romagna
« il: 30 Apr 2013, 16:27:54 »
Ciao MAgliettaro!
adesso siamo a 2, della romagna, vediamo chi altro si associa.
ciaoo


18
funzione cerca...

http://forum.joomla.it/index.php/topic,190127.0.html

Grazie Tante ma se leggevi bene capivi anche la domanda.

è Possibile creare un PANNELLO DI CONTROLLO personalizzato??

Ho cercato ma non trovato nulla in merito

Altre idee??

19
Salve a tutti
Ho creato un sito e ho installato un paio di componenti, adesso dovrei fare in modo che questi componenti possano essere usati da vai utenti gestiti tramite acceso.
è possibile creare un pannello di controllo personalizzato?
saluti


20
Gestione Forum / Re:Quale componente per forum?
« il: 13 Mar 2013, 09:32:33 »
Credo sia la stessa domanda come la mia.


Pagine: [1] 2 3

Torna su