Autore Topic: phpBB + Joomla  (Letto 55185 volte)

Offline AlmAck

  • Esploratore
  • **
  • Post: 65
    • Mostra profilo
    • AlmAck.ch
Re: phpBB + Joomla
« Risposta #20 il: 20 Ott 2007, 17:59:57 »
Vi segnalo che oggi è uscita la nuova versione di phpbbconnector con il nome di cbconnector.

trovate una breve guida su come fare l'aggiornamento qui:

http://www.almack.ch/2007/10/20/rilasciato-cb-connector-v2-beta-1

Ciao

Offline cloud_the_king

  • Esploratore
  • **
  • Post: 150
  • Sesso: Maschio
    • Mostra profilo
    • www.h2o-sport.it
Re: phpBB + Joomla
« Risposta #21 il: 15 Nov 2007, 14:49:27 »
scusate, forse non capisco, ma come e dove si installa CBuilder1_0_2_unzip1st.zip? ???
…• Quello che facciamo in vita riecheggia per l'eternità •…

Offline AlmAck

  • Esploratore
  • **
  • Post: 65
    • Mostra profilo
    • AlmAck.ch
Re: phpBB + Joomla
« Risposta #22 il: 15 Nov 2007, 19:45:59 »
scusate, forse non capisco, ma come e dove si installa CBuilder1_0_2_unzip1st.zip? ???

Ciao ti consiglio fortemente di prendere l'ultima versione di community builder (la guida è vecchia). Per installarlo basta che lo scompatti e leggi le istruzioni che ci sono dentro :).

CIAO

Offline cloud_the_king

  • Esploratore
  • **
  • Post: 150
  • Sesso: Maschio
    • Mostra profilo
    • www.h2o-sport.it
Re: phpBB + Joomla
« Risposta #23 il: 16 Nov 2007, 15:05:24 »
appunto, è che una volta scompattato ho 2 file e non ho capito dove installarli. ???
…• Quello che facciamo in vita riecheggia per l'eternità •…

Offline andreaogeno

  • Esploratore
  • **
  • Post: 116
    • Mostra profilo
Re: phpBB + Joomla
« Risposta #24 il: 19 Nov 2007, 04:07:29 »
Ciao AlmAck, ho seguito passo passo la tua guida, quindi ho:

-installato tutti i moduli ed il componente Contenuti nella cartella Community builder 1.02

-Disabilitato il modulo di login standard di Joomla

-Abilitato il login CBlogin

-Ho quindi sincronizzato con la funzione Synchronize

Qui viene il difficile;
La tua guida dice di scaricare il CBconnector e non piu il PhpBBconnector, così ho scaricato il CB_Connector_v2_0_0_Beta_2; Vado nel Plugin manager del CB e lo installo con successo, ma una volta installato, cliccando su questa nuova plugin appena installata(CB connector) mi appare una pagina bianca con scritto Fatal error: main() [function.require]: Failed opening required '/membri/andreaogeno/mambots/system/xajax_0.2.4/xajax.inc.php' (include_path='.:') in /membri/andreaogeno/components/com_comprofiler/plugin/user/plug_cbconnector/cbconnector.php on line 21.

A questo punto visto che io ho uso JOOMLA 1.0.12 ho pensato di provare a installare PHPBBCONNECTOR v1.0.2+patch-v2 ma in questo caso non riesco proprio ad installarlo perchè mi da errore.
 :o
Help! :'(

Offline AlmAck

  • Esploratore
  • **
  • Post: 65
    • Mostra profilo
    • AlmAck.ch
Re: phpBB + Joomla
« Risposta #25 il: 19 Nov 2007, 20:55:21 »
hai installato xAjax Mambot?
Ti consiglio di usare l'ultimo CB e non la versione 1.02
http://www.joomlapolis.com/component/option,com_docman/task,doc_details/gid,127/Itemid,36/

Ciao

Offline andreaogeno

  • Esploratore
  • **
  • Post: 116
    • Mostra profilo
Re: phpBB + Joomla
« Risposta #26 il: 20 Nov 2007, 02:02:35 »
hai installato xAjax Mambot?
Ti consiglio di usare l'ultimo CB e non la versione 1.02
Ciao


Si avevo installato la versione cb_1_1_0-unzip1st, ho sbagliato a scrivere invece questo xAjax Mambot non lo avevo installato perchè non c'era scritto nella tua guida estesa.

Ora che l'ho scaricato questo xAjax non ho idea di come installarlo,ho provato a installarlo con il plugin manager del Community Builder ma mi da errore, per ora ho solo capito che va installato prima del Connector e non sono riuscito a trovare delle istruzioni in italiano, come posso fare?
« Ultima modifica: 20 Nov 2007, 02:30:09 da andreaogeno »

Offline AlmAck

  • Esploratore
  • **
  • Post: 65
    • Mostra profilo
    • AlmAck.ch
Re: phpBB + Joomla
« Risposta #27 il: 20 Nov 2007, 10:39:47 »
Ciao, per la guida la trovi qui (se leggevi i messaggi sopra era tutto spiegato):
http://www.almack.ch/2007/10/20/rilasciato-cb-connector-v2-beta-1

ciao

Offline andreaogeno

  • Esploratore
  • **
  • Post: 116
    • Mostra profilo
Re: phpBB + Joomla
« Risposta #28 il: 20 Nov 2007, 14:10:19 »
Grazie
Dunque: in realtà la guida di quel link l'ho letta, in particolare la sezione ke interessa a me ossia "Nuova installazione con cbconnector" solo che la spiegazione per l'installazione di xAjax dice di "installare il pacchetto xAjax Mambot dal pannello di gestione mambot di joomla"

Andando quindi nell'Amministrazione di Joomla, nella sezione MAMBOT\MAMBOT SITO non vedo nessuna funzione per l'installazione di xAjax.

Edit

ho trovato la sezione giusta...chiedo venia, ora provo e ti faccio sapere; Grazie Almack sei un grande
« Ultima modifica: 20 Nov 2007, 15:56:22 da andreaogeno »

Offline andreaogeno

  • Esploratore
  • **
  • Post: 116
    • Mostra profilo
Re: phpBB + Joomla
« Risposta #29 il: 20 Nov 2007, 18:14:20 »
Perfetto tutto riuscito perfettamente.

Ho installato xAjax dal pannello Amministrazione Joomla, nella sezione INSTALLAZIONI\MAMBOT e subito dopo il CB_CONNECTOR, ho cliccato poi su CB_CONNECTOR e indicato dove si trova il forum, infine dal pannello di controllo Community Builder/Tool ho sincronizzato gli utenti

Ovviamente ho disattivato il modulo login standard di Joomla e ho abilitato il nuovo CB_login, i nuovi utenti registrati sul sito Joomla erano automaticamente loggati sul forum phpbb2.

Ora resta solo una piccola cosa: Togliere il modulo login dal forum, per farlo ho seguito passo passo questa guida di Almack
http://wiki.almack.ch/index.php/Hack_phpBB#Togliere_il_box.2C_la_scritta_login_e_registrati
ma editando con blocconote il file overall_header.tpl non mi corrispondono le righe che dice nella guida, quindi non riesco a modificarle, come posso fare?

Offline AlmAck

  • Esploratore
  • **
  • Post: 65
    • Mostra profilo
    • AlmAck.ch
Re: phpBB + Joomla
« Risposta #30 il: 20 Nov 2007, 20:23:08 »
Ora resta solo una piccola cosa: Togliere il modulo login dal forum, per farlo ho seguito passo passo questa guida di Almack
http://wiki.almack.ch/index.php/Hack_phpBB#Togliere_il_box.2C_la_scritta_login_e_registrati
ma editando con blocconote il file overall_header.tpl non mi corrispondono le righe che dice nella guida, quindi non riesco a modificarle, come posso fare?

CIao andreaogeno, che versione di phpBB stai usando? la guida era fatta per la versione phpBB2 e non la 3. Ti consiglio se usi phpBB3 di provare a fare una ricerca in internet, sicuramente troverai qualche cosa a riguardo. Per il momento non ho intenzione di aggiornare la guida visto che non uso più phpBB ma magari in futuro faccio dei cambiamenti.
CIao

Offline andreaogeno

  • Esploratore
  • **
  • Post: 116
    • Mostra profilo
Re: phpBB + Joomla
« Risposta #31 il: 21 Nov 2007, 01:27:47 »
Uso la versione phpBB 2.0.22, e un paio di skins, quello ke ho provato a modificare è stato il template attualmente in uso.

P.s. se non ci lavori più con Phpbb è un peccato, l'ho sempre trovato molto ben fatto, anche se il Vbullettin resta il mio preferito.

Offline AlmAck

  • Esploratore
  • **
  • Post: 65
    • Mostra profilo
    • AlmAck.ch
Re: phpBB + Joomla
« Risposta #32 il: 21 Nov 2007, 18:05:22 »
Molto strano perché il template della pagina principale non cambia di molto da versione a versione (intendo di phpBB2, la guida mi pare si basava sulla versione 2.0.19).

OT: la mia storia: volevo integrare sto benedetto phpBB in joomla e per farlo avevo scoperto il componente phpbbconnector (ora cbconnector). L'ho usato per parecchio tempo ma poi non mi soddisfava più e sono passato a fireboard. Fireboard non è male ma è ancora molto giovane e soffre di alcuni problemi. Alla fine stufo nero sono passato a drupal. Con drupal è tutto diverso tutto integrato, proprio quello che cercavo.

Offline andreaogeno

  • Esploratore
  • **
  • Post: 116
    • Mostra profilo
Re: phpBB + Joomla
« Risposta #33 il: 23 Nov 2007, 03:17:28 »
orsu come potrei fare per togliere ste funzioni di login dal forum?  ;D

Offline cloud_the_king

  • Esploratore
  • **
  • Post: 150
  • Sesso: Maschio
    • Mostra profilo
    • www.h2o-sport.it
Re: phpBB + Joomla
« Risposta #34 il: 26 Nov 2007, 15:29:33 »
scusate, forse non capisco, ma come e dove si installa CBuilder1_0_2_unzip1st.zip? ???

Ciao ti consiglio fortemente di prendere l'ultima versione di community builder (la guida è vecchia). Per installarlo basta che lo scompatti e leggi le istruzioni che ci sono dentro :).

CIAO
Ho installato Community Builder, ma il processo non è stato chiaro per nulla. Ho dovuto scompattare i file all'interno del file zippato e inserire il tutto dall'installazione dei mambot. Ora sul sito mi compare il CBLogin, ma non ho capito dove devo installare phpbbconnector v1.0.3.
Non mi è chiaro dove sia il pannello di controllo di CBLogin. Inoltre ho installato anche XajaxMambo, ma non ho capito a cosa serva, e come utilizzarlo.
…• Quello che facciamo in vita riecheggia per l'eternità •…

Offline andreaogeno

  • Esploratore
  • **
  • Post: 116
    • Mostra profilo
Re: phpBB + Joomla
« Risposta #35 il: 26 Nov 2007, 17:20:03 »
Cloud, non devi installare phpconnector 1.0.3 ma CBCONNECTOR, ovviamente prima di farlo devi installare  XAJAX System Mambot.

Quindi ricapitolando:

-Installi Community Builder (cb_1_1_0-unzip1st)
-Installi xAjax
-Installi come plugin CBConnector (CB_Connector_v2_0_0_Beta_2)da 
Componenti/Community Builder/Plugin management/install plugin
-Nella sezione plugin installate, clicchi su CB Connector per attivarlo.

dopo di cio'nella sezione moduli troverai CB_login CB_online e tutte le altre funzioni CB da configurare a proprio piacimento.


P.S.
Almack se ci sei, fammi sapere per quella modifica al forum phpbb che non riesco a togliere i moduli di registrazione.  ;)

Offline AlmAck

  • Esploratore
  • **
  • Post: 65
    • Mostra profilo
    • AlmAck.ch
Re: phpBB + Joomla
« Risposta #36 il: 26 Nov 2007, 19:05:44 »
Grazie andreaogeno di aver risposto alla domanda di cloud_the_king

Ho provato a vedere come funziona il nuovo phpBB-2.0.22 ma notato che alla fine non cambia nulla.
Prova a seguire questa guida dovrebbe andare bene anche con l'ultima versione di phpBB2 (ho controllato).

http://wiki.almack.ch/index.php/Hack_phpBB#Togliere_il_box.2C_la_scritta_login_e_registrati


CIao

Offline andreaogeno

  • Esploratore
  • **
  • Post: 116
    • Mostra profilo
Re: phpBB + Joomla
« Risposta #37 il: 29 Nov 2007, 14:23:40 »
Prego Almack, figurati per così poco?
Cmq....
i vari tpl dei vari template per phpbb, non corrispondono alle scritte che compaiono sulla guida,
ne sul template di default(subsilver) ne su quelli aggiuntivi (cobalt Blue)  ??? ???

Offline AlmAck

  • Esploratore
  • **
  • Post: 65
    • Mostra profilo
    • AlmAck.ch
Re: phpBB + Joomla
« Risposta #38 il: 30 Nov 2007, 01:39:47 »
Impossibile, ho controllato io stesso e li ho trovati senza problemi. Cerca nel file overall_header.tpl la stringa {L_USERGROUPS} e dovresti trovare il resto.

CIao

Offline andreaogeno

  • Esploratore
  • **
  • Post: 116
    • Mostra profilo
Re: phpBB + Joomla
« Risposta #39 il: 30 Nov 2007, 02:05:59 »
Si infatti se con Wordpad cerco {L_USERGROUPS} me lo trova, ma le scritte corrispondono solo nel template SUBSILVER
mentre per quello che uso io che è COBALT BLUE, ha il testo leggermente diverso da quanto descritto nel tuo wiki.

Ad esempio, l'overall header.tpl del mio CobaltBlue è:

</td>
                                 <td align="center" valign="middle" nowrap class="mainmenu">                     
                                    <table border="0" cellspacing="0"><tr><td><a href="{U_GROUP_CP}"><img src="templates/Cobalt/images/icon_mini_groups.gif" width="22" height="22" border="0" alt="{L_USERGROUPS}" />[/url]</td><td style="padding-right: 7px" class="mainmenu"><a href="{U_GROUP_CP}">{L_USERGROUPS}[/url]</td></tr></table>[/url]
                                 </td>
                                 <!-- BEGIN switch_user_logged_out -->
                                 <td align="center" valign="middle" nowrap class="mainmenu">
                                    <table border="0" cellspacing="0"><tr><td><a href="{U_REGISTER}"><img src="templates/Cobalt/images/icon_mini_register.gif" width="22" height="22" border="0" alt="{L_REGISTER}" />[/url]</td><td tyle="padding-right: 7px" class="mainmenu"><a href="{U_REGISTER}">{L_REGISTER}[/url]</td></tr></table>[/url]
                                 </td>
                                 <!-- END switch_user_logged_out -->                                 
                              </tr>
                           </table>
                           
                           <table border="0" cellpadding="0">
                              <tr>
                                 <td align="center" class="mainmenu" valign="middle" nowrap class="mainmenu">                     
                                     <table border="0" cellspacing="0"><tr><td class="mainmenu"><a href="{U_PROFILE}" class="mainmenu"><img src="templates/Cobalt/images/icon_mini_profile.gif" width="22" height="22" border="0" alt="{L_PROFILE}" />[/url]</td><td class="mainmenu" style="padding-right: 7px"><a href="{U_PROFILE}" class="mainmenu">{L_PROFILE}[/url]</td></tr></table>
                                 </td>
                                 <td align="center" class="mainmenu" valign="middle" nowrap class="mainmenu">                                 
                                    <table border="0" cellspacing="0"><tr><td class="mainmenu"><a href="{U_PRIVATEMSGS}" class="mainmenu"><img src="templates/Cobalt/images/icon_mini_message.gif" width="22" height="22" border="0" alt="{PRIVATE_MESSAGE_INFO}" />[/url]</td><td class="mainmenu" style="padding-right: 7px"><a href="{U_PRIVATEMSGS}" class="mainmenu">{PRIVATE_MESSAGE_INFO}[/url]</td></tr></table>[/url]
                                 </td>
                                 <td align="center" class="mainmenu" valign="middle" nowrap class="mainmenu">
                                    <table border="0" cellspacing="0"><tr><td class="mainmenu"><a href="{U_LOGIN_LOGOUT}" class="mainmenu"><img src="templates/Cobalt/images/icon_mini_login.gif" width="22" height="22" border="0" alt="{L_LOGIN_LOGOUT}" />[/url]</td><td class="mainmenu" style="padding-right: 7px"><a href="{U_LOGIN_LOGOUT}" class="mainmenu">{L_LOGIN_LOGOUT}[/url]</td></tr></table>[/url]
                                 </td>
                              </tr>
                           </table>
                     
                  </td>
               </tr>
            </table>


Mentre nel tuo wiki è:

hspace="3" />{L_USERGROUPS}[/url]   <a href="{U_REGISTER}" class="mainmenu"><img src="templates/subSilver/images/icon_mini_register.gif" width="12" height="13" border="0" alt="{L_REGISTER}" hspace="3" />{L_REGISTER}[/url]  </span></td>

e poi

<tr> <td height="25" align="center" valign="top" nowrap="nowrap"><span class="mainmenu"> <a href="{U_PROFILE}" class="mainmenu"><img src="templates/subSilver/images/icon_mini_profile.gif" width="12" height="13" border="0" alt="{L_PROFILE}" hspace="3" />{L_PROFILE}[/url]   <a href="{U_PRIVATEMSGS}" class="mainmenu"><img src="templates/subSilver/images/icon_mini_message.gif" width="12" height="13" border="0" alt="{PRIVATE_MESSAGE_INFO}" hspace="3" />{PRIVATE_MESSAGE_INFO}[/url]   <a href="{U_LOGIN_LOGOUT}" class="mainmenu"><img src="templates/subSilver/images/icon_mini_login.gif" width="12" height="13" border="0" alt="{L_LOGIN_LOGOUT}" hspace="3" />{L_LOGIN_LOGOUT}[/url] </span></td> </tr>

 

Torna su