Autore Topic: {Risolto}Caratteri speciali errata visualizzazione  (Letto 16953 volte)

Offline mariocz

  • Esploratore
  • **
  • Post: 56
  • Sesso: Maschio
    • Mostra profilo
{Risolto}Caratteri speciali errata visualizzazione
« il: 18 Ago 2011, 09:54:45 »
Salve a tutti ho cercato un po sul forum e ho trovato tante spiegazioni ma non sono riuscito comunque a risolvere il mio problema.
 Mi spiego meglio, ho da poco iniziato un e-commerce e nel footer ho inserito un testo che ha della lettere accentate, il sito però nella visualizzazione le lettere accentate vengono "oscurate" da questo simbolino "�"
 da quello che ho letto in giro pare che nel DB possa esserci un errore ho controllato e tutto il db è in utf8_general_ci, la versione di joomla è la 1.5.23 sopra c'è installato virtuemart 1.1.9
 Grazzie a tutti per l'aiuto.
 
« Ultima modifica: 18 Ago 2011, 10:52:04 da mariocz »
Aiuta & lasciati aiutare

Offline giovi

  • Instancabile
  • ******
  • Post: 9834
  • Sesso: Maschio
    • Mostra profilo
    • Simple
Re:Caratteri speciali errata visualizzazione
« Risposta #1 il: 18 Ago 2011, 10:18:08 »
Che simboli stai usando? Il linguaggio di riferimento è l'html, non tutti i simboli sono supportati! Ogni simbolo ha un suo codice che comincia per &, stai usando questa sintassi?
Che ti costa? Se ti ho aiutato,  vota  la mia estensione sulla JED

Offline mariocz

  • Esploratore
  • **
  • Post: 56
  • Sesso: Maschio
    • Mostra profilo
Re:Caratteri speciali errata visualizzazione
« Risposta #2 il: 18 Ago 2011, 10:51:44 »
Ho risolto in pratica il file index.php del template non era codificato in utf8 ma in un altra codifica che non ricordo.
mi è bastato aprirlo con notepad e salvarlo con la codifica utf8.


Grazie comunque per l'aiuto :D
Aiuta & lasciati aiutare

 

Torna su