Autore Topic: Probleme con caratteri lingua turca  (Letto 16219 volte)

Offline Secursystem

  • Nuovo arrivato
  • *
  • Post: 16
    • Mostra profilo
Probleme con caratteri lingua turca
« il: 27 Ott 2011, 12:44:59 »
Buongiorno,


  sono nuovo del forum, sto impazzendo per risolvere un problema forse stupido:


sto realizzando un sito in turco (!!!) il link questo: http://www.stepstore.com.tr ho installato lingua turca lato sito e funziona ma SOLO per alcune parti, infatti come potete vedere nel carrello in alto a dx alcuni caratteri speciali tuchi ( ş, la u con due puntini sopra, ecc)me li sostituisce con ignoti. Cos come se entrate in un qualsiasi prodotto i pulsanti sono tradotti male sempre con sti caratteri ignoti.


Alch ho provato a cambiare codifica nel browser, ho messo turco e qui venuta fuori la sorpresa: i caratteri che prima si vedevano male adesso si vedono bene, ma le stesse lettere incriminate che prima si vedevano bene con codifica UTF standard per noi in italia adesso si vedono male!! Incredibile..


Qualcuno sa darmi qualche dritta?

Offline Npaquito

  • Abituale
  • ****
  • Post: 1832
    • Mostra profilo
Re:Probleme con caratteri lingua turca
« Risposta #1 il: 27 Ott 2011, 13:16:42 »
.... con codifica UTF standard per ....
Hola

Usando Joomfish i caratteri turchi si vedono bene solo con le tabelle a utf-8, io proverei il cambio

Offline Secursystem

  • Nuovo arrivato
  • *
  • Post: 16
    • Mostra profilo
Re:Probleme con caratteri lingua turca
« Risposta #2 il: 27 Ott 2011, 13:33:10 »
Hola

Usando Joomfish i caratteri turchi si vedono bene solo con le tabelle a utf-8, io proverei il cambio


.. ma a me serve solo la lingua turca, non un sito in multilingua.


Ho gi installato la lingua turca e viene tutto tradotto correttamente ma i caratteri "speciali" come la Ş
vengono visualizzati bene SOLTANTO in alcune parti del sito... PERCHE' nn in tutto il sito?!


 
[/size][/size][/font][/color]

Offline Npaquito

  • Abituale
  • ****
  • Post: 1832
    • Mostra profilo
Re:Probleme con caratteri lingua turca
« Risposta #3 il: 27 Ott 2011, 13:43:49 »
... caratteri turchi si vedono bene solo con le tabelle a utf-8, io proverei il cambio
Hola

...nel collation delle tabelle di mysql

Offline Secursystem

  • Nuovo arrivato
  • *
  • Post: 16
    • Mostra profilo
Re:Probleme con caratteri lingua turca
« Risposta #4 il: 27 Ott 2011, 14:10:33 »
Scusa puoi essere pi preciso?


Ho visto che nel database sql ho in ogni tabella questo valore: utf8_general_ci
[/size]
Joomfish ho provato ad installarlo ma non cambia nulla, mi mette solo la bandierina turca..




Offline Npaquito

  • Abituale
  • ****
  • Post: 1832
    • Mostra profilo
Re:Probleme con caratteri lingua turca
« Risposta #5 il: 27 Ott 2011, 15:10:53 »
Hola
 
...
Ho visto che nel database sql ho in ogni tabella questo valore: utf8_general_ci..

 Se hai gia utf-8 general_ci non per questa ragione.

... ma i caratteri "speciali" come la Ş
vengono visualizzati bene SOLTANTO in alcune parti del sito...
con che componenti si vedono bene i caratteri e con che componenti si vedono male?P

Offline Secursystem

  • Nuovo arrivato
  • *
  • Post: 16
    • Mostra profilo
Re:Probleme con caratteri lingua turca
« Risposta #6 il: 27 Ott 2011, 18:39:47 »
Guarda tu stesso:


a questo link: http://www.stepstore.com.tr/homepage?page=shop.browse&category_id=1  vedi nel modulo "minicart" in alto che alcuni caratteri sono sconosciuti al browser, inoltre nei pulsanti neri sopra il prezzo puoi vedere anche altri caratteri non riconosciuti dal browser.


Se adesso provi a visualizzare la stessa pagina con codifica del browser in turco vedrai che questi caratteri che ti ho detto qui sopra adesso si vedono bene.. ma questa codifica scazza molte altre lettere del top men, del menu login ecc..


Come cavolo posso risolvere? :(


Devo consegnare il sito e non so come fare helppp!  :'(

 

Torna su