Autore Topic: Assegnare il modulo slideshow all'header nel template Beez2 joomla 1.7  (Letto 14404 volte)

Offline uriel70

  • Esploratore
  • **
  • Post: 79
    • Mostra profilo
Ciao a tutti:D


Vorrei sostituire il mio header con uno slideshow per rendere il mio sito più dinamico!
Per fare questo mi sono servito di questa guida http://wiki.joomla.it/index.php?title=Come_aggiungo_nuove_posizioni_modulo%3F ma credo di aver commesso qualche errore.


1) ho aggiunto nel templateDetails.xml la nuova posizione che ho deciso di chiamare slideshow



<positions>
      <position>debug</position>
      <position>position-0</position>
      <position>position-1</position>
      <position>position-2</position>
      <position>position-3</position>
      <position>position-4</position>
      <position>position-5</position>
      <position>position-6</position>
      <position>position-7</position>
      <position>position-8</position>
      <position>position-9</position>
      <position>position-10</position>
      <position>position-11</position>
      <position>position-12</position>
      <position>position-13</position>
      <position>position-14</position>
      <position>slideshow</position>
   </positions>


2) nel file index.php del template mi si chiede di aggiungere sopra alla riga <jdoc:include type="component" />.


la seguente parte di codice


<jdoc:include type="message" />
                <?php /*<position>slideshow</position> */?>                                       
    <?php if ($this->countModules('slideshow')) : ?>
      <div id="nuovo_div">
        <jdoc:include type="modules" name="slideshow" style="xhtml" />
      <>
   <?php endif; ?>
 <?php /*<position>slideshow</position>*/?>
                                                        <jdoc:include type="component" />.




3) nel file template.css mi si chiede di aggiungere il seguente codice



#nuovo_div {
 float: left;
 width:100%}


Fatto questo, sono andato nella gestione moduli e ho attivato il modulo Plimun Nivo Slider nella posizione creata. Ma non si è sostituito all'header fisso:(((
Potete vedere direttamente il sito da qui http://fitaction.altervista.org/fitaction/


dove sto sbagliando?








Offline adottauncane

  • Team Joomla.it
  • Fuori controllo
  • *******
  • Post: 18027
  • Sesso: Femmina
    • Mostra profilo
    • Adotta un cane
Ciao uriel70,
hai risolto?

Offline uriel70

  • Esploratore
  • **
  • Post: 79
    • Mostra profilo
Ciao!!
Ho seguito la guida, senza avere successo! Poi, facendo alcuni test con le posizioni dei moduli ho risolto il problema.
In poche parole ho fatto i seguenti passi:


Premetto che ho usato il modulo slideshow free chiamato Plimun Nivo Slider.


1) Ho installato il modulo.
2) come posizione ho messo ho messo position-0, e poi ho salvato.
3) Poi, tramite ftp, sono entrato e sono andato a selezionare il template beez2.
e sono andato a cancellare il file png dell'header chiamato personal2.png in Templates-->beez2-->images-->personal-->personal2.png


4) ho regolato le dimenzioni dello slideshow direttamente dal modulo!


funziona tutto alla grande:DDD

Offline adottauncane

  • Team Joomla.it
  • Fuori controllo
  • *******
  • Post: 18027
  • Sesso: Femmina
    • Mostra profilo
    • Adotta un cane
Bene! Ricordati il [RISOLTO] davanti al titolo del primo post. Grazie mille.

Offline aex

  • Abituale
  • ****
  • Post: 1239
  • Sesso: Maschio
    • Mostra profilo
Ciao!!
Ho seguito la guida, senza avere successo! Poi, facendo alcuni test con le posizioni dei moduli ho risolto il problema.
In poche parole ho fatto i seguenti passi:


Premetto che ho usato il modulo slideshow free chiamato Plimun Nivo Slider.


1) Ho installato il modulo.
2) come posizione ho messo ho messo position-0, e poi ho salvato.
3) Poi, tramite ftp, sono entrato e sono andato a selezionare il template beez2.
e sono andato a cancellare il file png dell'header chiamato personal2.png in Templates-->beez2-->images-->personal-->personal2.png


4) ho regolato le dimenzioni dello slideshow direttamente dal modulo!


funziona tutto alla grande:DDD


Scusa ma non ho capito se valgono le modifiche al codice che hai fatto oppure se hai seguito dal punto 1) al punto 4), senza modiche, eccetto l'eliminazione del png

Offline aex

  • Abituale
  • ****
  • Post: 1239
  • Sesso: Maschio
    • Mostra profilo
Ciao!!
Ho seguito la guida, senza avere successo! Poi, facendo alcuni test con le posizioni dei moduli ho risolto il problema.
In poche parole ho fatto i seguenti passi:


Premetto che ho usato il modulo slideshow free chiamato Plimun Nivo Slider.


1) Ho installato il modulo.
2) come posizione ho messo ho messo position-0, e poi ho salvato.
3) Poi, tramite ftp, sono entrato e sono andato a selezionare il template beez2.
e sono andato a cancellare il file png dell'header chiamato personal2.png in Templates-->beez2-->images-->personal-->personal2.png


4) ho regolato le dimenzioni dello slideshow direttamente dal modulo!


funziona tutto alla grande:DDD




Ho apportato le modifiche al codice e messo anch'io slideshow ma quando si va ad assegnare la posizione al modulo, slideshow non è presente in elenco.
Assegnando la posizione 0, la slide va a finire oltre lo spazio predefinito disponibile e ben oltre il top menu.


Come hai risolto....??

Offline adottauncane

  • Team Joomla.it
  • Fuori controllo
  • *******
  • Post: 18027
  • Sesso: Femmina
    • Mostra profilo
    • Adotta un cane
Prova a scrivere slideshow direttamente nella finestra delle posizioni.

Offline aex

  • Abituale
  • ****
  • Post: 1239
  • Sesso: Maschio
    • Mostra profilo
Prova a scrivere slideshow direttamente nella finestra delle posizioni.


Niente da fare. La slide va a finire sotto la ex immagine predefinita e a destra del menu laterale.


Offline adottauncane

  • Team Joomla.it
  • Fuori controllo
  • *******
  • Post: 18027
  • Sesso: Femmina
    • Mostra profilo
    • Adotta un cane
Vedere cammello?  :)

Offline aex

  • Abituale
  • ****
  • Post: 1239
  • Sesso: Maschio
    • Mostra profilo
Mi piacerebbe sapere come ha risolto. la posizione inserita nella index, così come indicato, a me non viene corretta. Infatti risulta sotto la posizione 12 che è praticamente nel corpo principale.
Anche eliminando personal2.png, il richiamo rimane e lo spazio nel layout rimane così com'è. idem modificando il css

Offline aex

  • Abituale
  • ****
  • Post: 1239
  • Sesso: Maschio
    • Mostra profilo
Vedere cammello?  :)


A me basta rivedere....o meglio risentire lui..... :P

Offline aex

  • Abituale
  • ****
  • Post: 1239
  • Sesso: Maschio
    • Mostra profilo
Uriel, puoi spiegarmi meglio? Dalle prove che ho fatto, pare che la posizione di inserimento nell'index, non sia corretta. Per arrivare a posizionare in qualche modo il modulo, sono dovuto salire parecchio.


Se puoi aiutarmi....

Offline uriel70

  • Esploratore
  • **
  • Post: 79
    • Mostra profilo
Ciao Aex,
Il procedimento è più semplice di quanto credessi. Perché non c'è bisogni di mettere mano al codice.


Cerco di spiegarti meglio che posso:DD


1) Ti scarichi il modulo Plimun Nivo Slider che è completamente free.
[/size]2) Lo installi normalmente dal pannello di controllo di joomla.
[/size]3) Poi vai su Gestioni Moduli. Alla tua sinistra trovi la voce "Posizione" e setti la posizione "position-0". Non dare un altro nome al modulo, basta tenere nascosto titolo .
[/size]Alla tua destra trovi tutti i parametri del modulo. Cerca Settings ed inserisci la larghezza e altezza in pixel del tuo slide show. Nel template bee2 è di 1060x288.
[/size]4) Ti prepari 2 slide con photoshop in formato jpg e la vai a mettere in modules/mod_PlimunNivoSlider/images/slide_01.jpg (ovviamente devi entrare nel tuo sito ftp con filezilla o simili).
[/size]5) Sempre via ftp, vai templates-->beez_20-->images-->personal e cancelli fisicamente il personal2.png.

[/size]fai un bel refresh e vedrai che funziona tutto.

[/size]Let me know

Offline aex

  • Abituale
  • ****
  • Post: 1239
  • Sesso: Maschio
    • Mostra profilo
Ciao Aex,
Il procedimento è più semplice di quanto credessi. Perché non c'è bisogni di mettere mano al codice.


Cerco di spiegarti meglio che posso:DD


1) Ti scarichi il modulo Plimun Nivo Slider che è completamente free.
2) Lo installi normalmente dal pannello di controllo di joomla.
3) Poi vai su Gestioni Moduli. Alla tua sinistra trovi la voce "Posizione" e setti la posizione "position-0". Non dare un altro nome al modulo, basta tenere nascosto titolo .
Alla tua destra trovi tutti i parametri del modulo. Cerca Settings ed inserisci la larghezza e altezza in pixel del tuo slide show. Nel template bee2 è di 1060x288.
4) Ti prepari 2 slide con photoshop in formato jpg e la vai a mettere in modules/mod_PlimunNivoSlider/images/slide_01.jpg (ovviamente devi entrare nel tuo sito ftp con filezilla o simili).
5) Sempre via ftp, vai templates-->beez_20-->images-->personal e cancelli fisicamente il personal2.png.

fai un bel refresh e vedrai che funziona tutto.

Let me know


Si, ma in questo modo mi sono perso il Top Menu in Posizione 1 e mi servirebbe. Se il modulo è pubblicato in posizione 0, non capisco perchè vado a perdere il menu.....

Offline uriel70

  • Esploratore
  • **
  • Post: 79
    • Mostra profilo
Ciao:D


Io invece il top menù l'ho tolto e ho mantenuto solo quello verticale!
Per le mie conoscenze, aver messo uno slideshow al posto dell'header è stata una conquista!
Magari prova a cambiare le dimensioni dello slideshow. Mantieni la larghezza a 1060 px e riduci l'altezza a 200 px e fai una prova.


Offline adottauncane

  • Team Joomla.it
  • Fuori controllo
  • *******
  • Post: 18027
  • Sesso: Femmina
    • Mostra profilo
    • Adotta un cane
@aex,
se non serve alla comprensione della risposta non citare il post recedente, appesantisce inutilmente. Grazie mille.

Offline aex

  • Abituale
  • ****
  • Post: 1239
  • Sesso: Maschio
    • Mostra profilo
Ciao:D


Io invece il top menù l'ho tolto e ho mantenuto solo quello verticale!
Per le mie conoscenze, aver messo uno slideshow al posto dell'header è stata una conquista!
Magari prova a cambiare le dimensioni dello slideshow. Mantieni la larghezza a 1060 px e riduci l'altezza a 200 px e fai una prova.




Io non l'ho tolto ma è sparito. E' anche vero che ho inserito un'img da 350px di altezza, ho modificato personal.css adeguando la nuova altezza ma lo slider del modulo, sembra che sia meno alto di quello che dovrebbe essere
La tua soluzione mi sembra valida nel senso che si raggiunge il fine, però ho l'impressione che non sia proprio pulitissima.


Vedrò di trovare qualche soluzione alternativa


Offline uriel70

  • Esploratore
  • **
  • Post: 79
    • Mostra profilo
La dimensione del file originale, quello chiamato personal2.png misura 1060x288 px.
Inoltre, controlla anche la misura dell'header nel file personal.css (riga 94) che dovrebbe essere di  200px.



.logoheader
{


   background:  #0c1a3e  URL(../images/personal/personal2.png) no-repeat bottom right ;
   color:#fff;
   min-height:200px;
   margin:0em 10px 0 10px !important;


}


sostituisci min-height:200px; con min-height:288px; oppure metti la dimensione che vuoi.


Oppure potresti lasciare 200 e diminuire la dimensione dell'altezza direttamente dai parametri dello slideshow.


Let me know

Offline aex

  • Abituale
  • ****
  • Post: 1239
  • Sesso: Maschio
    • Mostra profilo
La dimensione del file originale, quello chiamato personal2.png misura 1060x288 px.
Inoltre, controlla anche la misura dell'header nel file personal.css (riga 94) che dovrebbe essere di  200px.



.logoheader
{


   background:  #0c1a3e  URL(../images/personal/personal2.png) no-repeat bottom right ;
   color:#fff;
   min-height:200px;
   margin:0em 10px 0 10px !important;


}


sostituisci min-height:200px; con min-height:288px; oppure metti la dimensione che vuoi.


Oppure potresti lasciare 200 e diminuire la dimensione dell'altezza direttamente dai parametri dello slideshow.


Let me know


Ho risolto con il beez5, che prevede anche la posizione per l'header.

Offline uriel70

  • Esploratore
  • **
  • Post: 79
    • Mostra profilo
Grande, mi fa molto piacere ;D

 

Torna su