Autore Topic: Problema caricamento immagine su un sito.  (Letto 4015 volte)

Offline r.colzi

  • Nuovo arrivato
  • *
  • Post: 18
    • Mostra profilo
Problema caricamento immagine su un sito.
« il: 26 Set 2013, 16:35:21 »
Salve,
ho postato qualche giorno fa un topic per un problema allo stesso sito di cui parlerò ora.

Il sito in questione è: http://www.akumaltravel.it/
Ecco, dovrei mettere il logo che si trova sul lato destro della slide, ANCHE sotto il giglio rosso che si trova sulla sinistra della pagina.
Non essendo ancora molto pratico dei cms non riesco a capire come fare, perchè il codice html viene generato automaticamente, quindi penso di dover modificare i CSS. Se qualcuno potesse darmi una mano, gli sarei molto grato.
Ho anche un ulteriore problema, ossia che il logo sul lato destro della slide è un po troppo allungato, quindi ho tentato di modificare i CSS con FireBug modificando la prorietà "Width" relativa al logo per vedere se riuscivo ad "allargarlo", ma ciò che avviene è che esso viene spostato o verso destra o verso sinistra... :o

Vi ringrazio in anticipo...

Offline adottauncane

  • Moderator
  • Fuori controllo
  • *****
  • Post: 18049
  • Sesso: Femmina
    • Mostra profilo
    • Adotta un cane
Re:Problema caricamento immagine su un sito.
« Risposta #1 il: 27 Set 2013, 01:48:37 »
Ciao r.colzi,
ma, per mettere il logo sotto il giglio dal css devi correggere così:

Codice: [Seleziona]
#giglio {    background: url("/immagini/mexican.png") no-repeat scroll center 110px rgba(0, 0, 0, 0);    height: 324px;    position: absolute;    right: 966px;    top: 60px;    width: 190px;}lo trovi nel file template.css, non so dirti la riga, hai una compressione dei css.

Però potresti anche fare un'unica immagine giglio + marchio e poi cambiare solo le misure del contenitore...

Per ridimensionare correttamente il logo aggiungi questo al fondo del file template.css

Codice: [Seleziona]
#logo h1 img {    height: 90% !important;    width: 90% !important;}
Però da qualche parte hai impostato misure diverse per il logo. Magari nelle impostazioni in backend... Se riesci aggiusta quelle che ci sono, altrimenti il css che aggiungi le sovrascrive comunque.


Offline r.colzi

  • Nuovo arrivato
  • *
  • Post: 18
    • Mostra profilo
Re:Problema caricamento immagine su un sito.
« Risposta #2 il: 01 Ott 2013, 00:49:17 »
Ciao r.colzi,
ma, per mettere il logo sotto il giglio dal css devi correggere così:

Codice: [Seleziona]
#giglio {    background: url("/immagini/mexican.png") no-repeat scroll center 110px rgba(0, 0, 0, 0);    height: 324px;    position: absolute;    right: 966px;    top: 60px;    width: 190px;}lo trovi nel file template.css, non so dirti la riga, hai una compressione dei css.

Però potresti anche fare un'unica immagine giglio + marchio e poi cambiare solo le misure del contenitore...

Per ridimensionare correttamente il logo aggiungi questo al fondo del file template.css

Codice: [Seleziona]
#logo h1 img {    height: 90% !important;    width: 90% !important;}
Però da qualche parte hai impostato misure diverse per il logo. Magari nelle impostazioni in backend... Se riesci aggiusta quelle che ci sono, altrimenti il css che aggiungi le sovrascrive comunque.
Ti ringrazio infinitamente, però vorrei chiederti se possibile una cosa. Come funziona il codice css che mi hai postato per inserire il logo sotto al giglio? Com'è possibile che il giglio rimanga nello stesso posto e appaia sotto a lui il logo, pur cambiando tutto il codice relativo al giglio?
Se non sono stato chiaro provo a spiegarlo in altro modo... (fare domande di questo tipo è complicato... :\)

Offline adottauncane

  • Moderator
  • Fuori controllo
  • *****
  • Post: 18049
  • Sesso: Femmina
    • Mostra profilo
    • Adotta un cane
Re:Problema caricamento immagine su un sito.
« Risposta #3 il: 05 Ott 2013, 11:49:47 »
Il giglo è caricato direttamente dal .php del template, non con il suo css. Così l'immagine del giglio non è influenzata dalla modifica css del suo div.

 

Torna su