Autore Topic: Problema file .ini lingua NL non funzionante  (Letto 15443 volte)

Offline lucsound

  • Esploratore
  • **
  • Post: 106
    • Mostra profilo
Problema file .ini lingua NL non funzionante
« il: 22 Mag 2014, 14:36:04 »
Ciao a tutti.

Nel mio sito ho attivato diverse lingue tra cui inglese, tedesco e olandese.
L'italiano va bene mentre le altre lingue no.

Ho caricato nel cartella language del mio template le varie cartelle ad esempio nl-NL e inserito dentro il file ini 'nl-NL.tpl_MIOTEMPLATE.ini'

Al cambio lingua non va. Ho provato allora ad inserire quel file nella cartella generale language di joomla e non va nemmeno li.

In amministrazione però le lingue sono attive, il plugin a posto. Non so proprio perchè non va.
Qualche soluzione?  :(

E' una cosa molto strana.
Non vanno nemmeno le altre lingue, solo l'italiano va bene.


Offline ste

  • Administrator
  • Instancabile
  • *****
  • Post: 8772
  • Sesso: Femmina
    • Mostra profilo
Re:Problema file .ini lingua NL non funzionante
« Risposta #1 il: 22 Mag 2014, 15:08:08 »
Ciao lucsound,
hai provato ad inserire i file lignua nelle rispettive cartelle in administrator/language?
TTI - Team Traduzione Italiano di Joomla.it - Guide su Joomla

Offline lucsound

  • Esploratore
  • **
  • Post: 106
    • Mostra profilo
Re:Problema file .ini lingua NL non funzionante
« Risposta #2 il: 22 Mag 2014, 17:30:52 »
Si adesso ho provato ma non funziona.

Offline lucsound

  • Esploratore
  • **
  • Post: 106
    • Mostra profilo
Re:Problema file .ini lingua NL non funzionante
« Risposta #3 il: 23 Mag 2014, 11:06:42 »
Qualche soluzione??  :( :(

Offline ste

  • Administrator
  • Instancabile
  • *****
  • Post: 8772
  • Sesso: Femmina
    • Mostra profilo
Re:Problema file .ini lingua NL non funzionante
« Risposta #4 il: 23 Mag 2014, 11:14:02 »
Al cambio lingua tutte le altre variabili lingua del frontend vengono tradotte?
TTI - Team Traduzione Italiano di Joomla.it - Guide su Joomla

Offline lucsound

  • Esploratore
  • **
  • Post: 106
    • Mostra profilo
Re:Problema file .ini lingua NL non funzionante
« Risposta #5 il: 23 Mag 2014, 11:18:50 »
Le voci di menu per le singole lingue funzionano ma i testi caricati con  JText::_('TESTO'); purtroppo no

Offline ste

  • Administrator
  • Instancabile
  • *****
  • Post: 8772
  • Sesso: Femmina
    • Mostra profilo
Re:Problema file .ini lingua NL non funzionante
« Risposta #6 il: 23 Mag 2014, 12:48:37 »
Puoi darmi un link al sito per vedere?
TTI - Team Traduzione Italiano di Joomla.it - Guide su Joomla

Offline lucsound

  • Esploratore
  • **
  • Post: 106
    • Mostra profilo
Re:Problema file .ini lingua NL non funzionante
« Risposta #7 il: 23 Mag 2014, 17:31:38 »
No non posso perchè il sito è in versione demo non accessibile a terzi.
E' un progetto che non posso far vedere.

Sto riprovando con le lingue ma niente.
L'unica cosa che ho tralasciato è che le lingue vengono gestite dal componente FALANG e in più non ho settato  l'homepage per ciascuna lingua.
Ma ciò non dovrebbe essere indispensabile perchè falang gestite le pagine in maniera diversa anche senza associazione.

Qualche possibile idea o soluzione?

Offline ste

  • Administrator
  • Instancabile
  • *****
  • Post: 8772
  • Sesso: Femmina
    • Mostra profilo
Re:Problema file .ini lingua NL non funzionante
« Risposta #8 il: 23 Mag 2014, 23:50:59 »
Se utilizzi una 2.5 o una 3 di Joomla allora utilizza il miltilingua nativo, seguendo bene le istruzioni riportate qui
http://www.joomla.it/mediawiki/index.php?title=Joomla!_2.5:Gestione_multilingua

PS: Quando apri una discussione gentilmente inserisci tutte le indicazioni utili a capire il problema e la versione di Joomla che utilizzi, grazie ;)
« Ultima modifica: 24 Mag 2014, 00:02:54 da ste »
TTI - Team Traduzione Italiano di Joomla.it - Guide su Joomla

Offline lucsound

  • Esploratore
  • **
  • Post: 106
    • Mostra profilo
Re:Problema file .ini lingua NL non funzionante
« Risposta #9 il: 24 Mag 2014, 13:49:18 »
Provo allora a disattivare falang e ad utilizzare le importazioni standard ma non penso che sia quello il problema.

Farò sapere se risolvo o meno.

Grazie per adesso.

Offline lucsound

  • Esploratore
  • **
  • Post: 106
    • Mostra profilo
Re:Problema file .ini lingua NL non funzionante
« Risposta #10 il: 24 Mag 2014, 15:43:09 »
Allora.

Ho disattivato Falang, impostato le homepage per ogni lingua ma il risultato non cambia. Falang non è la causa.
Comunque ho notato che le lingue sono attive perchè al cambio lingua le digiture proprie di joomla e di altri componenti vengono tradotti.

Il problema dovrebbe stare nel file o nel suo nome perchè cosi non va proprio. Se inserisco qualche scritta in questi file dei componenti va bene ma se li metto nel mio file del template niente.

Inoltre non va nemmeno se rinomino il file ini mettendogli un nome tipo di un componente.

L'unica alternativa che ho trovato è inserire le stringhe nel file content di Joomla ma cosi non riesco ad organizzare bene le stringhe separandole dalle altre.

Qualche idea su che cosa potrebbe essere?

Offline ste

  • Administrator
  • Instancabile
  • *****
  • Post: 8772
  • Sesso: Femmina
    • Mostra profilo
Re:Problema file .ini lingua NL non funzionante
« Risposta #11 il: 25 Mag 2014, 15:29:38 »
Non capisco...
Quel file ini del template l'hai preso da un file lingua in inglese del template che utilizzi?
TTI - Team Traduzione Italiano di Joomla.it - Guide su Joomla

 

Torna su