Autore Topic: [Risolto] Problema grafico template  (Letto 1463 volte)

Offline WillerCT

  • Appassionato
  • ***
  • Post: 407
  • Sesso: Maschio
    • Mostra profilo
[Risolto] Problema grafico template
« il: 10 Mar 2015, 22:23:28 »
Salve a tutti,

ho un problema con il template del mio sito. In sostanza, attivando un banner nella posizione appunto "banner"  ::) , attorno ad esso appare un fastidioso margine ed inoltre non presente lo sfondo. Non so se mi sono spiegato...ad ogni modo, il sito *** ed il problema visibile nella parte bassa, dove ho pubblicato un banner di prova in formato jpeg...allego screenshoot.

Grazie anticipatamente
« Ultima modifica: 12 Mar 2015, 18:42:55 da WillerCT »

Offline maxzilla

  • Appassionato
  • ***
  • Post: 620
  • Sesso: Maschio
    • Mostra profilo
Re:Problema grafico template
« Risposta #1 il: 11 Mar 2015, 10:12:20 »
Ciao WillerCT io non vedo banner a fondo pagina, lo hai tolto?
Ikonart Informatica - Trento

"Mangia prodotti italiani. W il made in Italy"

Offline WillerCT

  • Appassionato
  • ***
  • Post: 407
  • Sesso: Maschio
    • Mostra profilo
Re:Problema grafico template
« Risposta #2 il: 11 Mar 2015, 10:25:27 »
Si, ora nuovamente attivo  8)

Offline maxzilla

  • Appassionato
  • ***
  • Post: 620
  • Sesso: Maschio
    • Mostra profilo
Re:Problema grafico template
« Risposta #3 il: 11 Mar 2015, 10:39:41 »
L'immagine deve essere portata a 980px anziche' 960 di larghezza

poi in layouts.cc alla riga 254

bisognerebbe aggiungere
margin:0;
padding:0;

diventa

#mx-banner {   
text-align: center;
margin:0;
padding:0;
}
Ikonart Informatica - Trento

"Mangia prodotti italiani. W il made in Italy"

Offline WillerCT

  • Appassionato
  • ***
  • Post: 407
  • Sesso: Maschio
    • Mostra profilo
Re:Problema grafico template
« Risposta #4 il: 11 Mar 2015, 10:58:52 »
Non succede nulla...cmq io vorrei che anche pubblicando un banner pi piccolo non si vedesse il nero attorno, quindi ad esempio aggiungendo un background dello stesso grigio che fa da sfondo al men sottostante potrebbe andare bene.

Offline maxzilla

  • Appassionato
  • ***
  • Post: 620
  • Sesso: Maschio
    • Mostra profilo
Re:Problema grafico template
« Risposta #5 il: 11 Mar 2015, 11:36:36 »
ci sono ancora questi parametri

<img width="960" height="90" alt="banner bottom" src="/images/varie/banner-bottom.jpg" style="margin-right: auto; margin-bottom: 5px; display: block; margin-left: 0;">

da cambiare in

<img width="980" height="90" alt="banner bottom" src="/images/varie/banner-bottom.jpg" style="margin:0; padding: 0;">
Ikonart Informatica - Trento

"Mangia prodotti italiani. W il made in Italy"

Offline maxzilla

  • Appassionato
  • ***
  • Post: 620
  • Sesso: Maschio
    • Mostra profilo
Re:Problema grafico template
« Risposta #6 il: 11 Mar 2015, 11:42:48 »
per lo sfondo potresti modificare quello di prima in

#mx-banner {   
text-align: center;
margin:0;
padding:0;
background-color: #CACACA;
}

ma lo vedi solo se ci sara' un testo sopra o un'immagine piu' piccola dello spazio banner
Ikonart Informatica - Trento

"Mangia prodotti italiani. W il made in Italy"

Offline WillerCT

  • Appassionato
  • ***
  • Post: 407
  • Sesso: Maschio
    • Mostra profilo
Re:Problema grafico template
« Risposta #7 il: 11 Mar 2015, 13:09:38 »
Non riesco a far sparire il margine sopra e sotto il banner

Offline maxzilla

  • Appassionato
  • ***
  • Post: 620
  • Sesso: Maschio
    • Mostra profilo
Re:Problema grafico template
« Risposta #8 il: 11 Mar 2015, 18:23:54 »
non hai cambiato i parametri nel modulo html in
<img width="980" height="90" alt="banner bottom" src="/images/varie/banner-bottom.jpg" style="margin:0; padding: 0;">
Ikonart Informatica - Trento

"Mangia prodotti italiani. W il made in Italy"

Offline WillerCT

  • Appassionato
  • ***
  • Post: 407
  • Sesso: Maschio
    • Mostra profilo
Re:Problema grafico template
« Risposta #9 il: 11 Mar 2015, 19:00:47 »
Come devo intervenire ? Ho copiato il codice e l'ho incollato sul modulo ed attualmente il banner si spostato tutto in alto ma il margine nero sempre l. Forse sbaglio procedura.  ::)

Offline maxzilla

  • Appassionato
  • ***
  • Post: 620
  • Sesso: Maschio
    • Mostra profilo
Re:Problema grafico template
« Risposta #10 il: 12 Mar 2015, 09:28:28 »

per il banner stai usando un modulo html personalizzato?

prova a togliere il paragrafo
<p>
...
</p>

e lascia solo
<img width="980" height="90" alt="banner bottom" src="/images/varie/banner-bottom.jpg" style="margin:0; padding: 0;">
Ikonart Informatica - Trento

"Mangia prodotti italiani. W il made in Italy"

Offline WillerCT

  • Appassionato
  • ***
  • Post: 407
  • Sesso: Maschio
    • Mostra profilo
Re:Problema grafico template
« Risposta #11 il: 12 Mar 2015, 18:41:46 »
Ok funziona togliendo <p> nel modulo html, mentre se utilizzo il modulo banner tutto fila liscio. Grazie

 

Torna su