Autore Topic: [RISOLTO] Problema sfondo non in tutte le pagine  (Letto 2141 volte)

Offline Zio_Jack

  • Nuovo arrivato
  • *
  • Post: 13
    • Mostra profilo
[RISOLTO] Problema sfondo non in tutte le pagine
« il: 27 Ago 2015, 00:00:48 »
Buonasera a tutti.

Nella mia pagina web (www.koredanza.com) utilizzo un template TD Okini e ho voluto mettere, dove si trova lo slideshow, uno sfondo con dei listelli di legno bianco.

Sono riuscito, dopo vari tentativi, aggiungendo questo codice (segnalato in rosso) al file index.php:

<div id="header_wrap">
         <style>
        #header_wrap {
                          background: url('images/abete-bianco2.png')
                                   }
        </style>



E QUESTO

90    #slideshow {
91      min-width: 1068px;
92      background: url('<?php echo $this->baseurl ?>/templates/<?php echo $this->template; ?>/images/slide_shadow.png') no-repeat center bottom,   url ('images/abetebianco2.png');
94      background-color: #000;
95      margin-bottom: -1px;
96    }


Il problema è che questi due sfondi rimangono solamente quando clicco sulle voci di menu principali. Se clicco su una voce di menu secondaria tipo questa: http://www.koredanza.com/sitoaggiornato/la-scuola/corsi-2 i due sfondi tornano ad essere quelli originali. Qualcuno saprebbe aiutarmi?

Vi ringrazio tantissimo in anticipo
 
« Ultima modifica: 27 Ago 2015, 12:42:57 da Zio_Jack »

Offline adottauncane

  • Team Joomla.it
  • Instancabile
  • *******
  • Post: 17972
  • Sesso: Femmina
    • Mostra profilo
    • Adotta un cane
Re:Problema sfondo non in tutte le pagine
« Risposta #1 il: 27 Ago 2015, 00:41:14 »
Ciao Zio_Jack
prova ad aggiungere ../ davanti all'url così:

url('../images/abete-bianco2.png')

Offline Zio_Jack

  • Nuovo arrivato
  • *
  • Post: 13
    • Mostra profilo
Re:Problema sfondo non in tutte le pagine
« Risposta #2 il: 27 Ago 2015, 12:42:38 »
Ha funzionato!!!  :D :D :D :D

Posso chiederti la spiegazione di questo?

GRAZIE MILLE

Offline adottauncane

  • Team Joomla.it
  • Instancabile
  • *******
  • Post: 17972
  • Sesso: Femmina
    • Mostra profilo
    • Adotta un cane
Re:[RISOLTO] Problema sfondo non in tutte le pagine
« Risposta #3 il: 27 Ago 2015, 12:50:29 »
Sarebbe probabilmente meglio fare queste variazioni sul file .css del template, anzi magari creare un file custom.css per le modifiche in modo che un eventuale aggiornamento del template non ripristini il settaggio originale.

In sostanza aggiungere ../ davanti permette di caricare il file anche dalle "sottopagine" e non solo da quella principale.
Le sottopagine non trovano altrimenti il percorso corretto.

 

Torna su