Autore Topic: Fatal error: Call to a member function get() on a non-object in  (Letto 1283 volte)

Offline neonove

  • Nuovo arrivato
  • *
  • Post: 9
  • Sesso: Maschio
    • Mostra profilo
Buongiorno a tutti,
confido nel vostro aiuto!!!
sto ricevendo un errore che pare derivare da kunena (da cui provo a scrivere in questa parte del forum):

Fatal error: Call to a member function get() on a non-object in /home/nomesito/public_html/components/com_kunena/views/topics/view.html.php on line 359

l'errore potrebbe derivare da ultimo aggiornamento effettuato ieri sera di kunena (unica modifica sostanziale da me fatta) questo tipo di errore non si riflette sul forum, ma sul sito, compare accedendo alla lista di file che gestisco con jdownloads, accedendo a qualunque ricerca sul sito ed ancora mi ha fatto sparire alcuni moduli (tra cui proprio quelli di jdowloads) e non sono più ripristinabili)
non so come uscirne se non facendo un ripristino del databse (cosa che volevo evitare).
non sono un esperto, un semplice amatore che gestisce una piccola community privata per un gruppo di amici.
spero vivamente in un vostro aiuto, o almeno in qualche dritta per sistemare (aggirare) l'errore.
grazie in anticipo,



edit:
nel caso: mi chiedo se sia possibile reinstallare kunena non perdendo i vari settaggi (categorie) ed i post
« Ultima modifica: 14 Gen 2016, 17:59:49 da neonove »

Offline neonove

  • Nuovo arrivato
  • *
  • Post: 9
  • Sesso: Maschio
    • Mostra profilo
Re:Fatal error: Call to a member function get() on a non-object in
« Risposta #1 il: 17 Gen 2016, 21:15:35 »
e niente ...
sovrascrivere il componenete non è servito a nulla,
l'unica soluzione che ho trovato è stata disinstallare e reinstallare kunena, con buona pace di tutte le discussioni aperte ed in corso (non molte tra l'altro)
grazie in ogni caso,
buona serata
n.

Offline neonove

  • Nuovo arrivato
  • *
  • Post: 9
  • Sesso: Maschio
    • Mostra profilo
Re:Fatal error: Call to a member function get() on a non-object in
« Risposta #2 il: 02 Mag 2016, 16:40:14 »

Ripropongo questo post, in quanto il problema mi si è ripresentato, ma con qualche novità..
Il problema non l'ho risolto, ma quantomeno isolato, per cui a beneficio di chi necessitasse e/o si trovasse in una situazione simile:
Leggendo nel forum di Kunena, il problema è attribuibile al modulo "Kunena Latest Module", che per capirci, è il modulo che permette di visualizzare gli ultimi messaggi presenti nel forum.
disattivando il modulo, non si ottiene più l'errore di cui ai messaggi precedenti.
Il problema non è risolto, ma almeno è circoscritto.
In attesa di trovare una soluzione definitiva (il modulo in fondo mi servirebbe anche).....
un saluto a tutti.

 

Torna su