Autore Topic: Custom form fields non trovati [RISOLTO]  (Letto 509 volte)

Offline giovi

  • Instancabile
  • ******
  • Post: 9761
  • Sesso: Maschio
    • Mostra profilo
    • Simple
Custom form fields non trovati [RISOLTO]
« il: 23 Mag 2016, 13:23:01 »
Nello sviluppo di un componente ho trovato comodo creare dei custom form fields seguendo questo riferimento: https://docs.joomla.org/Creating_a_custom_form_field_type


In locale tutto ok, quando installo l'estensione in remoto (in sottodirectory), aprendo la maschera di configurazione del componente, i campi custom vengono visti come semplici textbox.


Vi mai successo?


Al config.xml ho gi aggiunto l'attributo addfieldpath="/administrator/components/com_componente/model/fields"


Non ne vengo fuori.
« Ultima modifica: 23 Mag 2016, 13:27:41 da giovi »
Che ti costa? Se ti ho aiutato, aiutami anche tu votando Simple sulla Joomla! Extension Directory

Offline giovi

  • Instancabile
  • ******
  • Post: 9761
  • Sesso: Maschio
    • Mostra profilo
    • Simple
Re:Custom form fields non trovati [RISOLTO]
« Risposta #1 il: 23 Mag 2016, 13:27:17 »
Che dire, magico effetto risolutore del forum  ;D  Appena ho aperto la discussione ho trovato la soluzione. Il mio sistema di sviluppo (stranamente) case-insensitive mentre quello remoto abbastanza permaloso a riguardo (anche se non lascia tracce di log). E' bastato rinominare in minuscolo (e conseguentemente correggendo anche il config.xml) i nomi dei custom form fields... et voila!


Spero che questa info possa essere utile a qualcuno (ma anche a me stesso se in futuro dovesse riaccendermi!)
Che ti costa? Se ti ho aiutato, aiutami anche tu votando Simple sulla Joomla! Extension Directory

 

Torna su