Autore Topic: URL richieste ma non trovate (codice HTTP 404) in multilingua  (Letto 863 volte)

Offline danjde

  • Esploratore
  • **
  • Post: 192
  • Sesso: Maschio
    • Mostra profilo
    • cosmogoniA
Salve amici,
su di un sito Joomla 3.5.1 multilinga, italiano/inglese
analizzando il traffico del sito tramite awstats, mi rendo conto che esistono tutta una serie di pagine che ottengono errore 404, ecco un esempio:

URL (382)                                                                                                                       Accessi con errore        Provenienza                   

/it/plugins/jsnimageshow/themeflow/assets/images/slider_h_bg.gif     1.038                                     http://www.miosito.it/it/
/it/                                                                                                                                     9                                             http://miosito.it/
/it/fancybox/fancy_shadow_sw.png                                                                     9                                            -



Di cosa si tratta? Devo contattare, per esempio, lo sviluppatore del componente "jsnimageshow" o si tratta di un errore mio di configurazione?
Oltre a questi, l'elenco prosegue con altri elementi non trovati sempre in  "/it" o in "/en".

Grazie infinite
cosmogoniA
n o p r o v a r e n o f a r e o n o n f a r e n o n c e p r o v a r e

Offline MariaElenaBoschi

  • Appassionato
  • ***
  • Post: 469
    • Mostra profilo
Re:URL richieste ma non trovate (codice HTTP 404) in multilingua
« Risposta #1 il: 01 Lug 2016, 22:22:55 »
beh dai non è tanto difficile...

ti dice che da http://www.miosito.it/it/ viene richiesta questa immagine /it/plugins/jsnimageshow/themeflow/assets/images/slider_h_bg.gif  e non c'è.
Trova cosa richiede quell'immagine poi si vede perchè, credo che il problema sia l'it nella path
« Ultima modifica: 01 Lug 2016, 23:07:18 da MariaElenaBoschi »
mancano 2 giorni alla mia prematura dipartita, saluti a tutti, meb.

Offline danjde

  • Esploratore
  • **
  • Post: 192
  • Sesso: Maschio
    • Mostra profilo
    • cosmogoniA
Re:URL richieste ma non trovate (codice HTTP 404) in multilingua
« Risposta #2 il: 02 Lug 2016, 18:39:37 »
[..] credo che il problema sia l'it nella path

..fin qua c'ero arrivato anch'io.
Il problema è perchè il suffisso crea questo problema o meglio ancora perchè il componete/plugin utilizzi una chiamata con suffisso per arrivare ad una gif..

Proverò a sentire lo sviluppatore. Chiarito uno degli errori poi credo sia facile risolvere i rimanenti.

Poi aggiornerò il post.


grazie comunque :-)
cosmogoniA
n o p r o v a r e n o f a r e o n o n f a r e n o n c e p r o v a r e

Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 27478
  • Sesso: Maschio
  • Chi si specializza muore. Chi divaga troppo affoga
    • Mostra profilo
    • Xataface Italia
Re:URL richieste ma non trovate (codice HTTP 404) in multilingua
« Risposta #3 il: 02 Lug 2016, 19:37:05 »
Fai prima ad eliminare il suffisso lingua per la lingua italiana, in un dominio .it non serve averlo.
NEWS DataGrill Xataface Installer (Ver. 1.0.0) per Joomla 3.6 ed un Esempio Applicazione Bblioteca

Offline danjde

  • Esploratore
  • **
  • Post: 192
  • Sesso: Maschio
    • Mostra profilo
    • cosmogoniA
Re:URL richieste ma non trovate (codice HTTP 404) in multilingua
« Risposta #4 il: 03 Lug 2016, 10:27:04 »
..il problema c'è anche per il suffisso "en".
Può essere un problema del componente/plugin interno Joomla che gestisce le lingue?

Grazie ancora per il gentile aiuto :-)
cosmogoniA
n o p r o v a r e n o f a r e o n o n f a r e n o n c e p r o v a r e

Offline $Red

  • Team Joomla.it
  • Instancabile
  • *******
  • Post: 4661
  • "Bastard Inside"
    • Mostra profilo
    • redwebsite
Re:URL richieste ma non trovate (codice HTTP 404) in multilingua
« Risposta #5 il: 03 Lug 2016, 10:41:13 »
Ciao, secondo me è sicuramente un problema del plugin, avevo un problema simile con le mappe di contentmap segnalato qui ed Alex l'ha risolto, quindi segnalalo allo sviluppatore sicuramente farà le modifiche necessarie
alterjoomla Guide joomla altervista - RedWebSite  joomla! e non solo joomla!
L'Anguilla! no non é un serpente né uno strano pesce

Offline danjde

  • Esploratore
  • **
  • Post: 192
  • Sesso: Maschio
    • Mostra profilo
    • cosmogoniA
Re:URL richieste ma non trovate (codice HTTP 404) in multilingua
« Risposta #6 il: 04 Lug 2016, 16:02:17 »
..per cui escludi che possa trattarsi di un problema del plugin multilingua.
Tu sostieni se ho ben capito che alcuni sviluppatori dei diversi plugin progettano i loro software non perfettamente aderenti alle specifiche multilingua. Mi confermi?


Grazie
cosmogoniA
n o p r o v a r e n o f a r e o n o n f a r e n o n c e p r o v a r e

Offline $Red

  • Team Joomla.it
  • Instancabile
  • *******
  • Post: 4661
  • "Bastard Inside"
    • Mostra profilo
    • redwebsite
Re:URL richieste ma non trovate (codice HTTP 404) in multilingua
« Risposta #7 il: 04 Lug 2016, 16:39:39 »
secondo me non è un problema del multilingua! e comunque non mi permetterei mai di giudicare il lavoro degli sviluppatori visto che di codice ci capisco quanto di energia nucleare  ;D , ti ho solo riportato un problema simile a cui lo sviluppatore dell'estensione ha rimediato  :)
alterjoomla Guide joomla altervista - RedWebSite  joomla! e non solo joomla!
L'Anguilla! no non é un serpente né uno strano pesce

 

Torna su