Autore Topic: Versione php utilizzabile  (Letto 851 volte)

Offline smy2029

  • Nuovo arrivato
  • *
  • Post: 24
    • Mostra profilo
Versione php utilizzabile
« il: 19 Set 2016, 11:17:21 »
Buongiorno a tutti, gestisco un sito joomla, versione 1.5.24, per vari motivi non posso aggiornarlo a versioni superiori (plugin, componenti ecc...)...Dovrò aggiornare la versione PHP del mio diminio a 5.3.29, avrò problemi o il sito continuerà a funzionare regolarmente? Grazie

Offline alexred

  • Administrator
  • Fuori controllo
  • *****
  • Post: 25211
  • Sesso: Maschio
  • Esperto in ozio relaxed
    • Mostra profilo
    • AlexRed.com
Re:Versione php utilizzabile
« Risposta #1 il: 19 Set 2016, 11:38:38 »
Ciao smy2029,
Joomla 1.5 è compatibile con PHP 5.3.29 ed anche con PHP 5.4, ma non lo è con PHP 5.5 e successivi.

Ti consiglio almeno di aggiornare alla versione 1.5.26  e relativa successiva patch di sicurezza che trovi qui:
http://www.joomla.it/download/joomla-15/joomla-15-1-5-26.html

Adoperati per backup giornalieri automatici perchè sia PHP 5.3 che Joomla 1.5 sono vulnerabili e facilmente attaccabili, vengono automaticamente bucati siti con queste vecchie configurazioni.

Offline smy2029

  • Nuovo arrivato
  • *
  • Post: 24
    • Mostra profilo
Re:Versione php utilizzabile
« Risposta #2 il: 19 Set 2016, 12:47:57 »
Grazie, e la versione 1.5.26 è compatibile anche con le versioni più recenti di php, tipo 5.6 ecc..?
ho visto poi che mi suggerisce di eliminare il template ja_purity, ma io uso proprio quello (si tratta di un sito di gestione file interni), devo per forza farlo?

Offline alexred

  • Administrator
  • Fuori controllo
  • *****
  • Post: 25211
  • Sesso: Maschio
  • Esperto in ozio relaxed
    • Mostra profilo
    • AlexRed.com
Re:Versione php utilizzabile
« Risposta #3 il: 19 Set 2016, 13:05:42 »
No, la 1.5.26 non è compatibile con le recenti versioni di PHP.

Per il ja_purity mi pare di ricordare una falla di tipo XSS

 

Torna su