Autore Topic: [Risolto] Problema visualizzazione menu con http e https  (Letto 669 volte)

Offline unpodicose

  • Esploratore
  • **
  • Post: 57
  • Sesso: Maschio
    • Mostra profilo
    • un po di cose
Ciao a tutti, ho un sito che ha sempre funzionato alla grande con il classico http://.
Ho installato il certificato ed ora posso anche utilizzare https://
Il problema che mi cambia il men principale, in https mi modifica il font e mi va a capo l'ultima voce.
Se l'amministratore mi da l'ok, metto il link del sito.
« Ultima modifica: 26 Gen 2017, 17:12:24 da unpodicose »

Offline alexred

  • Administrator
  • Fuori controllo
  • *****
  • Post: 25370
  • Sesso: Maschio
  • Esperto in ozio relaxed
    • Mostra profilo
    • AlexRed.com
Re:Problema visualizzazione menu con http e https
« Risposta #1 il: 26 Gen 2017, 16:57:15 »
Ciao unpodicose,
si, puoi mettere il link al sito, cos verifichiamo

Offline unpodicose

  • Esploratore
  • **
  • Post: 57
  • Sesso: Maschio
    • Mostra profilo
    • un po di cose

Offline unpodicose

  • Esploratore
  • **
  • Post: 57
  • Sesso: Maschio
    • Mostra profilo
    • un po di cose
Re:Problema visualizzazione menu con http e https
« Risposta #3 il: 26 Gen 2017, 17:08:07 »
credo di aver risolto

Offline unpodicose

  • Esploratore
  • **
  • Post: 57
  • Sesso: Maschio
    • Mostra profilo
    • un po di cose
Re:Problema visualizzazione menu con http e https
« Risposta #4 il: 26 Gen 2017, 17:11:51 »
E' un problema di visualizzazione dei contenuti. Dato che il template carica i font di Google, questi vengono visti come contenuti non sicuri.
Compare il solito popup "viene visualizzato solo il contenuto sicuro".......
Grazie comunque dell'attenzione

Offline Gianfranco Acwild

  • Nuovo arrivato
  • *
  • Post: 5
  • Sesso: Maschio
    • Mostra profilo
Re:[Risolto] Problema visualizzazione menu con http e https
« Risposta #5 il: 06 Mar 2017, 23:49:42 »
Ciao a tutti, ho un sito che ha sempre funzionato alla grande con il classico http://.
Ho installato il certificato ed ora posso anche utilizzare https://
Il problema che mi cambia il men principale, in https mi modifica il font e mi va a capo l'ultima voce.
Se l'amministratore mi da l'ok, metto il link del sito.
   Anche io ho lo stesso problema...ma non mi chiara la soluzione data! Potete aiutarmi? la soluzione credo sia discordante dal problema segnalato inizialmente. Nel mio caso il certificato funziona e non appaiono popup ma i font del sito sono cambiati.

Offline unpodicose

  • Esploratore
  • **
  • Post: 57
  • Sesso: Maschio
    • Mostra profilo
    • un po di cose
Re:[Risolto] Problema visualizzazione menu con http e https
« Risposta #6 il: 07 Mar 2017, 09:54:41 »
   Anche io ho lo stesso problema...ma non mi chiara la soluzione data! Potete aiutarmi? la soluzione credo sia discordante dal problema segnalato inizialmente. Nel mio caso il certificato funziona e non appaiono popup ma i font del sito sono cambiati.

Ciao, il template usa i font di Google?

Offline Gianfranco Acwild

  • Nuovo arrivato
  • *
  • Post: 5
  • Sesso: Maschio
    • Mostra profilo
Re:[Risolto] Problema visualizzazione menu con http e https
« Risposta #7 il: 07 Mar 2017, 10:02:18 »
Si il template usa anche i google font . Ho provato a disattivarli ma il risultato non cambia . I font dei menu sono cambiati e non so da dove li prenda! :(

Offline unpodicose

  • Esploratore
  • **
  • Post: 57
  • Sesso: Maschio
    • Mostra profilo
    • un po di cose
Re:[Risolto] Problema visualizzazione menu con http e https
« Risposta #8 il: 07 Mar 2017, 10:08:14 »
Il problema solo quello. Io non ho trovato altra soluzione che disattivare i font di Google e sostituirli con qualcosa di simile. Si trovano delle soluzioni on line ma non hanno risolto il mio problema.

Offline alexred

  • Administrator
  • Fuori controllo
  • *****
  • Post: 25370
  • Sesso: Maschio
  • Esperto in ozio relaxed
    • Mostra profilo
    • AlexRed.com
Re:[Risolto] Problema visualizzazione menu con http e https
« Risposta #9 il: 07 Mar 2017, 10:25:27 »
Sul sito https://www.abruzzotest.it/  i font vengono ancora richiamati in http://
http://fonts.googleapis.com/css?family=lato

questo un errore. Una pagina in https deve richiamare solo contenuti provenienti da sorgenti in https.
Quindi consiglio di ricercare nel codice del sito la parte http://fonts.googleapis.com e sostituirla in https://fonts.googleapis.com
« Ultima modifica: 07 Mar 2017, 11:36:18 da alexred »

Offline unpodicose

  • Esploratore
  • **
  • Post: 57
  • Sesso: Maschio
    • Mostra profilo
    • un po di cose
Re:[Risolto] Problema visualizzazione menu con http e https
« Risposta #10 il: 07 Mar 2017, 10:30:46 »
Grazie, provo a cercare quel codice.

Offline Gianfranco Acwild

  • Nuovo arrivato
  • *
  • Post: 5
  • Sesso: Maschio
    • Mostra profilo
Re:[Risolto] Problema visualizzazione menu con http e https
« Risposta #11 il: 07 Mar 2017, 11:40:18 »
Sul sito https://www.abruzzotest.it/  i font vengono ancora richiamati in http://
http://fonts.googleapis.com/css?family=lato

questo un errore. Una pagina in https deve richiamare solo contenuti provenienti da sorgenti in https.
Quindi consiglio di ricercare nel codice del sito la parte http://fonts.googleapis.com e sostituirla in https://fonts.googleapis.com
Sul mio sito, del quale se mi autorizzate posso scrivere il link, il problema non sembra dipendere da quanto scrivi, poich dalle impostazioni dello stile del template ho disattivato sotto la voce tipografia tutti i riferimenti a google font.

Offline alexred

  • Administrator
  • Fuori controllo
  • *****
  • Post: 25370
  • Sesso: Maschio
  • Esperto in ozio relaxed
    • Mostra profilo
    • AlexRed.com
Re:[Risolto] Problema visualizzazione menu con http e https
« Risposta #12 il: 07 Mar 2017, 12:05:30 »
Ciao    Gianfranco Acwild,
certo, scrivi pure il link al tuo sito cos  proviamo a verificare

Offline Gianfranco Acwild

  • Nuovo arrivato
  • *
  • Post: 5
  • Sesso: Maschio
    • Mostra profilo
Re:[Risolto] Problema visualizzazione menu con http e https
« Risposta #13 il: 07 Mar 2017, 12:25:47 »
Grazie Alexred ...il link   www.acwild.it

Offline alexred

  • Administrator
  • Fuori controllo
  • *****
  • Post: 25370
  • Sesso: Maschio
  • Esperto in ozio relaxed
    • Mostra profilo
    • AlexRed.com
Re:[Risolto] Problema visualizzazione menu con http e https
« Risposta #14 il: 07 Mar 2017, 13:23:58 »
Chorme visualizza ancora molti Font sul tuo sito che provengono da sorgenti in http://
Ti allego la schermata di quello che mi appare.

Prova a testarlo anche tu con l'ultima versione di Chrome e premi F12 sulla tastiera, la procedura descritta in questa FAQ: http://www.joomla.it/faq-joomla-3/443-configurazione/8582-come-configurare-il-sito-joomla-in-https.html

Offline Gianfranco Acwild

  • Nuovo arrivato
  • *
  • Post: 5
  • Sesso: Maschio
    • Mostra profilo
Re:[Risolto] Problema visualizzazione menu con http e https
« Risposta #15 il: 07 Mar 2017, 14:09:00 »
Grazie Alexred far le verifiche che hai suggerito

 

Torna su