Autore Topic: Correggere manualmente il bug nella registrazione utenti di Joomla 3.6.5  (Letto 621 volte)

Offline alexred

  • Fuori controllo
  • *
  • Post: 25673
  • Sesso: Maschio
  • Esperto in ozio relaxed
    • Mostra profilo
    • AlexRed.com
L'aggiornamento Joomla 3.6.5 è stato rilasciato già da qualche mese ma ha introdotto un bug che può risultare fastidioso per chi utilizza la registrazione utenti. Vediamo come correggerlo manualmente in attesa che questa correzione arrivi anche con la prossima versione 3.7.0.

Link all'articolo:  http://www.joomla.it/219-notizie/8623-correggere-manualmente-il-bug-nella-registrazione-utenti-di-joomla-3-6-5.html

Offline Gianluca Pantaleo

  • Esploratore
  • **
  • Post: 54
  • Gianluca Pantaleo - Webmaster
    • Mostra profilo
    • Gianluca Pantaleo - Webmaster
Ciao ragazzi,
ho seguito la guida e modificato il file registration.php, tuttavia il problema persite su questo sito:
https://www.kineticgroup.it/component/users/?view=registration
i campi dovrebbero essere tutti obbligatori e manca il link ai termini di servizio.
Aggiungo anche che Joomla è aggiornato alla 3.8.5 e che non ho override di template sul componente.
Qualcuno sa come posso risolvere? Grazie

Offline marine

  • Team Joomla.it
  • Instancabile
  • *******
  • Post: 3251
  • Sesso: Maschio
    • Mostra profilo
Che quelle indicazioni erano valide per la 3.6.5

Offline Gianluca Pantaleo

  • Esploratore
  • **
  • Post: 54
  • Gianluca Pantaleo - Webmaster
    • Mostra profilo
    • Gianluca Pantaleo - Webmaster
Hai una soluzione per la 3.8.5?
Grazie

Offline Ahmed Salvini

  • Appassionato
  • ***
  • Post: 332
    • Mostra profilo
una soluzione per cosa?
da cosa vedi che è un bug? E' stata aperta qualche segnalazione per questo malfunzionamento?

Offline Gianluca Pantaleo

  • Esploratore
  • **
  • Post: 54
  • Gianluca Pantaleo - Webmaster
    • Mostra profilo
    • Gianluca Pantaleo - Webmaster
Ho fatto dei test anche su altri due miei siti con 3.8.5 e anche su quelli ho riscontrato il problema. Mentre su uno con 3.8.4 e uno con 3.8.3 funziona. Chiedo a chi abbia tempo e voglia di fare un test di confermarmelo, così apriamo la segnalazione.
Grazie

Offline Ahmed Salvini

  • Appassionato
  • ***
  • Post: 332
    • Mostra profilo
se hai modificato dei files forse prima ti conviene togliere le modifiche.
test su versioni che non siano l'ultima non ha senso.
Poi non capisco quello che hai descritto, cosa deve essere obbligatorio?
vedo che hai aggiunto campi.

la 384 aveva problemi coi form fields perchè causavano una vulnerabilità e ci hanno messo le mani, magari è la configurazione che è stata manipolata male.
Ho fatto qualche ricerca e non vedo segnalazioni e mi pare molto strano, il form di registrazione è una cosa che moltissimi usano.

Io proverei installando su uno spazio di prova una nuova 3.8.5 per vedere se ci sono problemi.

Offline Gianluca Pantaleo

  • Esploratore
  • **
  • Post: 54
  • Gianluca Pantaleo - Webmaster
    • Mostra profilo
    • Gianluca Pantaleo - Webmaster
I file che avevo modificato ovviamente li ho ripristinati e i test sulle versioni precedenti per me hanno senso perchè se su 3.8.3 e 3.8.4 funziona ma su 3.8.5 no, evidentemente c'è un problema sull'ultima versione. Ad ogni modo proverò anche su una 3.8.5 pulita e vi farò sapere.


Il problema sono i campi nel form di registrazione utenti, quelli che si attivano dal plugin user profiles (indirizzo, città, data di nascita, ecc...) che in frontend risultano facoltativi nonostante in backend abbia selezionato che debbano essere obbligatori, poi il problema che l'accettazione dei termini di servizio non linka all'articolo.

Offline Gianluca Pantaleo

  • Esploratore
  • **
  • Post: 54
  • Gianluca Pantaleo - Webmaster
    • Mostra profilo
    • Gianluca Pantaleo - Webmaster
Testato anche con una installazione pulita di Joomla 3.8.5, il problema c'è!!

Offline Gianluca Pantaleo

  • Esploratore
  • **
  • Post: 54
  • Gianluca Pantaleo - Webmaster
    • Mostra profilo
    • Gianluca Pantaleo - Webmaster
La segnalazione era gia stata aperta:
https://issues.joomla.org/tracker/joomla-cms/19617

 

Torna su