Autore Topic: Non riesco ad accedere come Super User, per errore nella gestione dei permessi  (Letto 627 volte)

Offline frammenti

  • Nuovo arrivato
  • *
  • Post: 9
    • Mostra profilo

Salve a tutti.
Ho, per errore e forse per l'ora tarda, commesso un errore nell'andare a gestire il "permission setting" nella configurazione di Joomla.
Questa pagina, per intenderci:
https://docs.joomla.org/images/b/b9/Screenshot_global_acl_J3_tutorial-en.png

Il risultato è che non riesco ad accedere all'area amministrativa di joomla con le credenziali Super User, che è impostato così



Intervenendo in phpmyadmin ho cercato di trovare una soluzione, anche creando un nuovo utente amministratore.
L'operazione non ha raggiunto lo scopo. Dalle guide consultate, doveva arrivar mi una email con per confermare la creazione del nuovo utente, ma nulla.
Ho l'impressione che il problema risieda nel setting dei gruppi utente, che si trovano nella tabella del database _usergroups che attualmente è settato così


E' un settaggio corretto? O il problema risiede in qualche altra tabella?
« Ultima modifica: 23 Mar 2017, 11:30:09 da frammenti »

Offline Ahmed Salvini

  • Appassionato
  • ***
  • Post: 273
    • Mostra profilo
parent_id è l'id progressivo dell'utente

Offline frammenti

  • Nuovo arrivato
  • *
  • Post: 9
    • Mostra profilo
Sì è il primo ed unico utente creato originariamente.
Pensi che la tabella impostata così sia corretta?

Offline Ahmed Salvini

  • Appassionato
  • ***
  • Post: 273
    • Mostra profilo
devi mettere il parent_id uguale all'id dell'utente. Qual'è l'id dell'utente? basta leggerlo

Offline frammenti

  • Nuovo arrivato
  • *
  • Post: 9
    • Mostra profilo
Ho provato a mettere 1, ma anche 8, 9. Niente. Non accedo.
L'hosting mi dice che il setting sembra corretto:


"Dovrebbe funzionare a meno che non ci siano plugin di autenticazione attivi che possono in qualche modo bypassare quello di default di Joomla.
[/size]Le posso dire che i settaggi sembrano corretti.
Non è la prima volta che vediamo questo tipo di problema. Forse le conviene ricaricare l'ultimo backup se non riesce a risolvere. "

Offline Ahmed Salvini

  • Appassionato
  • ***
  • Post: 273
    • Mostra profilo
il parent_id dell'utente dell'immagine è 388 dove prendi i numeri che inserisci? perchè 1 2 3 ? Ti ho scritto che devi guardare che id ha l'utente

 

Torna su