Autore Topic: [RISOLTO] Errore upgrade da 3.6.5 a 3.7.0 - pagina bianca rientrando in home  (Letto 385 volte)

Offline Frto

  • Nuovo arrivato
  • *
  • Post: 20
  • Sesso: Maschio
    • Mostra profilo
Ciao,
ho scaricato il sito di produzione in  locale (XAMPP 3.2.2 su Win10) ed ho provato l'aggiornamento da Joomla 3.6.5 alla 3.7.0.
L'aggiornamento automatico è andato bene così come quello della lingua italiana.  Nessuna evidenza su "Estensioni - Avvisi".

Problema:
Accedendo al sito dalla home sembrava tutto ok (ho navigato dai menu su tutte le pagine principali senza problemi) ma appena rientrato alla home mi si è presentata una finestra  completamente  bianca.
Il problema si manifesta sia su Firefox 52.1.0 sia su MS Edge 40.15063.0.0 (non ho provato con altri browser).

Prove eseguite senza esito (ogni volta cancellata cache di Joomla e del browser):
- impostato template Protostar
- impostato file htaccess default di Joomla
- disattivata cache nel  pannello di configurazione globale.

Il problema si "risolve" solo disattivando il plug-in "System - page cache" .

Qualche suggerimento? Qualcun altro ha avuto un problema simile?
La "soluzione" di disattivare il plugin della cache non è  per me applicabile in produzione dove lascio intanto  la 3.6.5.
« Ultima modifica: 17 Mag 2017, 20:43:34 da Frto »

Offline alexred

  • Administrator
  • Fuori controllo
  • *****
  • Post: 25345
  • Sesso: Maschio
  • Esperto in ozio relaxed
    • Mostra profilo
    • AlexRed.com
Ciao Frto,
confermo il problema. E' già presente una segnalazione :  https://github.com/joomla/joomla-cms/issues/15593

speriamo in una soluzione con il prossimo aggiornamento

Offline Frto

  • Nuovo arrivato
  • *
  • Post: 20
  • Sesso: Maschio
    • Mostra profilo
Grazie alexred,
se ho capito bene l'errore è stato ricodificato nel Joomla!Issue tracker con #15674 e sia già pronta la soluzione per il prossimo aggiornamento: https://github.com/joomla/joomla-cms/issues/15674.

Attendo quindi la versione 3.7.1 (da ricontrollare in locale),  prima di aggiornare la 3.6.5 di produzione e mettere [Risolto] sull'oggetto .

Offline Frto

  • Nuovo arrivato
  • *
  • Post: 20
  • Sesso: Maschio
    • Mostra profilo
Aggiornamento ad utilità di quanti avessero analogo problema.

Ho notato che  nel Joomla!Issue Tracker, anche con il contributo di alexred:

a)  le molte segnalazioni di anomalia della versione 3.7.0 collegate al plugin "System - page cache" sono state tutte ricondotte al codice errore #15592 (https://github.com/joomla/joomla-cms/pull/15592)

b) è stata aggiornata una specifica pagina nelle FAQ della 3.7.0 (https://docs.joomla.org/J3.x:Caching_Issues) dove è confermata la soluzione definitiva con la versione 3.7.1 e quella provvisoria per la 3.7.0 (disattivare il plugin "System - page cache"  e la gestione della cache dal pannello di configurazione globale).

Ciao.

 

Torna su