Autore Topic: Pagina bianca al posto della home page dopo aggiornamento a Joomla 3.7 su 2 siti  (Letto 478 volte)

Offline mikyjoo

  • Nuovo arrivato
  • *
  • Post: 25
    • Mostra profilo
Salve a tutti! Vorrei sapere se sono io che ho sbagliato qualcosa oppure se sia la nuova versione di Joomla ad avere qualche problema. Ecco la questione: ho aggiornato due siti diversi dalla versione Joomla 3.6.5 alla versione 3.7.0 e su entrambi Ŕ successo che digitando l'indirizzo della home page, quindi non di una subpage, apparisse sempre una pagina bianca. L'unico modo per evitare la cosa Ŕ stato disattivare il System Cache Plugin, che per˛ non Ŕ stato pi¨ possibile riattivare, anche dopo molto tempo passato, altrimenti ritornava la pagina bianca. Questo ha causato un rallentamento dell velocitÓ di caricamento del sito, ed Ŕ questo che vorrei evitare, siccome su uno dei due siti ho molte immagini che rallentano parecchio. Quando c'era la pagina bianca, per˛, ho notato che se digitavo l'url di una qualunque subpage, questa veniva visualizzata correttamente. E' accaduto su entrambi i siti. Grazie se volete aiutarmi!

Offline marine

  • Moderator
  • Instancabile
  • *****
  • Post: 2499
  • Sesso: Maschio
    • Mostra profilo

Offline mikyjoo

  • Nuovo arrivato
  • *
  • Post: 25
    • Mostra profilo
Grazie molte! ora gli d˛ uno sguardo... ;)

Offline mikyjoo

  • Nuovo arrivato
  • *
  • Post: 25
    • Mostra profilo
Ok! Ho letto. Grazie!

Offline Frto

  • Nuovo arrivato
  • *
  • Post: 20
  • Sesso: Maschio
    • Mostra profilo
Per eventuali altri approfondimenti:

a)  nel Joomla! Issue Tracker le molte segnalazioni di anomalia della versione 3.7.0 collegate al plugin "System - page cache" sono state tutte ricondotte al codice errore #15592 (https://github.com/joomla/joomla-cms/pull/15592)

b) nel sito ufficiale Ŕ stata aggiornata una specifica pagina nelle FAQ della 3.7.0 (https://docs.joomla.org/J3.x:Caching_Issues) dove Ŕ confermata la soluzione definitiva con la versione 3.7.1 e quella provvisoria per la 3.7.0 (disattivare il plugin "System - page cache"  e la gestione della cache dal pannello di configurazione globale).

Ciao.

Offline mikyjoo

  • Nuovo arrivato
  • *
  • Post: 25
    • Mostra profilo
Ottimo! Grazie mille della gentilezza!

Offline giampolino

  • Esploratore
  • **
  • Post: 94
    • Mostra profilo
Anch'io nel passaggio dalla 3.6.5 a 3.7.1 ho lo stesso problema (anche se la 3.7.1 avrebbe dovuto risolvere) della pagina bianca

Guardando il log degli errori dal pannello di controllo del gestore dell'hosting vedo che ci sono molte righe con errore. Ne riporto una ma le altre sono simili:

mod_fcgid: stderr: PHP Fatal error:  Call to a member function get() on a non-object in /home/xxxx/domains/miosito.biz/public_html/plugins/system/jsntplframework/libraries/joomlashine/template/helper.php on line 1112

Cose che ho giÓ fatto:
1. ho portato la versione del php da 5.5 a 5.6 (l'ultima che dnshosting prevede)
2. ho disabilitato il plugin system - page cache e disabilitato la cache nella configurazione globale (stranamente erano giÓ disabilitate)
3. ho provato a cambiare template attivando Protostar

Non ho risolto.

Qualche suggerimento?
Grazie

Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 27692
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
    • Xataface Italia
Se hai lo stesso problema avrai le stesse risposte che ti invito a rileggere. In caso contrario il tuo problema sarÓ diverso e per problema diverso si apre un nuovo proprio topic.  :)
NEWS DataGrill Xataface Installer (Ver. 1.0.0) per Joomla 3.6 ed un Esempio Applicazione Bblioteca

Offline giampolino

  • Esploratore
  • **
  • Post: 94
    • Mostra profilo
Grazie Tomtomeight, ho provveduto.

 

Torna su