Autore Topic: problemi con i TAG su Joomla 3.7  (Letto 530 volte)

Offline Giaba

  • Esploratore
  • **
  • Post: 75
    • Mostra profilo
problemi con i TAG su Joomla 3.7
« il: 08 Mag 2017, 15:31:44 »
Salve,
dopo l'aggiornamento a Joomla! 3.7 di un sito nel quale faccio uso massiccio dei tags, si verifica una strana anomalia, richiamando gli articoli tramite tags vengono visualizzati correttamente, ma sia l'url sia il path visualizzati sono sbagliati, ovvero invece di mostrare il tag principale a cui appartengono, ne mostrano uno diverso e sempre lo stesso, indipendentemente dai gruppi di appartenenza dei vari tags.

Esempio:

il tag "Pinco Palla" appartiene al tag principale "Autori e interpreti" pertanto questi dovrebbero essere l'url e il path corretti:

www.miosito.com/trova/autori-e-interpreti/126-pinco-palla.html

Home Trova Autori e interpreti   

Dove "Trova" Ŕ soltanto voce del men¨, mentre "Autori e interpreti" Ŕ sia voce di men¨ sia categoria.
       

Ora invece mostra questo url e path

www.miosito.com/artisti/cinema/interpreti/pinco-palla.html

Home artisti cinema Interpreti   

Notare che Artisti, Cinema e Interpreti sono, il primo una categoria principale e i successivi sottocategorie.
Sono al tempo stesso anche voci di men¨ e sottomen¨.


Qualcuno ha giÓ riscontrato lo stesso problema?
Come risolverlo?

Buona giornata a tutti
Giaba
« Ultima modifica: 09 Mag 2017, 12:19:27 da Giaba »

Offline alexred

  • Administrator
  • Fuori controllo
  • *****
  • Post: 25572
  • Sesso: Maschio
  • Esperto in ozio relaxed
    • Mostra profilo
    • AlexRed.com
Re:problemi con i TAG su Joomla 3.7
« Risposta #1 il: 08 Mag 2017, 15:41:08 »
Ciao Giaba,
ho letto di problemi giÓ segnalati in Joomla 3.7.0 riferiti ai TAG,
hai il sito multilingua ?
https://github.com/joomla/joomla-cms/pull/15539

Hai un backup del sito funzionante in locale dove testare l'aggiornamento a Joomla 3.7.1 per capire se l'aggiornamento risolve il problema ?

Offline Giaba

  • Esploratore
  • **
  • Post: 75
    • Mostra profilo
Re:problemi con i TAG su Joomla 3.7
« Risposta #2 il: 08 Mag 2017, 21:34:26 »
Ciao Alexred,
il sito non Ŕ multilingue anche se sono installate Italiano e Inglese.
Ho il backup del sito in versione preaggiornamento alla 3.7, ma non installato.

Grazie  :)

Offline alexred

  • Administrator
  • Fuori controllo
  • *****
  • Post: 25572
  • Sesso: Maschio
  • Esperto in ozio relaxed
    • Mostra profilo
    • AlexRed.com
Re:problemi con i TAG su Joomla 3.7
« Risposta #3 il: 09 Mag 2017, 09:57:35 »
Prova ad installarlo in locale sul tuo PC ed aggiornarlo alla versione di sviluppo 3.7.1 per capire se con l'aggiornamento Ŕ un problema che viene risolto o se Ŕ un problema che riusciamo a replicare e segnalare al team.

Offline Giaba

  • Esploratore
  • **
  • Post: 75
    • Mostra profilo
Re:problemi con i TAG su Joomla 3.7
« Risposta #4 il: 09 Mag 2017, 10:43:49 »
Ciao Alexred,
Ŕ gia disponibile la release 3.7.1?

Ho installato il mio primo ed unico sito di prova in locale nel 2010, mi serve il tempo per documentarmi su come fare e reinstallare il software necessario. Consigli sono ben accetti  ;)

Una volta installato il sofware che serve, mi consigli di installate il sito precedente o quello attualmente online dove ho giÓ installato la versione 3.7 che presenta il problema segnalato?

Come fare l'aggiornamento alla versione 3.7.1?

Offline alexred

  • Administrator
  • Fuori controllo
  • *****
  • Post: 25572
  • Sesso: Maschio
  • Esperto in ozio relaxed
    • Mostra profilo
    • AlexRed.com
Re:problemi con i TAG su Joomla 3.7
« Risposta #5 il: 09 Mag 2017, 11:56:11 »
In questa pagina trovi il link al pacchetto di aggiornamento alla versione 3.7.1
https://developer.joomla.org/nightly-builds.html
si tratta della versione in sviluppo, ma pu˛ essere utilizzata per i test.

Offline Giaba

  • Esploratore
  • **
  • Post: 75
    • Mostra profilo
Re:problemi con i TAG su Joomla 3.7
« Risposta #6 il: 09 Mag 2017, 11:59:21 »
Correzioni ed integrazioni al primo post


Esempio:

il tag "Pinco Palla" appartiene al tag principale "Autori e interpreti" pertanto questi dovrebbero essere l'url e il path corretti:

www.miosito.com/trova/autori-e-interpreti/126-pinco-palla.html

Home Trova Autori e interpreti   

Dove "Trova" Ŕ soltanto voce del men¨, mentre "Autori e interpreti" Ŕ sia voce di men¨ sia categoria.
       

Ora invece mostra questo url e path

www.miosito.com/artisti/cinema/interpreti/pinco-palla.html

Home artisti cinema Interpreti   

Notare che Artisti, Cinema e Interpreti sono, il primo una categoria principale e i successivi sottocategorie.
Sono al tempo stesso anche voci di men¨ e sottomen¨.

« Ultima modifica: 09 Mag 2017, 12:18:59 da Giaba »

Offline Giaba

  • Esploratore
  • **
  • Post: 75
    • Mostra profilo
Re:problemi con i TAG su Joomla 3.7
« Risposta #7 il: 11 Mag 2017, 17:06:14 »
Prova ad installarlo in locale sul tuo PC ed aggiornarlo alla versione di sviluppo 3.7.1 per capire se con l'aggiornamento Ŕ un problema che viene risolto o se Ŕ un problema che riusciamo a replicare e segnalare al team.
Ciao Alexred, se ancora necessario ci posso provare durante il prossimo week end.
Questo tutorial Ŕ ancora valido e attuale?

In questa pagina trovi il link al pacchetto di aggiornamento alla versione 3.7.1
https://developer.joomla.org/nightly-builds.html
si tratta della versione in sviluppo, ma pu˛ essere utilizzata per i test.
Quale di queste tre versioni andrÓ installata sul sito giÓ aggiornato alla 3.7?


Ciao
Giaba
« Ultima modifica: 11 Mag 2017, 17:14:38 da Giaba »

Offline alexred

  • Administrator
  • Fuori controllo
  • *****
  • Post: 25572
  • Sesso: Maschio
  • Esperto in ozio relaxed
    • Mostra profilo
    • AlexRed.com
Re:problemi con i TAG su Joomla 3.7
« Risposta #8 il: 11 Mag 2017, 17:37:07 »
se hai giÓ la versione 3.7.0 potrai installare in locale il file:
Joomla_3.7.x_to_3.7.1-dev-Development-Patch_Package.zip

Offline Giaba

  • Esploratore
  • **
  • Post: 75
    • Mostra profilo
Re:problemi con i TAG su Joomla 3.7
« Risposta #9 il: 11 Mag 2017, 19:27:40 »
Le ho entrambi:

- ho il backup precedente all'installazione della 3.7;

- ho il sito online, con i problemi menzionati, e installata la versione 3.7.

Su quale delle due copie Ŕ preferibile fare le prove?

Offline alexred

  • Administrator
  • Fuori controllo
  • *****
  • Post: 25572
  • Sesso: Maschio
  • Esperto in ozio relaxed
    • Mostra profilo
    • AlexRed.com
Re:problemi con i TAG su Joomla 3.7
« Risposta #10 il: 11 Mag 2017, 21:40:18 »
inizialmente fai il test sulla 3.7.0 che Ŕ quella che hai online, cosý se risolvi in locale riporti la stessa soluzione online.

Offline Giaba

  • Esploratore
  • **
  • Post: 75
    • Mostra profilo
Re:problemi con i TAG su Joomla 3.7
« Risposta #11 il: 12 Mag 2017, 21:33:13 »
Ok, domani ci prover˛ e ti far˛ sapere.

Offline Giaba

  • Esploratore
  • **
  • Post: 75
    • Mostra profilo
Re:problemi con i TAG su Joomla 3.7
« Risposta #12 il: 14 Mag 2017, 23:19:35 »
Ciao Alexred, ci ho provato due volte ma senza riuscirci.

Prima ho fatto il backup (copia con filezilla) del sito online e del data base.

Poi ho installato XAAMP v3.2.2 seguendo le istruzioni di questo tutorial passo per passo fino a: Installazione Joomla! in locale con XAMPP
Qui invece di installare Joomla ho trasferito la cartella "Sito37" contenente il backup, sotto la catrella c:\xampp\htdocs\ come indicato.

A questo punto ho aperto phpMyAdmin e ho creato un nuovo data base, con lo stesso identico nome del data base presente nel sito online.

Quando ho provato ad importare i dati mi ha dato questo messaggio di errore: Stai probabilmente cercando di caricare sul server un file troppo grande. Fai riferimento alla documentazione se desideri aggirare questo limite.

Il file del db in formato SQL Ŕ si 22.2 Mb

Qui mi sono fermato  >:(
« Ultima modifica: 14 Mag 2017, 23:26:21 da Giaba »

Offline danielecr

  • Appassionato
  • ***
  • Post: 385
    • Mostra profilo
Re:problemi con i TAG su Joomla 3.7
« Risposta #13 il: 14 Mag 2017, 23:35:29 »
Devi modificare upload_max_filesize e post_max_size nel php.ini in uso da xampp. Di default dovresti essere limitato a 2mb. Cambia i valori a seconda delle tue esigenze.
Dopo la modifica al php.ini riavvia!



« Ultima modifica: 15 Mag 2017, 00:16:04 da danielecr »

Offline Giaba

  • Esploratore
  • **
  • Post: 75
    • Mostra profilo
Re:problemi con i TAG su Joomla 3.7
« Risposta #14 il: 15 Mag 2017, 09:26:07 »
Grazie delle indicazioni.
Come da indicazioni del tutorial ho giÓ modificato alcuni valori del file php.ini:

max_execution_time : 180
max_file_uploads  :  20
max_input_time  : 180
memory_limit  : 512M
upload_max_filesize : 128M

Vedo che non Ŕ contemplato post_max_size, ora il suo valore Ŕ 8M, modificato in 30M vediamo che succede  ;)


Mi ha dato questo errore: Fatal error:  Maximum execution time of 300 seconds exceeded in C:\xampp\phpMyAdmin\libraries\dbi\DBIMysqli.php on line 257
 Apri una nuova finestra di PhpMyAdmin
« Ultima modifica: 15 Mag 2017, 10:16:24 da Giaba »

Offline Giaba

  • Esploratore
  • **
  • Post: 75
    • Mostra profilo
Re:problemi con i TAG su Joomla 3.7
« Risposta #15 il: 18 Mag 2017, 02:39:22 »
Aggiornato il sito alla release 3.7.1, il problema non Ŕ stato risolto  :(

Offline Giaba

  • Esploratore
  • **
  • Post: 75
    • Mostra profilo
Re:problemi con i TAG su Joomla 3.7
« Risposta #16 il: 08 Lug 2017, 12:09:00 »
Anche dopo aver aggiornato il sito alla release 3.7.2 e 3.7.3, il problema non Ŕ stato risolto  :(

 

Torna su