Autore Topic: [RISOLTO]] Errore mail dopo aggiornamento a 3.7.1  (Letto 120 volte)

Offline Nick2005

  • Esploratore
  • **
  • Post: 80
  • Sesso: Maschio
    • Mostra profilo
    • Studio Nicosia
[RISOLTO]] Errore mail dopo aggiornamento a 3.7.1
« il: 19 Mag 2017, 17:44:39 »
Ciao a tutti
ho effettuato l'aggiornamento alla nuova versione, ma da questo momento ho degli errori nell'invio tramite smtp.
Ho fatto un test da configurazione globale inviando l'email di prova e questo è quanto mi viene visualizzato:
ErroreSi è verificato un errore di analisi durante l'elaborazione deiseguenti dati JSON:

 Warning:  stream_socket_enable_crypto(): Peer certificate CN=`*.aruba.it' did not match expected CN=`smtp.pippo.it' in /web/htdocs/www.pippo.it/home/libraries/vendor/phpmailer/phpmailer/class.smtp.php on line 367
 {"success":true,"message":null,"messages":{"message":["L'email \u00e8 stata inviata correttamente a <strong>supporto@pippo.it<\/strong> utilizzando <strong>SMTP<\/strong>. Controlla che ti sia arrivata l'email di prova."]},"data":true}

Qualcuno è in grado di aiutarmi?
Grazie
Gaetano
« Ultima modifica: 20 Mag 2017, 07:56:35 da Nick2005 »
Gaetano

Offline Alex21

  • Appassionato
  • ***
  • Post: 442
    • Mostra profilo
    • Immobili a Padova
Re:Errore mail dopo aggiornamento a 3.7.1
« Risposta #1 il: 19 Mag 2017, 18:50:18 »
Da notare che joomla 3.7.0 utilizza phpmailer versione 5.2.22.  Precedenti versioni di joomla utilizzavano phpmailer versione 5.2.14. C'è stato quindi anche un aggiornamento di phpmailer che, presumibilmente, si è adeguato agli standard attuali diventando più difficile per quanto riguarda i certificati.
In buona sostanza il mailer lamenta che si aspettava un certificato da  smtp.pippo.it  ma gli è arrivato un certificato da *.aruba.it, quindi si ferma.
Bisogna che riconfiguri la mail che invii in modo che phpmailer si aspetti un certificato da *.aruba.it. Ovvero da uno dei nomi server da cui partono le tue mail, insomma.
La cosa richiede alcune prove a meno che qualcuno, qui, non le abbia già fatte e posti la procedura.
Ciao!





Online tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 27471
  • Sesso: Maschio
  • Chi si specializza muore. Chi divaga troppo affoga
    • Mostra profilo
    • Xataface Italia
Re:Errore mail dopo aggiornamento a 3.7.1
« Risposta #2 il: 19 Mag 2017, 19:14:59 »
Per l'utilizzo di smtp il dominio del server smtp deve sempre essere uguale al dominio del mittente. In pratica non puoi inviare come mittente info@xxx.aa con server smtp smtp.yyy.bb
NEWS DataGrill Xataface Installer (Ver. 1.0.0) per Joomla 3.6 ed un Esempio Applicazione Bblioteca

Offline Nick2005

  • Esploratore
  • **
  • Post: 80
  • Sesso: Maschio
    • Mostra profilo
    • Studio Nicosia
Re:Errore mail dopo aggiornamento a 3.7.1
« Risposta #3 il: 19 Mag 2017, 20:00:59 »
Ho scoperto l'inghippo.
Era il componente Admin Tools di Akeeba che, non so perchè, mi creava il problema.
L'ho disinstallato e tutto è tornato a funzionare, anche perchè il dominio di smtp era identico a quello del mittente.
Gaetano

Online tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 27471
  • Sesso: Maschio
  • Chi si specializza muore. Chi divaga troppo affoga
    • Mostra profilo
    • Xataface Italia
Re:Errore mail dopo aggiornamento a 3.7.1
« Risposta #4 il: 19 Mag 2017, 20:35:41 »
Bene, adesso per cortesia inserisci il risolto come si conviene.
NEWS DataGrill Xataface Installer (Ver. 1.0.0) per Joomla 3.6 ed un Esempio Applicazione Bblioteca

 

Torna su