Autore Topic: Virtuemart 3.2.3: problema con nuovi prodotti/categorie dopo AGGIORNAMENTO  (Letto 952 volte)

Offline andreamatta

  • Appassionato
  • ***
  • Post: 208
  • Sesso: Maschio
    • Mostra profilo
    • Un sito web non è solo un sito, se riesce a portati clienti e benessere!
Ciao, premesso che sto lavorando su un sito in un'area di test, un sito che ho aggiornato con J3.7.2 e VM 3.2.3, mi ritrovo con un problema assurdo:


dopo l'aggiornamento ho creato una nuova categoria e relativa sottocategoria, quando però ho provato a clonare un prodotto di una categoria diversa cambiandogli la categoria il salvataggio MI RIPRISTINA LE CATEGORIE del prodotto precedente. Non solo, quando creo un prodotto ex-novo, e cerco sull'area delle categorie quelle nuove che ho creato, non le visualizza e quindi non posso selezionarle. Mi trovo bloccato e mi chiedo se è un bug della nuova versione di VM o se negli aggiornamenti fatti (sono passato da J3.5.1 e VM3.0.14) qualcosa è andato storto... nel caso, che fare?


Grazie per qualsiasi suggerimento!
Siti Internet Joomla & SEO a Treviso  ...essere o non essere nel WEB?   >>  http:www.andreamattarollo.com

Offline conti1

  • Global Moderator
  • Instancabile
  • ********
  • Post: 8903
  • Sesso: Maschio
    • Mostra profilo
    • sito delle prove
ciao appena fatta una prova j3.7.2 vm3.2.2  nessun problema da te descritto.
la vm3.2.3 non da l'aggiornamento in automatico non voglio fare l'aggiornamento manualmente x verificare  ti saaprò dire appena si aggiorna
se possibile postare il link  x risolvere al meglio il problema grazie
evitare nomi commerciali grazie

Offline andreamatta

  • Appassionato
  • ***
  • Post: 208
  • Sesso: Maschio
    • Mostra profilo
    • Un sito web non è solo un sito, se riesce a portati clienti e benessere!
Grazie Conti1,
ho ricevuto una segnalazione in merito ad una discussione sul forum internazione per questo problema, uno pseudo bug che è stato riscontrato dopo un aggiornamento a J3.7.2 da parte di alcuni utenti. Il suggerimento è : aggiornare solo a J3.65 e VM 3.2.1
Cosa che ho fatto, inizialmente il problema sembrava risolto, ma ora che sono andato a inserire alcuni prodotti non mi mantiene più le sottocategorie ma solo la categoria principale.


Quando inserisco la sottocategoria e salvo il prodotto questa scompare, e quando clono un prodotto le categorie del prodotto continuano a rimanere e non si possono cancellare.


Qui la discussione di cui sopra: https://forum.virtuemart.net/index.php?topic=137323.0


Tenterò un aggiornamento a 3.65 e VM 3.2.0... non so che fare! :-(
Siti Internet Joomla & SEO a Treviso  ...essere o non essere nel WEB?   >>  http:www.andreamattarollo.com

Offline andreamatta

  • Appassionato
  • ***
  • Post: 208
  • Sesso: Maschio
    • Mostra profilo
    • Un sito web non è solo un sito, se riesce a portati clienti e benessere!
...aggiornamento: il problema per le diverse persone che l'hanno riscontrato non c'è fino alla versione 3.0.18 di vm (e quindi J3.6.4):


https://forum.virtuemart.net/index.php?topic=137040.30


tenterò e riferirò...



Siti Internet Joomla & SEO a Treviso  ...essere o non essere nel WEB?   >>  http:www.andreamattarollo.com

Offline conti1

  • Global Moderator
  • Instancabile
  • ********
  • Post: 8903
  • Sesso: Maschio
    • Mostra profilo
    • sito delle prove
io con la versione descritta  nel mio post non oh problemi funziona tutto
ps: che versione di php stai usando?

fatto altra prova con php 7 che la precedente  ma non riesco a replicare il problema
« Ultima modifica: 09 Giu 2017, 18:55:54 da conti1 »
se possibile postare il link  x risolvere al meglio il problema grazie
evitare nomi commerciali grazie

Offline andreamatta

  • Appassionato
  • ***
  • Post: 208
  • Sesso: Maschio
    • Mostra profilo
    • Un sito web non è solo un sito, se riesce a portati clienti e benessere!
PHP: 5.6.30
Fino alla versione 3.0.18 il problema non si presenta. Aggiornandolo alla successiva 3.0.18.1 (o superiore)... patatrac  :(
« Ultima modifica: 12 Giu 2017, 17:21:31 da andreamatta »
Siti Internet Joomla & SEO a Treviso  ...essere o non essere nel WEB?   >>  http:www.andreamattarollo.com

Offline conti1

  • Global Moderator
  • Instancabile
  • ********
  • Post: 8903
  • Sesso: Maschio
    • Mostra profilo
    • sito delle prove
ciao
in locale fai una installazione pulita di joomla  e di vm  e vedi se il problema persiste , io ripeto  fatto prove creando categorie nuove  sotto categorie  clonando un prodotto  crearne di nuovi ma nulla tutto funziona
se possibile postare il link  x risolvere al meglio il problema grazie
evitare nomi commerciali grazie

Offline andreamatta

  • Appassionato
  • ***
  • Post: 208
  • Sesso: Maschio
    • Mostra profilo
    • Un sito web non è solo un sito, se riesce a portati clienti e benessere!
Grazie Conti1, il problema evidentemente riguarda solo alcuni siti, tra cui il mio. Tra l'altro ho scoperto che nonostante la mia versione VM 3.0.18 non abbia i problemi delle categorie, invece ha modificato tutti gli alias (!) delle schede prodotto delle lingue diverse da quella di default modificandoli nella lingua di default (un disastro seo) e quando tento di modificare l'alias dopo il salvataggio torna quello della lingua di default.


Non ho parole!
Siti Internet Joomla & SEO a Treviso  ...essere o non essere nel WEB?   >>  http:www.andreamattarollo.com

Offline mapet

  • Nuovo arrivato
  • *
  • Post: 22
    • Mostra profilo
Ciao Andreamatta,
hai più rispolto questo problema sollevato?

Io mi trovo nella condizione in cui dalla pagina della categoria, seleziono e clicco su un prodotto ma al posto di andare sulla sua scheda prodotto viene aggiornata la pagina della categoria se pur cambiando la stringa l'indirizzo  www..

Quindi se ho ben capito tu hai/avevi un problema analogo.

Grazie

 

Torna su