Autore Topic: da 3.7.2 a 3.7.3 in locale con xampp  (Letto 396 volte)

Offline Sanma

  • Nuovo arrivato
  • *
  • Post: 27
    • Mostra profilo
da 3.7.2 a 3.7.3 in locale con xampp
« il: 24 Lug 2017, 13:23:37 »
Ciao, in questi giorni joomla non ne vuole sapere di fare l'update in automatico ne tantomeno via carica e installa. Sembra quasi una questione di permessi in quanto usando carica e installa e dopo che mi richiede di reinserire le credenziali se ne esce con un errore 403 accesso non consentito . Dal pannello di controllo directory e file sono tutti scrivibili ed utilizzo un utente super user che per definizione tutto "aperto". Cosa mi sta sfuggendo?
grazie anticipatamente.

Offline alexred

  • Fuori controllo
  • *
  • Post: 25673
  • Sesso: Maschio
  • Esperto in ozio relaxed
    • Mostra profilo
    • AlexRed.com
Re:da 3.7.2 a 3.7.3 in locale con xampp
« Risposta #1 il: 24 Lug 2017, 14:17:58 »
Ciao Sanma,
pu essere che sia un problema di permessi e privilegi su qualche cartella o file di sistema.
Puoi fare un tentativo installando "akkeba admin tools" che dovrebbe avere anche nella versione gratuita un tools per il reset dei permessi e privilegi di tutto il sistema di Joomla.

Offline Sanma

  • Nuovo arrivato
  • *
  • Post: 27
    • Mostra profilo
Re:da 3.7.2 a 3.7.3 in locale con xampp
« Risposta #2 il: 24 Lug 2017, 14:57:09 »
La versione core non ce l'ha! comunque ho dato una ripassata con tutti i tools presente che fanno comunque comodo... e il problema si ripresenta.

Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 28064
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
    • Xataface Italia
Re:da 3.7.2 a 3.7.3 in locale con xampp
« Risposta #3 il: 24 Lug 2017, 15:29:04 »
Non mi risulta che in fase di aggiornamento vengano richieste credenziali di accesso. Sicuro di quello che stai facendo?
NEWS DataGrill Xataface Installer (Ver. 1.0.1) per Joomla 3.8.x - DEMO Gestione Magazzino

Offline Sanma

  • Nuovo arrivato
  • *
  • Post: 27
    • Mostra profilo
Re:da 3.7.2 a 3.7.3 in locale con xampp
« Risposta #4 il: 24 Lug 2017, 15:44:16 »
Si sono sicuro. L'aggiornamento automatico si ferma sulla pagina completamente bianca, nel carica e aggiorna appena premo il tasto blu mi chiede espressamente di reinserire le credenziali. e una volta fatto mi esce l'errore 403.
Guardate gli allegati.

Offline alexred

  • Fuori controllo
  • *
  • Post: 25673
  • Sesso: Maschio
  • Esperto in ozio relaxed
    • Mostra profilo
    • AlexRed.com
Re:da 3.7.2 a 3.7.3 in locale con xampp
« Risposta #5 il: 24 Lug 2017, 16:22:04 »
Si, confermo che la procedura normale quella che richiede di inserire nome utente e password per gli aggiornamenti

Offline Sanma

  • Nuovo arrivato
  • *
  • Post: 27
    • Mostra profilo
Re:da 3.7.2 a 3.7.3 in locale con xampp
« Risposta #6 il: 24 Lug 2017, 16:24:28 »
Si, confermo che la procedura normale quella che richiede di inserire nome utente e password per gli aggiornamenti


Infatti.... ma sto 403 non ne vuole sapere. Sono anche certo che pu essere una stupidata ma non ci arrivo proprio.

Offline alexred

  • Fuori controllo
  • *
  • Post: 25673
  • Sesso: Maschio
  • Esperto in ozio relaxed
    • Mostra profilo
    • AlexRed.com
Re:da 3.7.2 a 3.7.3 in locale con xampp
« Risposta #7 il: 24 Lug 2017, 16:37:15 »
prova ad aprire il file di log degli errori di apache o di PHP,  xampp ti permette di accedere a questi file.
Magari se al momento in cui viene generato il 403 viene scritto qualche errore pi dettagliato in questi log riesci a capire dove intervenire.

Offline Sanma

  • Nuovo arrivato
  • *
  • Post: 27
    • Mostra profilo
Re:da 3.7.2 a 3.7.3 in locale con xampp
« Risposta #8 il: 24 Lug 2017, 17:28:02 »
prova ad aprire il file di log degli errori di apache o di PHP,  xampp ti permette di accedere a questi file.
Magari se al momento in cui viene generato il 403 viene scritto qualche errore pi dettagliato in questi log riesci a capire dove intervenire.


L'unica cosa interessante puo' essere la seguente :

10.78.110.45 - - [24/Jul/2017:17:25:40 +0200] "POST /administrator/index.php HTTP/1.1" 303 - "http://intranet.cis.local/administrator/index.php?option=com_joomlaupdate" "Mozilla/5.0 (Windows NT 5.2; rv:52.0) Gecko/20100101 Firefox/52.0"
10.78.110.45 - - [24/Jul/2017:17:25:41 +0200] "GET /administrator/index.php?option=com_joomlaupdate&task=update.captive&d5f917943621c6c141fb7385b8803dbe=1 HTTP/1.1" 200 26406 "http://intranet.cis.local/administrator/index.php?option=com_joomlaupdate" "Mozilla/5.0 (Windows NT 5.2; rv:52.0) Gecko/20100101 Firefox/52.0"
10.78.110.45 - - [24/Jul/2017:17:25:56 +0200] "POST /administrator/index.php HTTP/1.1" 403 20981 "http://intranet.cis.local/administrator/index.php?option=com_joomlaupdate&task=update.captive&d5f917943621c6c141fb7385b8803dbe=1" "Mozilla/5.0 (Windows NT 5.2; rv:52.0) Gecko/20100101 Firefox/52.0"

nell'access.log di apache.
non trovo altri riferimenti.
« Ultima modifica: 24 Lug 2017, 17:30:27 da Sanma »

Offline danielecr

  • Appassionato
  • ***
  • Post: 529
    • Mostra profilo
Re:da 3.7.2 a 3.7.3 in locale con xampp
« Risposta #9 il: 25 Lug 2017, 13:46:11 »
Hai per caso un firewall? mod_security o simili?

Offline Sanma

  • Nuovo arrivato
  • *
  • Post: 27
    • Mostra profilo
Re:da 3.7.2 a 3.7.3 in locale con xampp
« Risposta #10 il: 25 Lug 2017, 14:37:03 »
Lo sapevo che era una cavolata.... premesso che mi scuso per la perdita di tempo ma..... era solo una questione di case sensitive anche se mi stupisce.....!
Il login alla pagina di amministrazione non lo . entro con qualsiasi minuscola o maiuscola metto nel nome. Lo alla richiesta dello user per l'installazione.
Il problema in se risolto, ma mi fa alquanto strano.

 

Torna su