Autore Topic: problema indirizzamento sito multilingue  (Letto 168 volte)

Offline brenno71

  • Esploratore
  • **
  • Post: 80
    • Mostra profilo
problema indirizzamento sito multilingue
« il: 05 Ago 2017, 18:53:42 »
Ciao,
sto creando un sito multilingue in cui sto incontrando vari problemi (sicuramente per mia colpa). Uno da cui non esco fuori č questo:
Entro nel sito ed ho la versione IT
Clicco sul link per la versione EN mi apre: www.miosito.it/en/index.html
Funziona tutto bene, ma se clicco sul logo presente nella home della versione inglese mi riporta, direi correttamente, nella sezione www.miosito.it/en dove, purtroppo, non compare il menų della sezione inglese. Non compare nessun menų. Menų che viene selezionato dalle impostazioni del template.
Ovviamente se assegno il menų inglese alla home generica (ho una home generica, una home IT, una home EN  - come da guide) lo stesso evento accade nella sezione IT. Che casino sto combinando? Grazie
Se

Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 28064
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
    • Xataface Italia
Re:problema indirizzamento sito multilingue
« Risposta #1 il: 05 Ago 2017, 19:25:05 »
La home generica deve appartenere a tutte le lingue e non ci devi assegnare nessun modulo menú. Il tuo problema forse deriva dal templare che non prevede assegnazione a lingua, in tal caso devi duplicarlo per ogni lingua.
NEWS DataGrill Xataface Installer (Ver. 1.0.1) per Joomla 3.8.x - DEMO Gestione Magazzino

Offline brenno71

  • Esploratore
  • **
  • Post: 80
    • Mostra profilo
Re:problema indirizzamento sito multilingue
« Risposta #2 il: 05 Ago 2017, 20:01:49 »
Grazie Tom per la velocitā!

Allora: sė il template non prevede le lingue infatti ha un problema anche con l'apposito modulo per la visualizzazione della selezione delle lingue.
Al momento ho un template per la home generica con menu italiano (creato dopo il tuo post), uno per la home italiana con menu italiano, uno con la home inglese con menu inglese.
Permane il problema. Ho notato anche che una volta entrato nella sezione inglese considera www.miosito.it/en come la root e anche se inserisco a mano www.miosito.it mi torna in www.miosito.it/en


Ho fatto delle prove andando ad assegnare i due menu alternandoli sulla home generale ed ovviamente rimane il problema solo che invece che sulla sezione inglese si incontra su quella italiana
Scusate ancora


« Ultima modifica: 05 Ago 2017, 20:49:18 da brenno71 »

Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 28064
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
    • Xataface Italia
Re:problema indirizzamento sito multilingue
« Risposta #3 il: 06 Ago 2017, 07:03:54 »
La home generica , deve essere assegnata a tutte le lingue. Non deve avere nessun modulo menų assegnato. Non confondere componente menų, voce menų e modulo menų.
NEWS DataGrill Xataface Installer (Ver. 1.0.1) per Joomla 3.8.x - DEMO Gestione Magazzino

Offline brenno71

  • Esploratore
  • **
  • Post: 80
    • Mostra profilo
Re:problema indirizzamento sito multilingue
« Risposta #4 il: 06 Ago 2017, 09:52:10 »
Grazie Tom,
alla prima tua risposta ho verificato ed effettivamente era attivo un modulo menų che ho subito disattivato.
Ora ho verificato di nuovo e non esistono moduli menų attivi.
La home generica č assegnata a tutte le lingue.
Ho un menų "generico" con una voce "Home" generica assegnata a tutte le lingue
Ho due menų identici, uno per lingua, assegnati alla singola lingua con voci associate fra di loro. Ognuno di questi due menų ha una voce home per la singola lingua.







 

Torna su