Autore Topic: 500 Unknown column 'a.client_id' in 'field list' Unknown column 'a.client_id' in  (Letto 292 volte)

Offline bbc281246

  • Nuovo arrivato
  • *
  • Post: 11
    • Mostra profilo

qualcuno può aiutarmi a capire che cosa è successo al backend di joomla !
grazie
bruno

Offline alexred

  • Administrator
  • Fuori controllo
  • *****
  • Post: 25390
  • Sesso: Maschio
  • Esperto in ozio relaxed
    • Mostra profilo
    • AlexRed.com
Ciao bbc281246,
forse è stato fatto un aggiornamento di Joomla ?

Offline bbc281246

  • Nuovo arrivato
  • *
  • Post: 11
    • Mostra profilo
Purtroppo sì, dalla 3.7.4 alla 3.7.5

Offline alexred

  • Administrator
  • Fuori controllo
  • *****
  • Post: 25390
  • Sesso: Maschio
  • Esperto in ozio relaxed
    • Mostra profilo
    • AlexRed.com
che procedura hai effettuato per fare l'aggiornamento ?

Offline bbc281246

  • Nuovo arrivato
  • *
  • Post: 11
    • Mostra profilo

All'nterno del backend è comparso il messaggio di aggiornamento , non ho fatto altro che cliccare.
Devo però dirti che io sto sviluppando un sito per conto di una persona che non è hostata su Joomla (mi risulta che per policy interna al forum non posso farne il nome , anche se puoi immaginarlo).
Successivamente ho anche provato una procedura di restore basata su Akeeba Kickstart cercando di utilizzare un backup vecchio ma secondo me ancora utile , il tentativo è fallito , non so perché.
A questo punto ho tentato un'altra strada : ho creato un DB vuoto (nell'hosting dove risiede il dominio ho a disposizione 5 db) e via ftp (filezilla) ho messo nel config i dati del vecchio db che , basato su joomla 3.7.4, funzionava correttamente prima del tentativo di aggiornamento. Risultato : il messaggio di errore messo in oggetto.
A questo punto ho aperto due ticket ,a quello su Joomla mi hanno risposto giustamente che non essendo un dominio Joomla non potevano farci nulla ; all'altro ticket mi devono ancora rispondere.
Quello che temo è che siano corrotti i dati , ma non so perché.
Nell'attesa in locale con Xampp cerco di ricostruire sotto 3.7.5 il sito ... a manina!
Comunque grazie dell'interessamento
 

Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 27698
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
    • Xataface Italia
Se punti ad un db vuoto è normale non trovare dati e tabelle. Se hai un backup ripristina quello. Ovviamente backup inteso con cartelle file e dump db.














NEWS DataGrill Xataface Installer (Ver. 1.0.0) per Joomla 3.6 ed un Esempio Applicazione Bblioteca

Offline bbc281246

  • Nuovo arrivato
  • *
  • Post: 11
    • Mostra profilo

L'unico backup utile , fatto con akeeba , in joomla 3.7.4 è quello che ho tentato di ripristinare con akeeba Kickstart , ma non ci sono riuscito . Domanda : in locale sotto Xampp posso inserire nella cartella apposita i file kickstart con il file di backup .jpa che ho generato non in locale (cioè sul dominio esterno a Joomla) , scusa l'imprecisione ma non sono un gran esperto in DB ?
In questo modo potrei proseguire lo sviluppo in locale e poi alla fine hostarlo all'esterno

Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 27698
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
    • Xataface Italia
Si con akeeba puoi ripristinare ovunque. Poi esporti in remoto manualmente che è sempre il miglior metodo e impari pure come è strutturato il cms joomla.
NEWS DataGrill Xataface Installer (Ver. 1.0.0) per Joomla 3.6 ed un Esempio Applicazione Bblioteca

Offline bbc281246

  • Nuovo arrivato
  • *
  • Post: 11
    • Mostra profilo

Problema risolto su server locale Xampp , sul server esterno i problemi continuano , ma almeno posso continuare lo sviluppo in locale , poi si vedrà.
Grazie comunque delle risposte
Bruno

 

Torna su