Autore Topic: [RISOLTO] Non si visualizzano i nuovi album in Ozio Gallery  (Letto 183 volte)

Offline Mat971

  • Nuovo arrivato
  • *
  • Post: 10
    • Mostra profilo
Ho aggiunto nuovi album su Google Foto ma Ozio Gallery in "Elenco album pubblici" non me li mostra.

Così ho provato a condividere gli album da Google foto e anche così niente da fare.
Ho provato a svuotare la cache del browser, di Joomla, ho provato con un altro browser ma niente, i nuovi album non li vedo.

Nei vari tentativi ho visto che i vecchi album, quelli che Ozio ancora mi mostra, in Google Foto risultano con la dicitura "condivisi" nonostante il fatto che scegliendo dal menù "opzioni di condivisione" compare la finestra per attivare la condivisione tramite link pubblico (come se fossero ancora da condividere).

Ricordo che una volta avevo reso pubblici degli album direttamente con Ozio Gallery, però non riesco a ripetere la procedura.


Qualche suggerimento?
« Ultima modifica: 16 Ott 2017, 17:39:22 da Mat971 »

Online alexred

  • Administrator
  • Fuori controllo
  • *****
  • Post: 25603
  • Sesso: Maschio
  • Esperto in ozio relaxed
    • Mostra profilo
    • AlexRed.com
Re:Non si visualizzano i nuovi album in Ozio Gallery
« Risposta #1 il: 11 Ott 2017, 13:35:24 »
Ciao Mat971,

Da febbraio 2017 Google non permette più di impostare come pubblici gli album di Google Foto. Non è più possibile cambiare le proprietà degli album utilizzando le API. La nuova versione Ozio Gallery 4.8.1 implementa un nuovo sistema per usare i nuovi album di Google Photo. Leggi le nuove istruzioni: https://www.opensourcesolutions.es/it/ext/ozio-gallery.html#Istruzioni

Offline Mat971

  • Nuovo arrivato
  • *
  • Post: 10
    • Mostra profilo
Re:Non si visualizzano i nuovi album in Ozio Gallery
« Risposta #2 il: 11 Ott 2017, 13:43:57 »
In primis grazie per la celere risposta.


Ho seguito le istruzioni, che già avevo letto a suo tempo, e le impostazioni mi risultano in linea con quello che ho letto ma i nuovi album non riesco comunque a vederli.


E l'unica stranezza che ho notato è quella che su Google Foto gli album "vecchi" compaiono con la dicitura "condivisi" anche se verificando le "opzioni di condivisione" risulta da attivare.

Online alexred

  • Administrator
  • Fuori controllo
  • *****
  • Post: 25603
  • Sesso: Maschio
  • Esperto in ozio relaxed
    • Mostra profilo
    • AlexRed.com
Re:Non si visualizzano i nuovi album in Ozio Gallery
« Risposta #3 il: 11 Ott 2017, 13:54:02 »
si, all'epoca era possibile condividere pubblicamente gli album, ora è presente solo una condivisione limitata che però non devi usare.
Assicurati di utilizzare un account Gmail e da quell'account creare gli album su Google Photos, quindi niente account G+ o Google business o altri.
Crea la tua API key su Google ed inserisci correttamente il tuo dominio nella api key, poi nella pagina di configurazione della Ozio Gallery aggiungi le credenziali della tua API key ed attiva il tuo utente Gmail da cui hai creato i normali album su Google Photo (non album condivisi).
Puoi anche provare ad aprire un nuovo account Gmail da configurare e su cui caricare le nuove foto.

Offline Mat971

  • Nuovo arrivato
  • *
  • Post: 10
    • Mostra profilo
Re:Non si visualizzano i nuovi album in Ozio Gallery
« Risposta #4 il: 11 Ott 2017, 15:02:14 »
Mi metto al lavoro e quando risolvo il problema lo scrivo.


Grazie.

Offline Mat971

  • Nuovo arrivato
  • *
  • Post: 10
    • Mostra profilo
Re:Non si visualizzano i nuovi album in Ozio Gallery
« Risposta #5 il: 12 Ott 2017, 20:18:30 »
Premetto che il funzionamento della console API di Google lo capisco poco, però partendo da un sito ex-novo il componente Ozio Gallery mi funziona alla perfezione. Creo un nuovo album e lo visualizzo all'istante tra le opzioni della voce di menù.
Mentre sul sito dov'era già presente, e correttamente configurato con le credenziali Google APls, i nuovi album non compaiono.
Ho provato ad aggiungere delle nuove credenziali dalla console di Google e sul componente, però senza successo.
Ho tentato eliminando le credenziali dal componente Ozio Gallery installato nel sito così da vedere se rimettendole magari si sbloccava qualcosa, e mi sono accorto che dalla voce di menù continuano ad esserci disponibili i vecchi album mentre credevo che senza credenziali non si dovessero più vedere.
Perciò ho cancellato la cache del browser ma tutto è rimasto invariato.


...qualche suggerimento?

Offline Mat971

  • Nuovo arrivato
  • *
  • Post: 10
    • Mostra profilo
Re:Non si visualizzano i nuovi album in Ozio Gallery
« Risposta #6 il: 13 Ott 2017, 12:05:43 »
Ho fatto nuovi tentativi e posso escludere con certezza un problema di configurazione delle API perché facendo dei test su altri siti riesco tranquillamente a vedere i nuovi album che invece non compaiono sul sito in questione.
A questo punto vorrei reinstallare Ozio però il mio dilemma è che dopo dovrò ricreare tutte le voci di menù, e sono parecchie, con relativo codice all'interno di tutti gli articoli che mostrano una OzioGallery e che sono altrettanto, se non più, numerosi.
Perciò domando: esiste una cache o dei file temporanei di Ozio che potrei provare a cancellare? Un registro eventi o simile che eliminandolo possa ricreare l'elenco degli album a disposizione?
E in caso non si potesse fare niente di del genere, qual'è il modo meno indolore per reinstallare OzioGallery?

Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 27834
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
    • Xataface Italia
Re:Non si visualizzano i nuovi album in Ozio Gallery
« Risposta #7 il: 13 Ott 2017, 13:57:48 »
Sei sicuro che le api non siano legate al dominio?
NEWS DataGrill Xataface Installer (Ver. 1.0.0) per Joomla 3.6 ed un Esempio Applicazione Bblioteca

Online alexred

  • Administrator
  • Fuori controllo
  • *****
  • Post: 25603
  • Sesso: Maschio
  • Esperto in ozio relaxed
    • Mostra profilo
    • AlexRed.com
Re:Non si visualizzano i nuovi album in Ozio Gallery
« Risposta #8 il: 13 Ott 2017, 14:04:29 »
ciao Mat971,
allega qualche schermata della tua configurazione delle API google sia nella Ozio Gallery che nella pagina di Google.
Sei certo che anche nel sito dove non si vedono i nuovi album tu utilizzi un account Gmal per gli album su Google Photos ?  niente account G+ o Google business

Offline Mat971

  • Nuovo arrivato
  • *
  • Post: 10
    • Mostra profilo
Re:Non si visualizzano i nuovi album in Ozio Gallery
« Risposta #9 il: 13 Ott 2017, 14:52:41 »
Sono quasi, il condizionale è d'obbligo, certo che sia tutto in regola.
Comunque avendo la versione a pagamento ho contattato l'assistenza e adesso se ne stanno occupando loro.
Appena scopro l'inghippo lo scrivo.

Offline Mat971

  • Nuovo arrivato
  • *
  • Post: 10
    • Mostra profilo
Re:Non si visualizzano i nuovi album in Ozio Gallery
« Risposta #10 il: 16 Ott 2017, 17:38:04 »
Dopo svariati tentativi ho disinstallato e reinstallato il componente utilizzando la versione aggiornata e adesso funziona a meraviglia.
Probabilmente si è trattato di un problema legato agli aggiornamenti perché reinstallando la versione che avevo utilizzato all'inizio, la 4.3.2, e aggiornandola, il malfunzionamento restava inalterato. Mentre installando direttamente l'ultima versione disponibile tutto è filato liscio come l'olio.


Il mio timore era che nel fare questa operazione dovessi rifare tutti i menu, e in quel sito ne ho parecchi, invece anche eliminando Ozio le varie voci sono rimaste inalterate, ovviamente non funzionanti, e quando l'ho reinstallato hanno ripreso a funzionare come, e meglio, di prima.
L'unica cosa da rifare dopo l'installazione è aggiungere le credenziali, ma questa è una cosa che si fa in un attimo.

 

Torna su