Autore Topic: Problemi installazione Template  (Letto 534 volte)

Offline Erica Giovanetti

  • Nuovo arrivato
  • *
  • Post: 11
  • Sesso: Femmina
    • Mostra profilo
Problemi installazione Template
« il: 18 Ott 2017, 18:00:14 »
Ciao a tutti!


Vi spiego brevemente il mio problema sperando non sia una ripetizione di qualche topic.
Ho provato a fare una ricerca ma mi sembra di capre che ogni caso sia a sé, quindi provo a spiegare il mio.


Ho acquistato un Template per Joomla e ho seguito le istruzioni d'installazione del venditore.
Mi presentava 2 possibilità ovvero caricare su server un pacchetto che comprendeva sia Joomla che il template, il tutto pronto all'uso, oppure un'installazione standard in cui mi occupavo autonomamente dell'installazione di Joomla per poi uploadare i file zip del template.


Il metodo consigliato era il primo ma mi ha dato grossi problemi dato che il gestore dello spazio web mi da limiti nel gestire la cosa in autonomia, ovvero se installo Joomla tramite loro posso creare un Database con tutte le caratteristiche necessarie, altrimenti mi da ben poche possibilità di personalizzare le opzioni. A causa di questo l'installazione del pacchetto presentava parecchi errori.
Ho provato quindi con la modalità classica e tutto sembra andare a buon fine se non fosse che quando visualizzo l'anteprima del sito si vede chiaramente che qualcosa non va.


Vi chiedo se potete aiutarmi a risolvere questa cosa che magari è una cavolata ma mi sta totalmente bloccando dall'iniziare il lavoro vero e proprio, ovvero quello della modifica del template.


Grazie!!


Erica

Offline adottauncane

  • Team Joomla.it
  • Instancabile
  • *******
  • Post: 17696
  • Sesso: Femmina
    • Mostra profilo
    • Adotta un cane
Re:Problemi installazione Template
« Risposta #1 il: 18 Ott 2017, 18:03:50 »
Ciao,
benvenuta nel forum.
Sul forum non si dà supporto a prodotti commerciali, quindi, se sono problemi specifici del template dovresti chiedere al produttore.

In generale, hai fatto l'installazione del template in maniera corretta?
Cosa non va?

Offline Erica Giovanetti

  • Nuovo arrivato
  • *
  • Post: 11
  • Sesso: Femmina
    • Mostra profilo
Re:Problemi installazione Template
« Risposta #2 il: 18 Ott 2017, 18:28:44 »
Ho acquistato il template parecchio tempo fa quindi non posso più usufruire del supporto del produttore.


Beh si, io ritengo di averlo fatto in maniera corretta, altrimenti se sapessi dove ho sbagliato avrei già probabilmente risolto.


Il problema è che il sito non si presenta graficamente come deve essere e quindi deduco debba esserci qualche problema...

Offline marine

  • Moderator
  • Instancabile
  • *****
  • Post: 2893
  • Sesso: Maschio
    • Mostra profilo
Re:Problemi installazione Template
« Risposta #3 il: 18 Ott 2017, 18:57:29 »
Abbiamo troppe poche informazioni per cercare di autarti, ma da una mia personale idea, penso che tu ti riferisca che non ci sono tutti i moduli presenti nella demo del template che hai acquistato.
IL consiglio che ti posso dare è di installare il quickstart (il pacchetto completo di tutto) in uno spazio gratuito tipo altervista o similari e da li poi fai il confronto con la tua installazione.

Offline adottauncane

  • Team Joomla.it
  • Instancabile
  • *******
  • Post: 17696
  • Sesso: Femmina
    • Mostra profilo
    • Adotta un cane
Re:Problemi installazione Template
« Risposta #4 il: 18 Ott 2017, 20:39:38 »
Non vedendo il sito, non sapendo che template usi, non avendo nessuna informazione utile, è impossibile aiutarti.
Fai come consiglia marine e controlla se nell'istallazione del solo template mancano moduli o altro, confrontandola con quella completa.
Puoi anche spacchettare il quickstart e vedere quali estensioni prevede l'installazione completa.

Offline Erica Giovanetti

  • Nuovo arrivato
  • *
  • Post: 11
  • Sesso: Femmina
    • Mostra profilo
Re:Problemi installazione Template
« Risposta #5 il: 18 Ott 2017, 22:56:36 »
Ho dato una panoramica completa ma certo se necessario posso dare tutte le specifiche del caso...


L'installazione standard l'avevo già fatta su altervista e mi dava lo stesso problema.
Mi sembra strano però sia un errore del template perché ha 300 download, penso il problema sarebbe stato lampante..


Provo l'installazione tramite quickstart su altervista e vi aggiorno!


Intanto grazie..

Offline giusebos

  • Fuori controllo
  • *
  • Post: 18278
  • Sesso: Maschio
  • Giuseppe Serbelloni Mazzanti Viendalmare
    • Mostra profilo
    • Demo iCagenda
Re:Problemi installazione Template
« Risposta #6 il: 18 Ott 2017, 23:19:58 »
Non vedendo il sito, non sapendo che template usi, non avendo nessuna informazione utile, è impossibile aiutarti.


Io ci riesco concentrandomi sull'avatar dell'utente, aprendo un corridoio spazio temporale riesco a vedere tutto quello che vede l'utente......una sorta di "condividi lo schermo" di Skype.

Sto studiando al fine di poter invece operare come teamwiever, così da prendere possesso della macch... hem del corpo in questo caso e sistemare le cose direttamente.   ;D ;D ;D ;D

su www.icagenda.it guide e tutorial con esempi di chronoforms e chronoconnectivity

Offline Erica Giovanetti

  • Nuovo arrivato
  • *
  • Post: 11
  • Sesso: Femmina
    • Mostra profilo
Re:Problemi installazione Template
« Risposta #7 il: 23 Ott 2017, 23:52:20 »
Rieccomi!
Ho provato l'installazione su Altervista tramite Quickstart e tutto è funzionato a pennello!
Ho quindi ritentato sul mio Host ma niente da fare.
Con l'installazione classica come vi dicevo il sito si visualizza ma non come dovrebbe essere. Con Quickstart invece mi escono proprio delle stringhe di errore.
Questo è il sito:
http://ericagiovanetti.it/


Questa l'nstallazione fatta su Altervista:
http://joomlaprova.altervista.org/


Ho notato però che Altervista utilizza PHP 5.6, mentre io sto utilizzando 1&1 che utilizza il 7!

A questo punto mi chiedo se sia questo il problema o se possa essere una questione di provilegi sul Database...


Grazie in anticipo!

Online danielecr

  • Appassionato
  • ***
  • Post: 487
    • Mostra profilo
Re:Problemi installazione Template
« Risposta #8 il: 24 Ott 2017, 00:12:01 »
Ciao Erica,
la tua versione di joomla dovrebbe essere la 3.3.6 e questa versione non supporta php 7.

Tralascio la solita trafila del perchè non bisognerebbe utilizzare versioni di joomla datate... ::)

Offline Erica Giovanetti

  • Nuovo arrivato
  • *
  • Post: 11
  • Sesso: Femmina
    • Mostra profilo
Re:Problemi installazione Template
« Risposta #9 il: 24 Ott 2017, 00:17:51 »
L'ho installato tramite Quickstart quindi non ho la possibilità di sceglierla...


Come dicevo avevo provato anche l'installazione classica ma anche lì ho avuto problemi. In quel caso il template veniva visualizzato, senza codici di errore, ma incompleto e non come si vede ora su Altervista.

Online danielecr

  • Appassionato
  • ***
  • Post: 487
    • Mostra profilo
Re:Problemi installazione Template
« Risposta #10 il: 24 Ott 2017, 00:30:06 »
Ok, lo installi con il pacchetto quickstart con quella versione di joomla, ma poi potrai aggiornarla no? Scusa ma non ho mai installato un pacchetto quickstart quindi non so come funziona, ma immagino si possa aggiornare.
Può essere però che il template non sia compatibile con l'ultima versione di joomla, in questo caso l'acquisto del template non è stata una scelta proprio saggia, in quanto ti ritroveresti bloccata a una versione di joomla datata per farlo funzionare, con tutti i problemi di sicurezza del caso.
Può anche essere che il template non sia compatibile con la versione di php 7, in questo caso se il tuo hosting te lo permette, potresti retrocedere nella versione di php (tipo la 5.6.31), ma tenendo joomla aggiornato.

Offline Erica Giovanetti

  • Nuovo arrivato
  • *
  • Post: 11
  • Sesso: Femmina
    • Mostra profilo
Re:Problemi installazione Template
« Risposta #11 il: 24 Ott 2017, 00:42:51 »
Teoricamente si, dovrei poterla aggiornare.
Il problema è che se l'installazione presenta degli errori come quelli che presenta a me non posso fare nulla se non guardare quelle bellissime stringhe di errore! :-)


Il template l'ho acquistato tempo fa, probabilmente al tempo era l'ultima versione di Joomla ma avendone bisogno ora spererei che questo sia un problema non insormontabile!


Vorrei capire però di preciso quale è il problema, se la vecchia versione di Joomla (e a questo punto ritento con l'installazione classica e vi mostro come si presenta così) oppure la versione PHP e vedere in quel caso se posso risolvere in altro modo.

Online danielecr

  • Appassionato
  • ***
  • Post: 487
    • Mostra profilo
Re:Problemi installazione Template
« Risposta #12 il: 24 Ott 2017, 08:28:46 »
Per saperlo installi il quickstart con joomla 3.3.6 e php <5.6.31 (meglio se la 5.6.31).
Aggiorni joomla alla 3.8.1 mantenendo php 5.6.31 o comunque un php compatibile (e fino a qui puoi farlo su altervista).
Infine cambi php a 7, se il tuo host non ha un php switcher fai un backup da altervista e poi lo importi sul nuovo host.
In questo modo hai tutti gli incroci.
« Ultima modifica: 24 Ott 2017, 08:32:19 da danielecr »

Offline Erica Giovanetti

  • Nuovo arrivato
  • *
  • Post: 11
  • Sesso: Femmina
    • Mostra profilo
Re:Problemi installazione Template
« Risposta #13 il: 29 Ott 2017, 14:16:30 »
Grazie 1000 il problema era proprio quello!!


L'unica cosa è che ora mi da un messaggio di errore che però sparisce prima ancora di avere il tempo di leggerlo...
Dopo di che carica il sito apparentemente normalmente...


http://ericagiovanetti.it/


Cosa potrebbe essere?




Offline Erica Giovanetti

  • Nuovo arrivato
  • *
  • Post: 11
  • Sesso: Femmina
    • Mostra profilo
Re:Problemi installazione Template
« Risposta #14 il: 29 Ott 2017, 14:18:26 »
Vedo anche che scorrendo si muove a scatti e che mi da problemi con la parte in cui dovrebbe essere visualizzata la cartina da google maps...

Online danielecr

  • Appassionato
  • ***
  • Post: 487
    • Mostra profilo
Re:Problemi installazione Template
« Risposta #15 il: 29 Ott 2017, 14:26:05 »
Riguardo all'"errore" non è un errore ma un warning, che si riferisce al plugin plgsystemk2.
Il warning è questo:
Codice: [Seleziona]
Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; plgSystemK2 has a deprecated constructor in ...../htdocs/plugins/system/k2/k2.php on line 15

Maggiori info le trovi qua:
http://php.net/manual/en/migration70.deprecated.php

Prima verifica di avere tutte le estensioni aggiornate.
Nel caso, se vuoi, puoi nasconderlo con un php.ini, sempre se il tuo host te lo consente.

A scatti non lo vedo a scatti, potrebbe essere il tuo pc un po' più vecchio del mio o non troppo performante?Mi sa di template non proprio snello.

Google maps andrà impostato, forse gli manca la chiave api, che devi generare, anche se qua sul forum ho letto che puoi visualizzarla anche senza chiave.

Offline Erica Giovanetti

  • Nuovo arrivato
  • *
  • Post: 11
  • Sesso: Femmina
    • Mostra profilo
Re:Problemi installazione Template
« Risposta #16 il: 31 Ott 2017, 17:14:38 »
Ho provato a controllare se i plug in erano aggiornati ma entrando nel pannello di amministrazione mi da questo errore:
Citazione
Failed to start the session because headers have already been sent by "/homepages/45/d700193167/htdocs/plugins/system/k2/k2.php" at line 15.
di consguenza non riesco a fare nulla!
è il caso di riportare la versione PHP a quella precedente?


La copia che ho installato su altervista non va a scatti quindi non è il mio pc, in più confrontandole vedo che su ericagiovanetti.it non visualizza nemmeno la sezione "Works" e l'errore che mi da per la mappa su altervista non c'è quindi non credo sia solo questione di impostarlo...
« Ultima modifica: 31 Ott 2017, 17:16:20 da Erica Giovanetti »

Offline Erica Giovanetti

  • Nuovo arrivato
  • *
  • Post: 11
  • Sesso: Femmina
    • Mostra profilo
Re:Problemi installazione Template
« Risposta #17 il: 31 Ott 2017, 17:22:00 »
Riportando la versione PHP alla precedente i problemi spariscono ( tranne quello della mappa) quindi confermo il problema fosse quello!
Ora provo a controllare i plug in siano aggiornati e ritento lo switch al 7...

Online danielecr

  • Appassionato
  • ***
  • Post: 487
    • Mostra profilo
Re:Problemi installazione Template
« Risposta #18 il: 31 Ott 2017, 17:26:17 »
Io penso che il template non sia compatibile con php 7.
Per quanto riguarda la mappa confermo il problema della chiave api.

Negli strumenti di firefox mi segnala questo, sia per la versione ufficiale sia per la prova su altervista (nemmeno su altervista si vede la mappa).

"Google Maps API error: MissingKeyMapError https://developers.google.com/maps/documentation/javascript/error-messages#missing-key-map-error"
"Google Maps API warning: NoApiKeys https://developers.google.com/maps/documentation/javascript/error-messages#no-api-keys"
"Google Maps API warning: SensorNotRequired https://developers.google.com/maps/documentation/javascript/error-messages#sensor-not-required"

Il modulo probabilmente utilizza le api javascript quindi devi generare una chiave api e settarla da qualche parte.

Offline Erica Giovanetti

  • Nuovo arrivato
  • *
  • Post: 11
  • Sesso: Femmina
    • Mostra profilo
Re:Problemi installazione Template
« Risposta #19 il: 31 Ott 2017, 17:29:51 »
No non si vede ma non esce il messaggio di errore...
Comunque ho trovato dei componenti che andavano aggiornati e poi riportato alla versione 7. Ora funziona tutto.
Niente scatti, le sezioni si vedono correttamente e niente warning all'apertura del sito...che però compare nella pagine principale del pannello di amministrazione! Lo posso lasciare o mi può creare problemi in futuro?

 

Torna su