Autore Topic: Aggiornamento da J2.5.28 a J3.5.1  (Letto 230 volte)

Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 27923
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
    • Xataface Italia
Aggiornamento da J2.5.28 a J3.5.1
« il: 19 Ott 2017, 13:44:31 »
Buongiorno

Devo aggiornare un sito come in oggetto, ho fatto il backup e trasportato in locale, Cancello come da prassi cache, browser e joomla , da joomla update mi dice che ho gi l'ultima versione, vado nelle opzioni e setto short term support, ma purtroppo non mi salva e resta nel long term support, chiedo come settare l'opzione direttamente nel db. Ho fatto una ricerca  nelle tabelle del db senza esito.
NEWS DataGrill Xataface Installer (Ver. 1.0.1) per Joomla 3.6 ed un Gestione Magazzino

Offline alexred

  • Fuori controllo
  • *
  • Post: 25674
  • Sesso: Maschio
  • Esperto in ozio relaxed
    • Mostra profilo
    • AlexRed.com
Re:Aggiornamento da J2.5.28 a J3.5.1
« Risposta #1 il: 19 Ott 2017, 13:57:05 »
Ciao    tomtomeight,
nessun messaggio di errore al salvataggio ? 
Neppure nei file di log errori di PHP ?
Che versione di PHP ?

Offline danielecr

  • Appassionato
  • ***
  • Post: 487
    • Mostra profilo
Re:Aggiornamento da J2.5.28 a J3.5.1
« Risposta #2 il: 19 Ott 2017, 14:30:54 »
Ciao tomtomheight,
ho installato una versione 2.5.28 di test salvato il database, impostato lo short term support, risalvato il database e infine paragonato con un comparatore txt i due database:

Dovrebbe essere sufficiente aggiungere \"updatesource\":\"sts\",\"customurl\":\"\" per lo short term support (vedi il paragone tra le due stringhe)

Long term support:
Codice: [Seleziona]
(28, 'com_joomlaupdate', 'component', 'com_joomlaupdate', '', 1, 1, 0, 1, '{\"legacy\":false,\"name\":\"com_joomlaupdate\",\"type\":\"component\",\"creationDate\":\"February 2012\",\"author\":\"Joomla! Project\",\"copyright\":\"(C) 2005 - 2014 Open Source Matters. All rights reserved.\\t\",\"authorEmail\":\"admin@joomla.org\",\"authorUrl\":\"www.joomla.org\",\"version\":\"2.5.0\",\"description\":\"COM_JOOMLAUPDATE_XML_DESCRIPTION\",\"group\":\"\"}', '{}', '', '', 0, '0000-00-00 00:00:00', 0, 0),

Shor term support:
Codice: [Seleziona]
(28, 'com_joomlaupdate', 'component', 'com_joomlaupdate', '', 1, 1, 0, 1, '{\"legacy\":false,\"name\":\"com_joomlaupdate\",\"type\":\"component\",\"creationDate\":\"February 2012\",\"author\":\"Joomla! Project\",\"copyright\":\"(C) 2005 - 2014 Open Source Matters. All rights reserved.\\t\",\"authorEmail\":\"admin@joomla.org\",\"authorUrl\":\"www.joomla.org\",\"version\":\"2.5.0\",\"description\":\"COM_JOOMLAUPDATE_XML_DESCRIPTION\",\"group\":\"\"}', '{\"updatesource\":\"sts\",\"customurl\":\"\"}', '', '', 0, '0000-00-00 00:00:00', 0, 0),

Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 27923
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
    • Xataface Italia
Re:Aggiornamento da J2.5.28 a J3.5.1
« Risposta #3 il: 19 Ott 2017, 19:48:59 »
Al salvataggio mi dice successfull e la versione php su xampp la7.1.x 
Domani provo a modificare il db come da suggerimento di daniele
 Ringrazio entrambi.
NEWS DataGrill Xataface Installer (Ver. 1.0.1) per Joomla 3.6 ed un Gestione Magazzino

Offline alexred

  • Fuori controllo
  • *
  • Post: 25674
  • Sesso: Maschio
  • Esperto in ozio relaxed
    • Mostra profilo
    • AlexRed.com
Re:Aggiornamento da J2.5.28 a J3.5.1
« Risposta #4 il: 19 Ott 2017, 20:19:23 »
mi pare parecchio esagerato usare Joomla 2.5 su PHP 7.1, ma anche 7.0 non consigliato, non pienamente compatibile con PHP 7 Joomla 2.5.

Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 27923
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
    • Xataface Italia
Re:Aggiornamento da J2.5.28 a J3.5.1
« Risposta #5 il: 19 Ott 2017, 20:23:48 »
mi pare parecchio esagerato usare Joomla 2.5 su PHP 7.1, ma anche 7.0 non consigliato, non pienamente compatibile con PHP 7 Joomla 2.5.
Lo so ma pensavo che bastasse ignorare gli errori e che poi una volta passato alla v3 si stabilizzava. Se non ci riesco reinstallo una xampp con  php inferiore.
NEWS DataGrill Xataface Installer (Ver. 1.0.1) per Joomla 3.6 ed un Gestione Magazzino

Offline maicolstaip

  • Global Moderator
  • Instancabile
  • ********
  • Post: 17530
  • Sesso: Maschio
    • Mostra profilo
    • https://www.hoteledelweiss.net/
Re:Aggiornamento da J2.5.28 a J3.5.1
« Risposta #6 il: 23 Ott 2017, 12:22:00 »
Ciao,
mi capitato di dover provare un aggiornamento tipo il tuo tomtom,  con php 7 un disastro per joomla 2.5.
Alla fine ho usato l'oramai classico j2xml e buonanotte ai suonatori.
Non si risponde a PM tecnici. Postate sul forum. Grazie.

 

Torna su