Autore Topic: Error: 0 - Call to undefined method Joomla\Registry\Registry::getValue()  (Letto 170 volte)

Offline frammenti

  • Nuovo arrivato
  • *
  • Post: 13
    • Mostra profilo

Salve a tutti,


Ho avuto diversi problemi con Joomla nelle ultime settimane:


Nella pagina appariva questo testo
Codice: [Seleziona]


<?php/** * @package             Joomla.Site * @copyright   Copyright (C) 2005 - 2014 Open Source Matters, Inc. All rights reserved. * @license             GNU General Public License version 2 or later; see LICENSE.txt */// Set flag that this is a parent file.define('_JEXEC', 1);define('DS', DIRECTORY_SEPARATOR);if (file_exists(dirname(__FILE__) . '/defines.php')) {        include_once dirname(__FILE__) . '/defines.php';}if (!defined('_JDEFINES')) {        define('JPATH_BASE', dirname(__FILE__));        require_once JPATH_BASE.'/includes/defines.php';}require_once JPATH_BASE.'/includes/framework.php';// Mark afterLoad in the profiler.JDEBUG ? $_PROFILER->mark('afterLoad') : null;// Instantiate the application.$app = JFactory::getApplication('site');// Initialise the application.$app->initialise();// Mark afterIntialise in the profiler.JDEBUG ? $_PROFILER->mark('afterInitialise') : null;// Route the application.$app->route();// Mark afterRoute in the profiler.JDEBUG ? $_PROFILER->mark('afterRoute') : null;// Dispatch the application.$app->dispatch();// Mark afterDispatch in the profiler.JDEBUG ? $_PROFILER->mark('afterDispatch') : null;// Render the application.$app->render();// Mark afterRender in the profiler.JDEBUG ? $_PROFILER->mark('afterRender') : null;// Return the response.echo $app;


Il servizio di hosting mi risponde al ticket di assistenza in questo modo:

il problema era legato al file .htaccess e alla riga in esso contenuto che riporto di seguito AddHandler application/x-httpd-php55 .phpDopo aver commentato questa riga, utilizzando il carattere #, il problema si risolto.

Successivamente mi decido ad aggiornare il sito
fermo ancora a Joomla 2.5. Ho effettuato l'aggiornamento delle mie estensioni in vista dell'aggiornamento a Joomla 3.X
Successivamente, quando procedo all'aggiornamento dall'interno del pannello di amministrazione con la funzione automatica ottengo questo messaggio di errore:




Error: 0 - Call to undefined method Joomla\Registry\Registry::getValue()
You may not be able to visit this page because of:


an out-of-date bookmark/favourite
a search engine that has an out-of-date listing for this site
a mistyped address you have no access to this page
The requested resource was not found.
An error has occurred while processing your request.



Il servizio di hosting mi risponde cos:


"l'errore riportato dai file di logxxxx.it [Mon Oct 23 09:43:16 2017] [error] [client 5.170.105.79:54099] AH01215: PHP Fatal error: Call to a member function getDefaults() on a non-object in /home/sites/xxxx.it/public_html/modules/mod_roknavmenu/lib/librokmenu/RokMenu.php on line 64: /home/sites/xxxx.it/public_html/index.php Rinominando il modulo mod_roknavmenu, sar possibile sbloccare la situazione. E' un problema legato a Joomla quindi...."

Non funzionando neanche il pannello amministrativo di Joomla, ho deciso di disabilitare da PhpMyAdmin la maggior parte delle estensioni non essenziali oltre id 10000.
Niente.
L'errore persiste.

Ho la sensazione che il problema sia legato al framework di gestione del template Gantry, ma non ho idea di come si possa selezionare un diverso template, senza potervi accedere al pannello amministrativo di Joomla.

Avete qualche idea?
« Ultima modifica: 28 Ott 2017, 15:56:55 da frammenti »

Offline frammenti

  • Nuovo arrivato
  • *
  • Post: 13
    • Mostra profilo
Il servizio di hosting mi risponde cos:


"Il problema non il database, ma i file di joomla che sono in uno stato inconsistente. L'errore Call to undefined method Joomla\Registry\Registry::getValue()
Se ha fatto l'upgrade provi a controllare se dei file vecchi di versioni precedenti non siano rimasti nello spazio."



Sto effettuando l'upload dei files non con il backup zippato da pannello di controllo con la funzione Restore, ma con un software per l'ftp.
Il problema si verificato proprio in fase di upgrade. Il mio back-up precede l'aggiornamento in quanto prima dell'aggiornamento che il sito funzionava.

Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 27923
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
    • Xataface Italia
Citazione
Il problema si verificato proprio in fase di upgrade

E come lo hai fatto l'upgrade?
NEWS DataGrill Xataface Installer (Ver. 1.0.1) per Joomla 3.6 ed un Gestione Magazzino

 

Torna su