Autore Topic: Problema dopo migrazione da 2.5.8 a 3.x andata a buon fine  (Letto 300 volte)

Offline flord

  • Nuovo arrivato
  • *
  • Post: 8
    • Mostra profilo

Un saluto a tutti
"ritorno sul forum dopo una parentesi di test su WP ...e una veloce retromarcia"


Pongo qui un quesito "variegato" nei suoi molteplici aspetti tecnici che non ho trovato nel forum.


premessa: Dopo alcuni tentativi e correzione alle configurazioni sono riuscito a migrare senza problemi da 2.5.8 a 3.1.1 e successivamente fino all'ultima versione 3.8.5, la migrazione č stata fatta on-line utilizzando una copia del sito in un sottodominio (e correggendo le configurazioni per /tmp e /logs). Come componenti aggiuntivi sul sito c'č solo Phoca Gallery e basta.
Quasi tutti gli articoli incorporano una galleria fotografica di Phoca ed č la funzionalitā pių importante che vorrei salvaguardare.


il problema penso sia riconducibile a PHP (o al template) per quel che ne capisco ma:
con il sito nella versione 2.5.8 prima dell'installazione succedeva che se cambiavo la versione di PHP passando dalla 5.4.45 a versioni successive mi sparivano i menų nel front-end (il template č Beez2). (di PHP sul pannello lato server posso avere le seguenti versioni 5.4.45-5.5.38-5.6.35-7.0.29 e 7.1.16)


Nella migrazione effettuata per step, passando dalla 3.1.1 alle successive mi sono sparite progressivamente diverse cose fino al il front-end  e nella parte la parte amministrativa tutti i menų sono presenti ma solo alcuni funzionano. Purtroppo non mi funziona la gestione delle estensioni, ad esempio. Tutto il resto dā errore 500


Le domande che vi sottopongo  sono queste:


come devo comportarmi con la versione di PHP ?... la migrazione parte con la versione PHP 5.4.45 che poi mi segnala "obsoleta": devo cambiarla prima di fare la migrazione o dopo? la migrazione stessa ha bisogno di una versione PHP successiva a quella di origine, ...quale?


se rifaccio la migrazione dal sito funzionante con PHP 5.4.45 cosa dovrei fare con PhocaGallery? (disabilitarla prima, disinstallarla, aggiornarla - prima? ...dopo?)


il template (grande punto di domanda) come devo regolarmi?
vedo che la maggior parte dei template nella versione 3.x non sono compatibili con la 2.5.8
Devo cambiarlo prima (dopo non č possibile dato che nel backend la funzione mi porta a una pagina con errore 500, come tutti quei menų che non mi funzionano del resto).


Leggendo vari post sulla migrazione e le guide non mi risulta chiaro quando si parla di aggiornare, tutti i componenti, plugin, template vanno aggiornati prima o dopo la migrazione? ...se le versioni non sono compatibili prima non posso farlo e dopo che si fa se dovessero creare problemi?


p.s. nella "disperazione" ho anche provato a fare un'installazione pulita della versione 3.8.5 ed esportare gli articoli, categorie e utenti (sono solo 2) utilizzando l'estensione gratuita J2XML ma riscontrando pių o meno gli stessi problemi.
E' possibile che il problema sia riconducibile a del codice contenuto negli articoli magari generato dai collegamenti di Phoca Gallery ??  (...che avrei a priori escluso)


ringrazio molto se qualcuno ha qualche risposta alle domande, anche se parziale.


buon joomla a tutti




Offline giusebos

  • Fuori controllo
  • *
  • Post: 19557
  • Sesso: Maschio
  • Giuseppe Serbelloni Mazzanti Viendalmare
    • Mostra profilo
    • Demo iCagenda
Re:Problema dopo migrazione da 2.5.8 a 3.x andata a buon fine
« Risposta #1 il: 18 Apr 2018, 11:12:49 »
qui usiamo una domanda per discussione in modo tale che con titolo esplicativo sia di aiuto ad altri che hanno o avranno lo stesso problema.
su www.icagenda.it guide e tutorial con esempi di chronoforms e chronoconnectivity

Offline flord

  • Nuovo arrivato
  • *
  • Post: 8
    • Mostra profilo
Re:Problema dopo migrazione da 2.5.8 a 3.x andata a buon fine
« Risposta #2 il: 19 Apr 2018, 09:39:20 »
Scusa,...ma non avevo idea di come porre la domanda :-[

Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 29135
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
    • Xataface Italia
Re:Problema dopo migrazione da 2.5.8 a 3.x andata a buon fine
« Risposta #3 il: 19 Apr 2018, 10:53:08 »
Il problema non č il come ma il quante insieme che ovviamente crea confusione nelle risposte e non rende il forum fruibile per la diffusione, e la ricerca di soluzione per le problematiche derivanti dall'utilizzo del cms Joomla che in ultimo č lo scopo stesso di questo forum e non, come molti credono, (non č il tuo caso) sia solo risolvere i problemi  e le richieste dei clienti.
Quindi per una migliore strutturazione e usabilitā č preferibile un post una richiesta con sezione e titolo adeguato.
NEWS DataGrill Xataface Installer (Ver. 1.0.1) per Joomla 3.8.x - DEMO Gestione Magazzino

 

Torna su