Autore Topic: Errore: Please run "composer require google/apiclient:~2.0" in....  (Letto 233 volte)

Offline dagh

  • Appassionato
  • ***
  • Post: 216
    • Mostra profilo
Salve a tutti,
sto cercando di utilizzare una api di google ma ricevo il messaggio di errore :
please run "composer require google/apiclient:~2.0" in "/home/tyftlmah/public_html/plugins/content/DirectPHP"

Ho utilizzato DirectPHP per implementare il codice direttamente in una pagina.

Avete qualche coniglio ?
Grazie a tutti!

Offline giusebos

  • Fuori controllo
  • *
  • Post: 19557
  • Sesso: Maschio
  • Giuseppe Serbelloni Mazzanti Viendalmare
    • Mostra profilo
    • Demo iCagenda
Re:Errore: Please run "composer require google/apiclient:~2.0" in....
« Risposta #1 il: 07 Mag 2018, 23:40:25 »
te ne do giusto uno:

investi un po' di energia in pi¨ per spiegare quello che vuoi fare ;)


la tua domanda Ŕ tipo

cercavo di andare in via Roma, ma sono rimasto intrappolato nel traffico!

Prova tu a darmi una risposta ;)
su www.icagenda.it guide e tutorial con esempi di chronoforms e chronoconnectivity

Offline dagh

  • Appassionato
  • ***
  • Post: 216
    • Mostra profilo
Re:Errore: Please run "composer require google/apiclient:~2.0" in....
« Risposta #2 il: 11 Mag 2018, 18:34:58 »
Hai ragione, scusatemi  :P :P

Vorrei dare la possibilitÓ agli utenti del mio sito di caricare dei video su youtube direttamente dalla mio sito (ovviamente utilizzo Joomla  :) ).Ho provato a cercare qualche componente giÓ pronto ma non avendo trovato nulla del genere ho deciso di provare ad usare l'api di google che ho trovato a questo indirizzo: https://developers.google.com/youtube/v3/docs/videos/insert .

Avendo a disposizione un esempio in PHP ho utilizzato DirectPHP per implementare il codice direttamente in un articolo. 

Ho provato ad utilizzare l'esempio in php inserendo il mio OAUTH2_CLIENT_ID e OAUTH2_CLIENT_SECRET ma mi viene restituito l'errore "please run "composer require google/apiclient:~2.0" in "/home/tyftlmah/public_html/plugins/content/DirectPHP" .


Avete qualche consiglio o suggerimento ?

Grazie
« Ultima modifica: 11 Mag 2018, 18:52:02 da dagh »

Offline giusebos

  • Fuori controllo
  • *
  • Post: 19557
  • Sesso: Maschio
  • Giuseppe Serbelloni Mazzanti Viendalmare
    • Mostra profilo
    • Demo iCagenda
Re:Errore: Please run "composer require google/apiclient:~2.0" in....
« Risposta #3 il: 11 Mag 2018, 19:19:14 »
con joomla scordati di appiccicare codice alla meno peggio, non funzionerebbe e comprometteresti la sicurezza del cms.
Con joomla o ti crei la tua estensione secondo le librerie del cms usando le classi del framework oppure ti cerchi un estensione giÓ pronta.

Ti conviene cercare un estensione nella jed,
su www.icagenda.it guide e tutorial con esempi di chronoforms e chronoconnectivity

Offline Lina Adrena

  • Nuovo arrivato
  • *
  • Post: 8
    • Mostra profilo
Re:Errore: Please run "composer require google/apiclient:~2.0" in....
« Risposta #4 il: 11 Mag 2018, 21:28:27 »
Vorrei dare la possibilitÓ agli utenti del mio sito di caricare dei video su youtube direttamente dalla mio sito
----------------------------------------------------------------------
Col tuo account o ti consegnano direttamente il loro? :)

 

Torna su