Autore Topic: [RISOLTO] Forzatura SSL non va  (Letto 325 volte)

Offline mirro

  • Esploratore
  • **
  • Post: 87
    • Mostra profilo
[RISOLTO] Forzatura SSL non va
« il: 12 Mag 2018, 13:06:15 »
Ciao a tutti, ho un problema con il sito www.joedibrutto.it al quale vorrei abilitare un mini e-commerce per vendita di magliette.
Volevo abilitare la forzatura su SSL, dopo avere verificato che il certificato fosse ok sul provider, ma non riesco a farlo andare.
Se digito manualmente l'indirizzo https mi ritorna in automatico in http; se abilito la forzatura da backend va in loop e non funziona nulla.
Le ho provate un po' tutte, ho guardato un sacco di forum, ho un altro sito che gestisco e non mi ha dato il minimo problema, ho confrontato i file .htaccess di entrambi e sono identici, quindi non quello il problema. Ho provato a disattivare uno ad uno i plugin di terze parti, pulendo la cache del browser... niente... non pu essere nemmeno il template, ho usato il medesimo software dell'altro sito per crearlo... ho provato anche a mettere quello di default, non va ugualmente...
Ma porcaccia la miseriaccia... qualcuno ha qualche suggerimento?
Ci sto passando le serate, mannaggia...


Grazie mille in anticipo.
« Ultima modifica: 13 Mag 2018, 13:47:49 da mirro »

Online marine

  • Moderator
  • Instancabile
  • *****
  • Post: 4367
  • Sesso: Maschio
    • Mostra profilo
Re:Forzatura SSL non va
« Risposta #1 il: 12 Mag 2018, 13:11:01 »
metti a mano il valore 1 alla voce force ssl (o qualcosa di simile, vado a memoria) nel file configuration.php

Offline mirro

  • Esploratore
  • **
  • Post: 87
    • Mostra profilo
Re:Forzatura SSL non va
« Risposta #2 il: 12 Mag 2018, 13:20:37 »
metti a mano il valore 1 alla voce force ssl (o qualcosa di simile, vado a memoria) nel file configuration.php


Il valore corretto sarebbe "2" (forza su tutto il sito), ho provato pure quello, nulla. Non comunque il settaggio che non mi prende, non va proprio il sito.. Il backend funziona benissimo in https. Ho scritto al provider, mi stato risposto che c' sicuramente qualcosa che forza su http e non consente https; pensano al template o a qualche plugin, ma io pi di disattivare un plugin alla volta non so che fare...

Offline Anthony Marra

  • Esploratore
  • **
  • Post: 125
  • Sesso: Maschio
    • Mostra profilo
Re:Forzatura SSL non va
« Risposta #3 il: 12 Mag 2018, 17:36:39 »
Cerca nella Jed "ssl redirect" ed installala, potresti risolverle.. nell'impostazione ha anche la forzatura a https://
Io la provai su un sito demo moltissimo tempo fa... E faceva il suo dovere.
Visto che tramite htaccess impostazioni ecc non hai risolto.. prova questa..
Ciao

Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 29302
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
    • Xataface Italia
Re:Forzatura SSL non va
« Risposta #4 il: 12 Mag 2018, 17:42:10 »
In joomla non si deve modificare e o impostare nulla se il certificato correttamente installato lato server.
Serve solo il redirect da http ad https lato  .htaccess.
NEWS DataGrill Xataface Installer (Ver. 1.0.1) per Joomla 3.8.x - DEMO Gestione Magazzino

Offline danielecr

  • Abituale
  • ****
  • Post: 966
    • Mostra profilo
Re:Forzatura SSL non va
« Risposta #5 il: 12 Mag 2018, 19:31:18 »
C'e gi un redirect 303 da https a http (per il solo frontend).
Impostare ora un redirect da http a https porterebbe quasi sicuramente all'errore "troppi reindirizzamenti".
Devi individuare dove viene impostato il reidirizzamento da https a http: comincerei dall'.htaccess

Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 29302
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
    • Xataface Italia
Re:Forzatura SSL non va
« Risposta #6 il: 12 Mag 2018, 19:55:33 »
Che senso ha un 303 da https a http?
NEWS DataGrill Xataface Installer (Ver. 1.0.1) per Joomla 3.8.x - DEMO Gestione Magazzino

Offline danielecr

  • Abituale
  • ****
  • Post: 966
    • Mostra profilo
Re:Forzatura SSL non va
« Risposta #7 il: 12 Mag 2018, 21:15:25 »
Nessuno! ;D

Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 29302
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
    • Xataface Italia
Re:Forzatura SSL non va
« Risposta #8 il: 12 Mag 2018, 21:28:46 »
Appunto, lo toglie mette quello giusto e risolve.
NEWS DataGrill Xataface Installer (Ver. 1.0.1) per Joomla 3.8.x - DEMO Gestione Magazzino

Offline mirro

  • Esploratore
  • **
  • Post: 87
    • Mostra profilo
Re:Forzatura SSL non va
« Risposta #9 il: 12 Mag 2018, 22:04:40 »
Appunto, lo toglie mette quello giusto e risolve.


chiedo scusa ma non ho capito molto bene...
che sarebbe questo 303?
Devo quindi ricontrollare l'htaccess e cercare quale istruzione?
Chiedo scusa ma non sono un gran esperto.

Offline ramses_2th

  • Global Moderator
  • Instancabile
  • ********
  • Post: 4039
  • Sesso: Maschio
    • Mostra profilo
Re:Forzatura SSL non va
« Risposta #10 il: 12 Mag 2018, 22:41:13 »
Codice: [Seleziona]
RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

Questo nel .htacces

Offline mirro

  • Esploratore
  • **
  • Post: 87
    • Mostra profilo
Re:Forzatura SSL non va
« Risposta #11 il: 12 Mag 2018, 22:46:26 »
Avevo gi tentato anche quello, mi va in loop esattamente come quando abilito la funzione da backend. Ho dovuto commentare le righe.
Posso copiarvi quanto c' nel mio file?

Offline danielecr

  • Abituale
  • ****
  • Post: 966
    • Mostra profilo
Re:Forzatura SSL non va
« Risposta #12 il: 12 Mag 2018, 23:08:00 »
Per forza ti va in loop, se leggi sopra quello che ho scritto hai gi un redirect 303 da https a http.
Toglilo e metti l'istruzione corretta.
Ora dove sia questa istruzione noi non lo sappiamo, puoessere nell'htaccess, o un'estensione o un'impostazione nel tuo pannello hosting.

Offline mirro

  • Esploratore
  • **
  • Post: 87
    • Mostra profilo
Re:Forzatura SSL non va
« Risposta #13 il: 12 Mag 2018, 23:19:21 »
Per forza ti va in loop, se leggi sopra quello che ho scritto hai gi un redirect 303 da https a http.
Toglilo e metti l'istruzione corretta.
Ora dove sia questa istruzione noi non lo sappiamo, puoessere nell'htaccess, o un'estensione o un'impostazione nel tuo pannello hosting.


Il pannello di hosting ha praticamente solo uno switch (non credo di poter nominare il provider nel forum, ma comunque un provider idoneo a tutti i CMS abbastanza conosciuto), lo uso regolarmente per un altro sito e non d problemi con https.. Il provider ha fatto tutte le verifiche del caso e ha concluso che il problema  deve stare nel template oppure in una estensione... Il problema individuare questa estensione, visto che il template non puo' essere (anche selezionando quello di default il problema rimasto).
Ho provato a disabilitare uno ad uno ogni plugin, ma nulla... Non c' qualche plugin che possa fare una sorta di diagnosi sul problema?


Offline mirro

  • Esploratore
  • **
  • Post: 87
    • Mostra profilo
Re:[RISOLTO] Forzatura SSL non va
« Risposta #14 il: 13 Mag 2018, 13:53:58 »
Ragazzi ce l'ho fatta....
Non mi ero assolutamente accorto che uno dei tanti plugin che installa un noto componente di e-commerce va proprio a fare un redirect su TUTTE LE PAGINE CHE NON SONO IL CARRELLO... Si chiama infatti "no ssl outside checkout plugin"!
Ho letto che normalmente disabilitato, ma io l'ho trovato abilitato...
Ma che senso ha un plugin del genere??? Mah...


In ogni modo grazie a tutti per l'aiuto!

 

Torna su