Autore Topic: RISOLTO aggiornamento da 3.8.5 a 3.8.8 fallito  (Letto 433 volte)

Offline Sonia Becco

  • Nuovo arrivato
  • *
  • Post: 15
    • Mostra profilo
RISOLTO aggiornamento da 3.8.5 a 3.8.8 fallito
« il: 26 Mag 2018, 17:18:45 »
Ciao a tutti, ho aggiornato il mio sito dalla versione 3.8.5 a 3.8.8 durante l'installazione nessun messaggio di errore (report su massimo). Ho aggiornato anche le estensioni fin qui tutto ok. Rimetto on line il sito e c' solo una pagina bianca. Rimetto il report di errori su massimo ed esce fuori questo messaggio. Sapete dirmi come risolvere. Non sono molto esperta, ma fino adesso seguendo tutte le istruzioni per aggiornare in sicurezza non ho mai avuto problema.
Versione php 7.0 Sono stata al telefono con aruba che mi ha fatto aprire un ticket di assistenza ma vorrei capire se posso rimediare e come.


Grazie per l'aiuto




Warning: require_once(/web/htdocs/www.corsicretella.it/home/libraries/joomla/document/html/renderer/head.php): failed to open stream: No such file or directory in /web/htdocs/www.corsicretella.it/home/templates/jl_finance_free/error.php on line 42Fatal error: require_once(): Failed opening required '/web/htdocs/www.corsicretella.it/home/libraries/joomla/document/html/renderer/head.php' (include_path='.:/php7.0/lib/php') in /web/htdocs/www.corsicretella.it/home/templates/jl_finance_free/error.php on line 42
« Ultima modifica: 26 Mag 2018, 22:56:01 da Sonia Becco »

Offline Alex21

  • Appassionato
  • ***
  • Post: 608
    • Mostra profilo
    • servizi web
Re:aggiornamento da 3.8.5 a 3.8.8 fallito
« Risposta #1 il: 26 Mag 2018, 19:28:27 »
Salvo errori, in joomla ultima versione, la tua, il percorso /libraries/joomla/document/html/renderer/head.php  non c'.
Cercando un po' a caso nelle precedenti versioni, l'ho trovato in joomla 3.0.2. Non ho controllato in quale versione stato dismesso.
Penso che ci sia un problema di aggiornamento del template che usi.
Ciao!

Offline Sonia Becco

  • Nuovo arrivato
  • *
  • Post: 15
    • Mostra profilo
Re:aggiornamento da 3.8.5 a 3.8.8 fallito
« Risposta #2 il: 26 Mag 2018, 19:33:24 »
Perdona l'ignoranza, ma avendo funzionato tutto bene fino alla 3.8.5 come posso risolvere il problema del template?

Offline Alex21

  • Appassionato
  • ***
  • Post: 608
    • Mostra profilo
    • servizi web
Re:aggiornamento da 3.8.5 a 3.8.8 fallito
« Risposta #3 il: 26 Mag 2018, 19:51:01 »
Beh, una cosa da fare per tentativi, temo. Dubito che ci sia una sola soluzione per questi errori. Supponendo che l'errore sia nel template, puoi cambiare il template (con uno recente) e con un po' di fortuna funziona tutto al primo colpo. Altrimenti credo sia meglio ripristinare un backup, trasportare il sito in locale o su un server di prova se il sito grande ed esaminare l'aggiornamento che viene fatto, un pezzettino per volta.
Ti ci vorr un po' di tempo.
Ricordati di scaricare subito l'ultimo backup, file + database perch aruba fa i backup in automatico e non sarebbe bene che venisse sovrascritto l'ultimo che stato fatto.
Ciao!

Offline Sonia Becco

  • Nuovo arrivato
  • *
  • Post: 15
    • Mostra profilo
Re:aggiornamento da 3.8.5 a 3.8.8 fallito
« Risposta #4 il: 26 Mag 2018, 20:05:41 »
Intanto grazie per le risposte ... di cuore.


Credimi non voglio fare la strappalacrime, ma sono davvero nei guai non essendo esperta.


Ho fatto prima dell'aggiornamento una copia di backup con akeeba.
Il template finance che installato questo http://www.joomla.it/template/8475-jl-finance-free-j3x-installation-1-0-1.html
La versione 1.0.1
Ora verificando il sito del produttore vedo che la versione attuale 1.0.6. scaricabile qui https://joomlead.com/joomla-template/finance/


Ora mi chiedo (da ignorante eh) se aggiorno joomla, il template deve essere periodicamente aggiornato? e se si, perdo tutte le modifiche che su di esso ho fatto? (colori, frame, moduli ecc?)


Potrebbe essere una soluzione ripristinare (non so ancora come) il backup di akeeba, ma poi non dovrei pi aggiornare joomla per non incorrere nuovamente nello stesso problema?


Grazie tante
« Ultima modifica: 26 Mag 2018, 20:12:10 da Sonia Becco »

Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 28930
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
    • Xataface Italia
Re:aggiornamento da 3.8.5 a 3.8.8 fallito
« Risposta #5 il: 26 Mag 2018, 20:15:03 »
Cerca nel file error.php nella cartella del template in uso e commenta la linea ove richiama quel file.
NEWS DataGrill Xataface Installer (Ver. 1.0.1) per Joomla 3.8.x - DEMO Gestione Magazzino

Offline Sonia Becco

  • Nuovo arrivato
  • *
  • Post: 15
    • Mostra profilo
Re:aggiornamento da 3.8.5 a 3.8.8 fallito
« Risposta #6 il: 26 Mag 2018, 20:22:53 »
questo quello che compare alla riga 42. Grazie


require_once(JPATH_LIBRARIES.'/joomla/document/html/renderer/head.php');

Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 28930
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
    • Xataface Italia
Re:aggiornamento da 3.8.5 a 3.8.8 fallito
« Risposta #7 il: 26 Mag 2018, 20:48:53 »
Commenta questa linea e se hai risolto, cortesemente aggiungi il risolto al titolo del primo post.
NEWS DataGrill Xataface Installer (Ver. 1.0.1) per Joomla 3.8.x - DEMO Gestione Magazzino

Offline Sonia Becco

  • Nuovo arrivato
  • *
  • Post: 15
    • Mostra profilo
Re:aggiornamento da 3.8.5 a 3.8.8 fallito
« Risposta #8 il: 26 Mag 2018, 20:53:38 »
Commenta questa linea e se hai risolto, cortesemente aggiungi il risolto al titolo del primo post.


Io ti chiedo venia... ma cosa vuol dire commenta questa linea? non sono espertissima ti chiedo scusa, potresti essere pi chiaro?

EDIT ho cercato cosa vuol dire commentare <!--require_once(JPATH_LIBRARIES.'/joomla/document/html/renderer/head.php');-->

non ho risolto per (spero di aver fatto bene) mi esce questo messaggio
Error: syntax error, unexpected '<', expecting end of file: Using $this when not in object context

« Ultima modifica: 26 Mag 2018, 21:29:22 da Sonia Becco »

Offline petitpier

  • Appassionato
  • ***
  • Post: 221
  • Sesso: Maschio
    • Mostra profilo
    • Casa Vacanze
Re:aggiornamento da 3.8.5 a 3.8.8 fallito
« Risposta #9 il: 26 Mag 2018, 21:12:01 »
Sonia, io ho avuto lo steso problema: dalla versione 3.8.7 sono passato alla successiva 3.8.8 non ho avuto messaggi di errore filato tutto liscio quando per ho visto il sito non esisteva pi mi si presentava una pagina bianca e basta senza errori. ho risolto in questo modo: tramite ftp sono entrato nella cartella dei moduli e ho eliminato il file mod_random_images.php e tutto   ritornato come prima.
In caso di vacanza CASA 'NTONI il Salento a portata di mano
www.casantoni.com

Offline Sonia Becco

  • Nuovo arrivato
  • *
  • Post: 15
    • Mostra profilo
Re:aggiornamento da 3.8.5 a 3.8.8 fallito
« Risposta #10 il: 26 Mag 2018, 21:13:35 »
ti ringrazio per la risposta, ma credo siano due problematiche differenti. Questa nn legata ad un modulo, ma al template...


Warning[/font][/color][/size]: require_once(/web/htdocs/www.corsicretella.it/home/libraries/joomla/document/html/renderer/head.php): failed to open stream: No such file or directory in [/size]/web/htdocs/www.corsicretella.it/home/templates/jl_finance_free/error.php[/size] on line [/size]42[/size]Fatal error: require_once(): Failed opening required '/web/htdocs/www.corsicretella.it/home/libraries/joomla/document/html/renderer/head.php' (include_path='.:/php7.0/lib/php') in /web/htdocs/www.corsicretella.it/home/templates/jl_finance_free/error.php on line 42

Offline petitpier

  • Appassionato
  • ***
  • Post: 221
  • Sesso: Maschio
    • Mostra profilo
    • Casa Vacanze
Re:aggiornamento da 3.8.5 a 3.8.8 fallito
« Risposta #11 il: 26 Mag 2018, 21:21:03 »
Ho visto il tuo templates non credo avesse bisogno di aggiornamenti. Visita questo post http://forum.joomla.it/index.php/topic,268637.0.html e prova ad eliminare il modulo (fanne una copia prima) se non funziona lo ricarichi.
In caso di vacanza CASA 'NTONI il Salento a portata di mano
www.casantoni.com

Offline Sonia Becco

  • Nuovo arrivato
  • *
  • Post: 15
    • Mostra profilo
Re:aggiornamento da 3.8.5 a 3.8.8 fallito
« Risposta #12 il: 26 Mag 2018, 21:59:36 »
il sito off line per questo si visualizza la pagina di cortesia... ma non riesco a risolvere sta storia...

Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 28930
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
    • Xataface Italia
Re:aggiornamento da 3.8.5 a 3.8.8 fallito
« Risposta #13 il: 26 Mag 2018, 22:47:10 »
Metti // davanti alla linea da commentare.
NEWS DataGrill Xataface Installer (Ver. 1.0.1) per Joomla 3.8.x - DEMO Gestione Magazzino

Offline Sonia Becco

  • Nuovo arrivato
  • *
  • Post: 15
    • Mostra profilo
RISOLTO aggiornamento da 3.8.5 a 3.8.8 fallito
« Risposta #14 il: 26 Mag 2018, 22:50:13 »
Ragazzi seguendo i vostri consigli, ho letto tutte le discussioni che riguardavano il problema con modulo immagini casuali.


Sono riuscita a risolvere quasi completamente il problema seguendo questa discussione presente nel forum http://forum.joomla.it/index.php/topic,268653.0.html


Grazie a tutti

E' rimasto un unico piccolo problema che sotto al modulo "immagini casuali del mio sito www.corsicretella.it compare una stringa di codice visibile sotto le immagini. Posso risolvere o devo attendere il prox aggiornamento?


Grazie


Il problema descritto causato dal modulo "Immagini casuali"Per risolverlo, in attesa di un nuovo update di Joomla che comprenda il "fix", occorre aprire questo file:modules\mod_random_image\tmpl\default.phpe sostituire l'intera riga 16 con questa nuova riga:<?php echo JHtml::_('image', $image->folder . '/' . htmlspecialchars($image->name, ENT_COMPAT, 'UTF-8'), htmlspecialchars($image->name, ENT_COMPAT, 'UTF-8'), array('width' => $image->width, 'height' => $image->height)); ?>

 

Torna su