Autore Topic: GDPR ,dare la possibilitÓ agli iscritti al sito di vedere i loro dati, come fare  (Letto 716 volte)

Offline giovannidipierno

  • Nuovo arrivato
  • *
  • Post: 46
    • Mostra profilo
Salve a tutti,

credo che siamo tutti presi dal GDPR e che si stanno cercando le soluzioni per poter mettere in regola anche i siti che sono datati come quello a cui lavoro io (vers. 2.5).

Tra le varie cose ho la necessitÓ di dare la possibilitÓ agli iscritti al sito di poter loggarsi (e questo Ŕ giÓ possibile) e di accedere alla loro scheda personale dove possono vedere, cambiare o cancellare i loro dati. Attualmente gli iscritti (che non amministrano) hanno la possibilitÓ di accedere all'area download. Come posso fare affinchÚ loro abbiano la possibilitÓ di loggarsi e cambiare i dati?

Inoltre per gli utenti iscritti e che hanno compilato il modulo d'iscrizione dove trovo il registro di queste iscrizioni?

Grazie in anticipo a chi vorrÓ darmi una mano.


Offline danielecr

  • Abituale
  • ****
  • Post: 929
    • Mostra profilo
Ciao,
sembrerÓ una risposta banale e di poco aiuto, ma, o trovi un'estensione per joomla 2.5 che ti aiuti, sempre che esista, o aggiorni a joomla 3 e trovi un estensione che ti aiuti (qui estensioni che fanno quello che chiedi esistono, cerca nel forum le discussioni a riguardo del GDPR), o ti armi di buona volontÓ e ti crei tu un'estensione o personalizzi il codice.

Offline giovannidipierno

  • Nuovo arrivato
  • *
  • Post: 46
    • Mostra profilo
Sicuramente devo trovare un'estensione che mi aiuti, ma non ho idea di come possa chiamarsi e quale possa essere e per questo ho chiesto a chi ha + esperienza di me.

Per la migrazione alla versione 3 di Joomla non credo sia fattibile (ho chiesto a un programmatore esperto di Joomla) per cui dovr˛ accontentarmi di quello che trovo per la versione 2.5.7

Hai qualche info sui registri d'iscrizione? Le iscrizioni precedenti sono archiviate da qualche parte? 

Offline druskus

  • Esploratore
  • **
  • Post: 109
  • Sesso: Maschio
  • www.imperoweb.it Community Builder Italia
    • Mostra profilo
    • Impero Web
Che estensioni utilizzi nel sito? Usi Community Builder?
Impero Web-Community Builder Italia http://communitybuilders.it Sito di Supporto per il Componente Community Builder

Offline druskus

  • Esploratore
  • **
  • Post: 109
  • Sesso: Maschio
  • www.imperoweb.it Community Builder Italia
    • Mostra profilo
    • Impero Web
Trovo strana la cosa della migrazione...
Impero Web-Community Builder Italia http://communitybuilders.it Sito di Supporto per il Componente Community Builder

Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 29145
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
    • Xataface Italia
Una raccomandazione fondamentale della GDPR riguarda la sicurezza dei dati. Come pensi di stare in regola se giÓ parti da una versione obsoleta ma soprattutto non sicura?
NEWS DataGrill Xataface Installer (Ver. 1.0.1) per Joomla 3.8.x - DEMO Gestione Magazzino

Offline giovannidipierno

  • Nuovo arrivato
  • *
  • Post: 46
    • Mostra profilo
Su questo sito (non realizzato da me, io mi occupo di tenerlo aggiornato) non c'Ŕ l'estensione che nomini. Ho subito cercato info su questa estensione e ho letto un interessante articolo. Devo solo capire se Ŕ compatibile con la versione che ho di Joomla e se con questa estensione ho la possibilitÓ di caricare gli utenti giÓ iscritti e dargli la possibilitÓ di gestire i loro dati.

Se hai modo di dai indicazioni in merito.

Offline giovannidipierno

  • Nuovo arrivato
  • *
  • Post: 46
    • Mostra profilo
Una raccomandazione fondamentale della GDPR riguarda la sicurezza dei dati. Come pensi di stare in regola se giÓ parti da una versione obsoleta ma soprattutto non sicura?
come darti torto ... stiamo lavorando per impostare il sito nuovo ma ci vorranno dei mesi di lavoro poichŔ Ŕ grande. Per cui cerco il modo di mettere al "pezza allo strappo"

Offline danielecr

  • Abituale
  • ****
  • Post: 929
    • Mostra profilo
La maggior parte delle estensioni che vanno per la maggiore (e forse le uniche?) che aiutano con il gdpr non sono compatibili con j 2.5.

JA GDPR solo joomla 3
GDPR Bundle solo joomla 3
pixGDPR solo joomla 3

GDPR 1.4 compatibile anche con 2.5
« Ultima modifica: 29 Mag 2018, 18:20:46 da danielecr »

Offline adottauncane

  • Team Joomla.it
  • Fuori controllo
  • *******
  • Post: 18070
  • Sesso: Femmina
    • Mostra profilo
    • Adotta un cane
Questa (per˛ a pagamento) ha anche la versione per la 2.5 https://extensions.joomla.org/extension/gdpr/

Offline danielecr

  • Abituale
  • ****
  • Post: 929
    • Mostra profilo
urca hai ragione adottauncane, mi son fermato a "compatibility 3", ma nelle caratteristiche estese riporta compatibile con 2.5.28 (raccomandato)

Offline druskus

  • Esploratore
  • **
  • Post: 109
  • Sesso: Maschio
  • www.imperoweb.it Community Builder Italia
    • Mostra profilo
    • Impero Web
prima di migrare alla 3 assicurati che tutte le estensioni, moduli e plugin siano aggiornati e pronti per migrare a Joomla 3, compreso il template, sarebbe possibile vedere il sito?
Impero Web-Community Builder Italia http://communitybuilders.it Sito di Supporto per il Componente Community Builder

Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 29145
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
    • Xataface Italia
Pagare per un estensione per mettere in regola una 2.5 Ŕ proprio come  buttare i soldi, come ho detto prima non si Ŕ mai a norma per la GDPR se prima non si considera l'aspetto sicurezza.
NEWS DataGrill Xataface Installer (Ver. 1.0.1) per Joomla 3.8.x - DEMO Gestione Magazzino

Offline druskus

  • Esploratore
  • **
  • Post: 109
  • Sesso: Maschio
  • www.imperoweb.it Community Builder Italia
    • Mostra profilo
    • Impero Web
Concorde, ma cerchiamo di aiutarlo e trovare una soluzione cosa che cerchiamo di fare  ;)
Impero Web-Community Builder Italia http://communitybuilders.it Sito di Supporto per il Componente Community Builder

Offline giusebos

  • Fuori controllo
  • *
  • Post: 19557
  • Sesso: Maschio
  • Giuseppe Serbelloni Mazzanti Viendalmare
    • Mostra profilo
    • Demo iCagenda
Concorde, ma cerchiamo di aiutarlo e trovare una soluzione cosa che cerchiamo di fare  ;)

Scusa che soluzione vuoi proporre per chi usa una versione di joomla non pi¨ supportata qualche anno?

la legge stessa mette in primo piano la sicurezza del sito/software, cosa che usando una vecchia versione non puoi dare.
Anche se qualcuno realizzasse un estensione per la 2.5, come la metti con le estensioni e la versione di joomla, come farai a dichiarare che Ŕ tutto supersicuro......forse all'italiana dichiarando cazzate?

Quindi quello che scrivi non ha assolutamente senso.
su www.icagenda.it guide e tutorial con esempi di chronoforms e chronoconnectivity

Offline druskus

  • Esploratore
  • **
  • Post: 109
  • Sesso: Maschio
  • www.imperoweb.it Community Builder Italia
    • Mostra profilo
    • Impero Web
Mi spiace per te carissimo, se ci sono soluzioni le si offrono cercando di aiutare al meglio anche nel passaggio da una versione all'altra di Joomla cosa che vorrei fare, prima di dare giudizi e sparare a vanvera qua e la i sorrisetti nel forum giusto per far numero, come ti hanno anche fatto notare in un'altro post, ho detto per caso rimaniamo alla versione di Joomla attuale? Sto tentando di aiutare e quindi tu fa il tuo ed io faccio il mio al meglio come sappiamo fare. GRAZIE
Impero Web-Community Builder Italia http://communitybuilders.it Sito di Supporto per il Componente Community Builder

Offline giusebos

  • Fuori controllo
  • *
  • Post: 19557
  • Sesso: Maschio
  • Giuseppe Serbelloni Mazzanti Viendalmare
    • Mostra profilo
    • Demo iCagenda
Mi spiace per te carissimo, se ci sono soluzioni le si offrono cercando di aiutare al meglio anche nel passaggio da una versione all'altra di Joomla cosa che vorrei fare, prima di dare giudizi e sparare a vanvera qua e la i sorrisetti nel forum giusto per far numero, come ti hanno anche fatto notare in un'altro post, ho detto per caso rimaniamo alla versione di Joomla attuale? Sto tentando di aiutare e quindi tu fa il tuo ed io faccio il mio al meglio come sappiamo fare. GRAZIE
Ti faccio i miei migliori auguri, poi quando trovi una soluzione per mettere in sicurezza joomla 2.5 e sistemarlo per il GDPR  fammi un fischio che ci scrivo un articolo. ;) ;)
su www.icagenda.it guide e tutorial con esempi di chronoforms e chronoconnectivity

Offline druskus

  • Esploratore
  • **
  • Post: 109
  • Sesso: Maschio
  • www.imperoweb.it Community Builder Italia
    • Mostra profilo
    • Impero Web
Ribadisco che non ho detto quello che tu asserisci. Se fai riferimento al "trovo strana la storia della migrazione" era in riferimento a quanto riportato sopra da giovanni.


Comunque per continuare la discussione ci sarÓ come postato anche come articolo la versione 3.9 di Joomla incentrata sul GDPR.
Impero Web-Community Builder Italia http://communitybuilders.it Sito di Supporto per il Componente Community Builder

Offline giovannidipierno

  • Nuovo arrivato
  • *
  • Post: 46
    • Mostra profilo
urca hai ragione adottauncane, mi son fermato a "compatibility 3", ma nelle caratteristiche estese riporta compatibile con 2.5.28 (raccomandato)


Ti ringrazio molto per l'aiuto che mi stai dando, mi rendo conto che Ŕ una "missione impossibile" visto che si tratta di una versione molto vecchia di Joomla. Vedo subito link che mi hai segnalato. GRAZIE

 

Torna su