Autore Topic: Fallisce Aggiornamento dietro Proxy  (Letto 565 volte)

Offline Elmste

  • Nuovo arrivato
  • *
  • Post: 9
    • Mostra profilo
Fallisce Aggiornamento dietro Proxy
« il: 30 Mag 2018, 11:41:16 »
Salve,
vediamo se su questo problema, qualcuno riesce a rispondermi. Ho aggiornato Joomla dalla 3.3.6 alla 3.8.8 e l'ho fatto tutto a "mano". Ho fatto tutto a mano, anche perch, mi va in errore l'aggiornamento automatico.
Cercando molto su Internet ho capito che la causa il fatto che il nostro Joomla, per "uscire", utilizza un proxy e la url di ricerca in https.
Ora, io sono un profano, ho letto molto ma c'ho capito poco ma non mi sembra di aver letto qualche soluzione possibile, o meglio, magari l'ho letto ma non sono riuscito a coglierla. Noi abbiamo altre applicazioni che per i loro update escono su internet utilizzando lo stesso proxy e comunque funzionano.
Qualcuno ha qualcosa da suggerirmi per risolvere il problema ??
Grazie.




Buona giornata

Offline marine

  • Moderator
  • Instancabile
  • *****
  • Post: 4377
  • Sesso: Maschio
    • Mostra profilo
Re:Fallisce Aggiornamento dietro Proxy
« Risposta #1 il: 30 Mag 2018, 11:51:49 »
Ripristina un backup pre aggiornamento e rifai l'aggiornamento dall'unica via possibile che l'aggiornamento tramite pannello di controllo.Se l'aggiornamento da pannello di controllo non funziona, la motivazione al 99% perch joomla non installato in uno spazio idoneo.

Offline Elmste

  • Nuovo arrivato
  • *
  • Post: 9
    • Mostra profilo
Re:Fallisce Aggiornamento dietro Proxy
« Risposta #2 il: 30 Mag 2018, 12:17:45 »
Scusate,


sono stato poco chiaro. L'aggiornamento manuale andato a buon fine e ho dovuto fare l'aggiornamento manuale perch quello automatico andava in errore. Anche ora, che comunque aggiornato e funziona il tutto, se lancio il check per gli aggiornamenti, mi esce l'errore:


Warning
Update: Could not open update site #14 "Joomla! Update Component Update Site", URL: https://update.joomla.org/core/extensions/com_joomlaupdate.xml


che l'errore che mi ha obbligato a fare gli aggiornamenti manuali, per mi piacerebbe che funzionasse anche l'automatico, anche per sfruttare gli avvisi che manda per avvertire di una nuova versione. Con il fatto che non riesce a contattare in modo corretto il sito di Joomla, non riesce a capire se c', o meno, una nuova versione.


Saluti

Online tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 29304
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
    • Xataface Italia
Re:Fallisce Aggiornamento dietro Proxy
« Risposta #3 il: 30 Mag 2018, 13:23:55 »
Scusa puoi descrivere come hai aggiornato manualmente?
NEWS DataGrill Xataface Installer (Ver. 1.0.1) per Joomla 3.8.x - DEMO Gestione Magazzino

Offline Elmste

  • Nuovo arrivato
  • *
  • Post: 9
    • Mostra profilo
Re:Fallisce Aggiornamento dietro Proxy
« Risposta #4 il: 30 Mag 2018, 13:41:57 »



Dalla 3.3.6 alla 3.6.5, mi sembra, ho proprio copiato brutalmente i file e poi aggiustato il DB tramite il pannello di Joomla. Da quella versione in poi, comparso il tab con cui si pu caricare lo zip dell'update e l'ho utilizzato per portarlo all'ultima versione.
Comunque, da quello che vedo, un problema generalizzato, nel senso, abbiamo una nuova installazione di Joomla fatta qualche tempo fa, la versione 3.8.1, e anche questa ha configurato il proxy per uscire su internet. Se faccio il check per vedere se ci sono nuove versioni, tab "Live Update", mi esce l'errore che ho postato prima.
Continuando a cercare, sembra che sia dovuto al comando curl che Joomla utilizza per cercare, ed eventualmente scaricare, gli aggiornamenti. Il problema che non riesco a trovare una soluzione per aggirare l'ostacolo e, per policy interne sulla sicurezza, non mi pubblicano direttamente il server che ospita Joomla !!




Ciao

Online tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 29304
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
    • Xataface Italia
Re:Fallisce Aggiornamento dietro Proxy
« Risposta #5 il: 30 Mag 2018, 14:39:16 »
E una procedura rischiosa e pu causare malfunzionamenti, non sempre riesci ad aggiustare anche il db e sicuramente non cancelli file non pi necessari
NEWS DataGrill Xataface Installer (Ver. 1.0.1) per Joomla 3.8.x - DEMO Gestione Magazzino

Offline Elmste

  • Nuovo arrivato
  • *
  • Post: 9
    • Mostra profilo
Re:Fallisce Aggiornamento dietro Proxy
« Risposta #6 il: 30 Mag 2018, 15:13:19 »
Ma l'aggiornamento andato bene, il problema che mi piacerebbe risolvere :


Warning[/size]Update: Could not open update site #14 "Joomla! Update Component Update Site", URL: https://update.joomla.org/core/extensions/com_joomlaupdate.xml



che si presenta anche da installazione nuova. Il problema che Joomla per andare su internet, deve utilizzare il proxy e sembra che il comando curl che Joomla utilizza, non riesce a getirlo soprattutto se la connessione in HTTPS.
Vorrei poterlo risolvere.




Saluti
[/color]

Online tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 29304
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
    • Xataface Italia
Re:Fallisce Aggiornamento dietro Proxy
« Risposta #7 il: 30 Mag 2018, 16:11:44 »
Curl per poter funzionare deve essere attivato sul server. Non c'entrano le impostazioni di joomla.

Anche se funziona non significa che va tutto bene e sia tutto a posto, prova ad attivare la visualizzazione degli errori.
NEWS DataGrill Xataface Installer (Ver. 1.0.1) per Joomla 3.8.x - DEMO Gestione Magazzino

Offline Elmste

  • Nuovo arrivato
  • *
  • Post: 9
    • Mostra profilo
Re:Fallisce Aggiornamento dietro Proxy
« Risposta #8 il: 30 Mag 2018, 16:42:46 »
Allora,
forse ho fatto un po di confusione, cerco di essere pi chiaro.
Installazione pulita di Joomla, ver. 3.8.1.
Nel pannello amministrativo di Joomla, gli configuro il nostro proxy aziendale, per poter uscire su internet e verificare se ci sono aggiornamenti.
Per quello che mi hai detto sull'abilitare gli errori, sono abbastanza ignorante in merito ma comunque ho messo "Error Reporting" al "Maximum"
Sempre dal pannello amministrativo, clicco su "Checking extensions", dopo un che di attesa, esce la scritta:



Warning
Update: Could not open update site #1 "Joomla Core", URL: https://update.joomla.org/core/list.xml
Update: Could not open update site #14 "Joomla! Update Component Update Site", URL: https://update.joomla.org/core/extensions/com_joomlaupdate.xml


dai log di Joomla, non vedo nulla mentre dai log di apache vedo la riga:
[Wed May 30 16:39:24 2018] [warn] Proxy client certificate callback: (www.cooperativacapodarco.it:443) downstream server wanted client certificate but none are configured


Saluti




Offline Alex21

  • Appassionato
  • ***
  • Post: 644
    • Mostra profilo
    • servizi web
Re:Fallisce Aggiornamento dietro Proxy
« Risposta #9 il: 30 Mag 2018, 17:09:40 »
Ciao,
sembra un problema di configurazione server.
Prova a leggere questo articolo: https://serverfault.com/questions/412206/apache-ssl-proxy-cant-find-client-certificate


Credo che non riguardi joomla.
Quando troverai la soluzione, per cortesia postala.
Ciao!

Offline Elmste

  • Nuovo arrivato
  • *
  • Post: 9
    • Mostra profilo
Re:Fallisce Aggiornamento dietro Proxy
« Risposta #10 il: 31 Mag 2018, 15:29:05 »
Ciao,
grazie per il suggerimento, purtroppo il post che mi hai indicato non mi ha risolto la problematica.
Si, anche io penso che il problema non sia Joomla ma la configurazione architetturale che abbiamo nella nostra azienda ma non riesco a capirlo, almeno per ora !!
Se riesco a risolverlo, sar mia cura postare la soluzione.


Saluti

Offline Elmste

  • Nuovo arrivato
  • *
  • Post: 9
    • Mostra profilo
Re:Fallisce Aggiornamento dietro Proxy
« Risposta #11 il: 12 Giu 2018, 13:53:43 »

Ciao a tutti,


ho, in qualche modo, risolto anche se non sono riuscito a trovare la vera causa del problema e purtroppo, non ho il tempo e ne le competenze per trovarlo.
Sono comunque arrivato alla conclusione che dovrebbe essere la versione del PHP o l'accoppiata versione PHP + versione SO, cerco di spiegarmi.
Ho "sdoppiato" il sito che dovevo aggiornare ed ho "sdoppiato" anche il DB e quindi sono partito da una situazione cui avevo gli stessi file del sito, con la versione di Joomla 3.3.6, lo stesso DB ma uno su di un server con SO CentOS 6 e PHP 5.6 e l'altro su di un server CentOS 7 e PHP 7.1, entrambi "escono" su internet utilizzando lo stesso proxy.
Partendo da qui, ho iniziato ad aggiornare Joomla e una volta arrivato alla versione 3.7, sul sito che stava sul server CentOS 7 e PHP 7.1 non mi si presentava pi il problema in oggetto e sono riuscito ad aggiornare il tutto in automatico, utilizzando il proxy.
Quindi, per come la vedo io, al 90%, la problematica descritta in precedenza, legata alla versione del PHP e tenderei ad escludere la versione del SO.
Spero che possa essere utile a qualcuno anche se mi dispiace non essere riuscito a trovare la "vera" fonte del problema.




Saluti


 

Torna su