Autore Topic: EU e-Privacy Directive e liquidità del sito.  (Letto 364 volte)

Offline Mozartino

  • Appassionato
  • ***
  • Post: 361
    • Mostra profilo
EU e-Privacy Directive e liquidità del sito.
« il: 31 Mag 2018, 09:00:07 »

Ho aggiornato il componente EU e-Privacy Directive Package 3.8.4 su template FAP 3.33.


Sembra funzionare tutto correttamente fino a quando accetto/rifiuto l'avviso privacy e riavvio il browser: il sito non si adatta al dispositivo e viene visualizzato interamente...


Chi può aiutarmi?
Grazie.

Offline matty80

  • Global Moderator
  • Instancabile
  • *****
  • Post: 3959
  • Sesso: Maschio
    • Mostra profilo
    • ASAO Calcio
Re:EU e-Privacy Directive e liquidità del sito.
« Risposta #1 il: 31 Mag 2018, 16:16:52 »
mozartino,
cosa vuol dire liquidità del sito?
Chi non ha mai posseduto un cane, non sa cosa significhi essere amato. Arthur Schopenhauer

Offline Mozartino

  • Appassionato
  • ***
  • Post: 361
    • Mostra profilo
Re:EU e-Privacy Directive e liquidità del sito.
« Risposta #2 il: 31 Mag 2018, 18:02:25 »
Ciao matty80.


Quando parlo di liquidità del sito mi riferisco alla capacità del template di adattarsi alla larghezza del browser utente.


Ti allego un paio di screenshot...
« Ultima modifica: 31 Mag 2018, 18:06:03 da Mozartino »

Online danielecr

  • Abituale
  • ****
  • Post: 966
    • Mostra profilo
Re:EU e-Privacy Directive e liquidità del sito.
« Risposta #3 il: 31 Mag 2018, 18:07:40 »
Utilizzo il componente e visto che sono costretto a modifiche all'estensione per farla funzionare sul mio hosting e quindi a comparare i files da una versione all:altra posso assicurarti che nulla é cambiato che possa generare il problema che descrivi: hai qualche prova che il problema sia di quell'estensione?
Credo che la causa vada cercata altrove.

Offline Mozartino

  • Appassionato
  • ***
  • Post: 361
    • Mostra profilo
Re:EU e-Privacy Directive e liquidità del sito.
« Risposta #4 il: 31 Mag 2018, 18:50:59 »
Ciao danielecr.


Penso che sia l'estensione a creare quel problema perché se la sospendo la visualizzazione del sito sui dispositivi risulta corretta.

Online danielecr

  • Abituale
  • ****
  • Post: 966
    • Mostra profilo
Re:EU e-Privacy Directive e liquidità del sito.
« Risposta #5 il: 31 Mag 2018, 19:04:40 »
È strano, prova a controllare i permessi acl sui vari moduli e controlla l'impostazione anche in eu eprivacy, una delle modifiche recenti riguarda la possibilità di settare un gruppo di utenti non solo per le estensioni da bloccare (com'era) ma anche per quelle una volta accettati i cookies.
Io avevo le estensioni da bloccare bloccate anche all'accettazione dei cookies perché il settaggio era stato impostato automaticamente con il gruppo "cookies" che era lo stesso gruppo assegnato per le estensioni da bloccare.

Offline druskus

  • Esploratore
  • **
  • Post: 167
  • Sesso: Maschio
  • www.imperoweb.it Community Builder Italia
    • Mostra profilo
    • Impero Web
Re:EU e-Privacy Directive e liquidità del sito.
« Risposta #6 il: 31 Mag 2018, 19:46:38 »
con l'estensione abilitata potresti premere F12 da tastiera e copiare l'errore che ti segnala? Per esser sicuro dell'errore segnalato verifica anche senza l'estensione abilitata.
Impero Web-Community Builder Italia http://communitybuilders.it Sito di Supporto per il Componente Community Builder

Offline Mozartino

  • Appassionato
  • ***
  • Post: 361
    • Mostra profilo
Re:EU e-Privacy Directive e liquidità del sito.
« Risposta #7 il: 02 Giu 2018, 12:27:20 »
Ciao druskus e grazie.


Se abilito il componente questi sono gli errori:



JQMIGRATE: Migrate is installed, version 1.4.1 jquery-migrate.min.js:2:542
TypeError: Joomla.optionsStorage is null eprivacy.class.min.js:16:398
TypeError: options is undefined eprivacy.class.min.js:3:67


Offline druskus

  • Esploratore
  • **
  • Post: 167
  • Sesso: Maschio
  • www.imperoweb.it Community Builder Italia
    • Mostra profilo
    • Impero Web
Re:EU e-Privacy Directive e liquidità del sito.
« Risposta #8 il: 02 Giu 2018, 12:44:00 »
Potresti provare con il template di default di Joomla e vedere se hai lo stesso problema? Il Template in uso è aggiornato? Se con il template di default non hai problemi il problema non è dell'estensione, ma del template che va in conflitto con gli script del plugin.
Impero Web-Community Builder Italia http://communitybuilders.it Sito di Supporto per il Componente Community Builder

 

Torna su