Autore Topic: Errore 'JClassLoader not found' durante l'aggiornamento da 3.8.8 a 3.8.9  (Letto 432 volte)

Offline Auron87

  • Nuovo arrivato
  • *
  • Post: 1
    • Mostra profilo
Ciao a tutti, spero di avere individuato la sezione giusta.
Da circa un annetto sviluppo siti con Joomla senza problemi di aggiornamento o altro. Oggi in uno di questi ho provato ad aggiornare Joomla dalla versione 3.8.8 a 3.8.9.
La progress bar arriva fino in fondo senza problemi di sorta, poi viene fuori una pagina bianca con questo messaggio:
Codice: [Seleziona]
Fatal error: Class 'JClassLoader' not found in C:\wamp64\www\(nome)\libraries\cms.php on line 40Il problema si verifica sia lato frontend che provando ad accedere al pannello di amministrazione.
Una breve ricerca ha portato alla luce un errore simile che però dovrebbe essere stato definitivamente risolto da una patch inclusa a partire da una versione precedente (quindi escludo un collegamento con il mio caso).
Ho provato un'installazione manuale di Joomla 3.8.9 ma nulla: stesso problema.
Al momento sono costretto a ripristinare la versione 3.8.8 con un backup di akeeba e kickstart.
Sviluppo in locale su Windows 10, uso Wamp (x64) con PHP 5.6.31 e Apache 2.4.27.
Qualche suggerimento?
Grazie per l'attenzione.

****************************
Edit: hanno rilasciato subito la versione 3.8.10. Coincidenza?
Vediamo come va, aggiornerò il post appena possibile.

****************************
Edit2: aggiornato con successo alla versione 3.8.10. Hanno fixato proprio quel singolo problema: ecco le note di rilascio.
Codice: [Seleziona]
What's in 3.8.10?
Joomla 3.8.10 is addressing one bug introduced into Joomla 3.8.9. This release is fixing the autoloader for Windows platforms.
If you are using a Windows platform, please update your site to 3.8.10 as soon as possible.
Grazie, si può chiudere!
« Ultima modifica: 26 Giu 2018, 19:11:45 da Auron87 »

 

Torna su