Autore Topic: Versione aggiornata PHP componente in errore  (Letto 668 volte)

Offline Alistair

  • Appassionato
  • ***
  • Post: 313
    • Mostra profilo
Versione aggiornata PHP componente in errore
« il: 03 Set 2018, 10:15:07 »
Joomla! mi da questo errore:


Warning: Your PHP version, 7.0.31, is only receiving security fixes at this time from the PHP project. This means your PHP version will soon no longer be supported. We recommend planning to upgrade to a newer PHP version before it reaches end of support on 2018-09-03. Joomla will be faster and more secure if you upgrade to a newer PHP version (PHP 7.x is recommended). Please contact your host for upgrade instructions.

Solo che aggiornando la versione PHP non mi funziona più il sito, ci deve essere un componente che non supporta la versione PHP 7.1 e 7.2, Joomla! però non mi segnala nessuna update necessaria, c'è un modo per trovare il componente in fallo? Grazie

Offline conti1

  • Global Moderator
  • Instancabile
  • ********
  • Post: 9018
  • Sesso: Maschio
    • Mostra profilo
Re:Versione aggiornata PHP componente in errore
« Risposta #1 il: 03 Set 2018, 10:43:02 »
ciaodisabilita i componenti o moduli uno ad uno  vedrai che lo trovi  non hai altro metodo che io sappia.
se possibile postare il link  x risolvere al meglio il problema grazie
evitare nomi commerciali grazie

Offline danielecr

  • Abituale
  • ****
  • Post: 1012
    • Mostra profilo
Re:Versione aggiornata PHP componente in errore
« Risposta #2 il: 03 Set 2018, 14:12:36 »
È molto strano, perché anche io ho la v. 7.0.31, ma il mio joomla non mi dà nessun avviso.A parte questo trovo molto strano che compaia quell'avviso per una versione 7.x.

Offline marine

  • Moderator
  • Instancabile
  • *****
  • Post: 4564
  • Sesso: Maschio
    • Mostra profilo
Re:Versione aggiornata PHP componente in errore
« Risposta #3 il: 03 Set 2018, 14:20:04 »
Succede anche ad un sito che ho accesso al backend, questo il messaggio:
Citazione
Attenzione La tua versione di PHP, 7.0.31-1+ubuntu16.04.1+deb.sury.org+1, sta ricevendo solo fix di sicurezza dal progetto PHP. Questo significa che la tua versione di PHP presto non sarà più supportata. Ti raccomandiamo di pianificare l'aggiornamento ad una versione di PHP più recente prima che raggiunga la fine del supporto il 03-09-2018. Joomla sarà più veloce e più sicuro se aggiorni ad una versione di PHP più recente (si raccomanda PHP 7.x). Contatta il tuo fornitore di hosting per le instruzioni su come aggiornare.

Offline marine

  • Moderator
  • Instancabile
  • *****
  • Post: 4564
  • Sesso: Maschio
    • Mostra profilo
Re:Versione aggiornata PHP componente in errore
« Risposta #4 il: 03 Set 2018, 14:58:58 »
C'è conferma anche dal sito php.net

http://php.net/supported-versions.php


Offline Alistair

  • Appassionato
  • ***
  • Post: 313
    • Mostra profilo
Re:Versione aggiornata PHP componente in errore
« Risposta #5 il: 03 Set 2018, 15:10:06 »
È molto strano, perché anche io ho la v. 7.0.31, ma il mio joomla non mi dà nessun avviso.A parte questo trovo molto strano che compaia quell'avviso per una versione 7.x.


Ho fatto l'upgrade del PHP alla 7.2 (e provato anche solo 7.1) ma il sito va in down. Ho sentito l'assistenza server e dicono che da loro test risulta ci sia un componente che non supporta le nuove versioni di PHP, è un componente (o modulo magari?) esterno, non c'entra Joomla! core.

Offline danielecr

  • Abituale
  • ****
  • Post: 1012
    • Mostra profilo
Re:Versione aggiornata PHP componente in errore
« Risposta #6 il: 03 Set 2018, 16:35:55 »
C'è conferma anche dal sito php.net

http://php.net/supported-versions.php


Grazie della info, chissà perché non mi esce l'avviso... :o

Offline Alistair

  • Appassionato
  • ***
  • Post: 313
    • Mostra profilo
Re:Versione aggiornata PHP componente in errore
« Risposta #7 il: 04 Set 2018, 10:39:28 »
Da un analisi del sito utilizzando l'error reporting (quindi senza disabilitare uno ad uno) mi dava l'Expires Headers come contenente qualcosa di obsoleto non compatibile con versione aggiornate di PHP. L'ho dunque disabilitato e tutto funziona. Voi come vi comportate con questo System - Expires Headers, ce l'avete? Serve a qualcosa?
« Ultima modifica: 04 Set 2018, 11:18:53 da Alistair »

Offline conti1

  • Global Moderator
  • Instancabile
  • ********
  • Post: 9018
  • Sesso: Maschio
    • Mostra profilo
Re:Versione aggiornata PHP componente in errore
« Risposta #8 il: 04 Set 2018, 11:15:39 »
ciao non  deve essere per forza nativo in joomla  sono propio i moduli o componetti  di terze parti a dare problemi , disabilitalo e vedi se il problema si risove  se si cerca se c'è un aggiornamento
se possibile postare il link  x risolvere al meglio il problema grazie
evitare nomi commerciali grazie

Offline Alistair

  • Appassionato
  • ***
  • Post: 313
    • Mostra profilo
Re:Versione aggiornata PHP componente in errore
« Risposta #9 il: 04 Set 2018, 11:20:20 »
Scusa ho modificato post mentre scrivevi, ok disabilitato e funziona.

Offline miao

  • Appassionato
  • ***
  • Post: 546
    • Mostra profilo
Re:Versione aggiornata PHP componente in errore
« Risposta #10 il: 04 Set 2018, 11:41:38 »
Io non ho lo
e visto che di di comp esterni ne ho proprio pochi
non è di joomla core
ciao

Offline Mozartino

  • Appassionato
  • ***
  • Post: 361
    • Mostra profilo
Re:Versione aggiornata PHP componente in errore
« Risposta #11 il: 06 Set 2018, 07:48:01 »
Salve a tutti.


Anche io ho avuto un problema simile.


Ho verificato l'errore e nel mio caso era: The apc Cache Storage is not supported on this platform

Ho risolto andando in Configurazione globale-->Sistema e cambiando il parametro Gestore cache da APC a File.

Aggiornato a Php 7.1 e sito online.

Buona giornata.

Offline zimos

  • Appassionato
  • ***
  • Post: 449
    • Mostra profilo
Re:Versione aggiornata PHP componente in errore
« Risposta #12 il: 09 Set 2018, 09:16:48 »
×Attenzione
Your PHP version, 7.0.31, is only receiving security fixes at this time from the PHP project. This means your PHP version will soon no longer be supported. We recommend planning to upgrade to a newer PHP version before it reaches end of support on 2018-09-03. Joomla will be faster and more secure if you upgrade to a newer PHP version (PHP 7.x is recommended). Please contact your host for upgrade instructions.
Anche io ricevo il messaggio di cui sopra..(credo dopo update a 3.8.12) ed avevo la cache impostata gia su FILE.  Non so..
« Ultima modifica: 09 Set 2018, 09:18:38 da zimos »

Offline marine

  • Moderator
  • Instancabile
  • *****
  • Post: 4564
  • Sesso: Maschio
    • Mostra profilo
Re:Versione aggiornata PHP componente in errore
« Risposta #13 il: 09 Set 2018, 10:47:13 »

Anche io ricevo il messaggio di cui sopra..(credo dopo update a 3.8.12) ed avevo la cache impostata gia su FILE.  Non so..

Quindi? cosa non sai?
E' un semplice avviso che la versione di php non riceve aggiornamenti, che centra la cache su file?

Offline danielecr

  • Abituale
  • ****
  • Post: 1012
    • Mostra profilo
Re:Versione aggiornata PHP componente in errore
« Risposta #14 il: 09 Set 2018, 11:26:21 »
Salve a tutti.


Anche io ho avuto un problema simile.


Ho verificato l'errore e nel mio caso era: The apc Cache Storage is not supported on this platform

Ho risolto andando in Configurazione globale-->Sistema e cambiando il parametro Gestore cache da APC a File.

Aggiornato a Php 7.1 e sito online.

Buona giornata.
Infatti questo messaggio non centra proprio niente con l'oggetto della discussione.

 

Torna su