Autore Topic: Rendere Joomla! completamente UTF-8 e risolvere il problema delle accentate  (Letto 58857 volte)

Offline sali40

  • Global Moderator
  • Instancabile
  • ********
  • Post: 4791
  • Sesso: Maschio
    • Mostra profilo
Si leggono spesso problemi relativi alle lettere accentate.
Ho preparato questa guida per provare a risolvere in modo definitivo la questione del sito multilingua, della codifica utf-8 e dei caratteri strani che si possono presentare.

Si ricorda di fare qualche backup, prima di cominciare (ma questo "mi pare" di averlo evidenziato a dovere, nella guida  8) )


EDIT: Oggi sostituisco il pdf. C'era una imprecisione. La stringa relativa all'header da inserire in calce al file globals.php, conteneva virgolette inglesi anziché le virgolette semplici per la qulificazione del testo.

[allegato eliminato da un amministratore]
« Ultima modifica: 12 Apr 2008, 22:21:43 da sali40 »

Offline matrix845

  • Appassionato
  • ***
  • Post: 483
    • Mostra profilo
grazie per la guida!!

Adesso mi ci menterò appena possibile , ma non mi è chiara una cosa....


Consigli o no di fare un backup prima di lavorare sul sito???

















.....

 ;D


Scherzavo è riportato almeno 100 volte di farlo!!

Saluti


Pierpaolo

Offline sali40

  • Global Moderator
  • Instancabile
  • ********
  • Post: 4791
  • Sesso: Maschio
    • Mostra profilo
grazie per la guida!!

Adesso mi ci menterò appena possibile , ma non mi è chiara una cosa....


Consigli o no di fare un backup prima di lavorare sul sito???

.....

 ;D


Scherzavo è riportato almeno 100 volte di farlo!!

Saluti


Pierpaolo

 ::)

Offline matrix845

  • Appassionato
  • ***
  • Post: 483
    • Mostra profilo

Offline sali40

  • Global Moderator
  • Instancabile
  • ********
  • Post: 4791
  • Sesso: Maschio
    • Mostra profilo
cos'è questo pianto disperato? parliamone  :D

Offline Andrea E

  • Team Joomla.it
  • Esploratore
  • *******
  • Post: 147
  • Sesso: Maschio
    • Mostra profilo
Ho letto la guida di sali40.

Mi è sembrata parecchio "articolata", ma è possibile che non ci sono sistemi più semplici per risolvere il problema delle lettere accentate ?

AndreaE
Andrea Errigo
www.andreaerrigo.it

Offline felixfabry

  • Esploratore
  • **
  • Post: 83
  • Sesso: Maschio
    • Mostra profilo
    • LA VOCE DEL PAESE
ciao ,,, ho applicato la guida e funziona...

tranne per una cosa. INFATTI IL SITO ERA TUTTO BLOCCATO.

cioè mi funziona tutto (e prima non funzionava nulla) ELIMINANDO

questa parte della guida.

header(“Content-Type: text/html; charset=UTF-8”);
 
Editare il file global.php con BabelPad, alla fine, subito dopo
}
e prima di
?>
inserire:
header(“Content-Type: text/html; charset=UTF-8”);


Citazione
alla fine, subito dopo
}
e prima di
?>
inserire:

se ci riferiamo alla fine (giù) del file. precisamente alla linea 136.

mi dava questo errore. ho eliminato quel comando e ora sembra funzionare tutto.

sito : www.turiweb.it

(PS: TUTTO era nato poichè avevo deciso di aggiornare il forum collegato SMF alla verisone 1.1.4

un casino, aveva perso gli accenti il forum... poi seguendo qualche guida ho risolto il problema del forum...ed è sorto in joomla.  allora questa ottima guida di sali40 mi ha salvato... non so, sono venuto qui per dire e condividere come ho fatto e come ho risolto. forse sali40 può dirmi altro o verificare, non so

PPS: mi raccomando ai backup se no Sali vi picchiaaa!!  ;)
grandi ragazzi!)



Offline Andrea E

  • Team Joomla.it
  • Esploratore
  • *******
  • Post: 147
  • Sesso: Maschio
    • Mostra profilo
Scusate ma il prblema delle lettere accentate può dipendere anche dal tempalte che si utilizza ?

AndreaE
Andrea Errigo
www.andreaerrigo.it

Offline felixfabry

  • Esploratore
  • **
  • Post: 83
  • Sesso: Maschio
    • Mostra profilo
    • LA VOCE DEL PAESE
In particolare da questo errore...

Parse error: syntax error, unexpected ':' in /web/htdocs/www.turiweb.it/home/globals.php on line 135


ho ancora problemi di accenti con la componente !JoomlaComment 3.20 e all'interno della sezione administrator del sito...dipende da questo?

syntax error... soluzioni?

Offline felixfabry

  • Esploratore
  • **
  • Post: 83
  • Sesso: Maschio
    • Mostra profilo
    • LA VOCE DEL PAESE
nessuno sa?

Offline sali40

  • Global Moderator
  • Instancabile
  • ********
  • Post: 4791
  • Sesso: Maschio
    • Mostra profilo
In particolare da questo errore...

Parse error: syntax error, unexpected ':' in /web/htdocs/www.turiweb.it/home/globals.php on line 135


ho ancora problemi di accenti con la componente !JoomlaComment 3.20 e all'interno della sezione administrator del sito...dipende da questo?

syntax error... soluzioni?
No, questo messaggio sembra riferirsi al fatto che ci stanno due punti ":" che on dovrebbero esserci. Magari sarebbero dovuti essere un punto e virgola ";".
In ogni caso significa che c'è un problema di sintassi in quella riga.


Scusate ma il prblema delle lettere accentate può dipendere anche dal tempalte che si utilizza ?

AndreaE

No. In genere no.

ciao ,,, ho applicato la guida e funziona...

tranne per una cosa. INFATTI IL SITO ERA TUTTO BLOCCATO.

cioè mi funziona tutto (e prima non funzionava nulla) ELIMINANDO

questa parte della guida.

header(“Content-Type: text/html; charset=UTF-8”);
 
Editare il file global.php con BabelPad, alla fine, subito dopo
}
e prima di
?>
inserire:
header(“Content-Type: text/html; charset=UTF-8”);


Citazione
alla fine, subito dopo
}
e prima di
?>
inserire:

se ci riferiamo alla fine (giù) del file. precisamente alla linea 136.

mi dava questo errore. ho eliminato quel comando e ora sembra funzionare tutto.

sito : www.turiweb.it

(PS: TUTTO era nato poichè avevo deciso di aggiornare il forum collegato SMF alla verisone 1.1.4

un casino, aveva perso gli accenti il forum... poi seguendo qualche guida ho risolto il problema del forum...ed è sorto in joomla.  allora questa ottima guida di sali40 mi ha salvato... non so, sono venuto qui per dire e condividere come ho fatto e come ho risolto. forse sali40 può dirmi altro o verificare, non so


E' molto strano. Non è che gli apici non erano apici ma virgolette inglesi? facendo il "quote" del tuo messaggio, quelle virgolette non vengono riconosciute. Anche questo mi pare strano in effetti. Babelpad non dovrebbe produrre virgolette inglesi.

In ogni caso, la guida è "esaustiva" (... nel senso che rende esausti, ovviamente  ;D) per rendere il sito completamente utf-8. E' il caso, ad esempio, di un sito multilingua con lingue occidentali, italiano (lo metto a parte proprio per via delle accentate), lingue arabe, lingue orientali ... per le quali la codifica ISO8859-1 non offre supporto.

EDIT: Giusto per raffrontare, queste sono le virgolette inserite nel tuo messaggio: “ e ”
Queste le virgolette di qualificazione testo: "

Ho letto la guida di sali40.

Mi è sembrata parecchio "articolata", ma è possibile che non ci sono sistemi più semplici per risolvere il problema delle lettere accentate ?

AndreaE

La risposta è sopra. Puoi provare le parti più semplici della guida. Non dovresti aver bisogno di intervenire sul database. Dovrebbe bastare la correzione del codice locale in configuration.php e l'aggiuta delle stringhe nel file lingua
« Ultima modifica: 12 Apr 2008, 22:08:24 da sali40 »

Offline Andrea E

  • Team Joomla.it
  • Esploratore
  • *******
  • Post: 147
  • Sesso: Maschio
    • Mostra profilo
Grazie per le risposte sali40.

Però ho notato che cambiando template (alcuni) il problema si risolve; in effetti in  testa all'index.php ci sono dei riferimenti diversi di ISO.

AndreaE
Andrea Errigo
www.andreaerrigo.it

Offline felixfabry

  • Esploratore
  • **
  • Post: 83
  • Sesso: Maschio
    • Mostra profilo
    • LA VOCE DEL PAESE
SALI HO SEGUITO PARI PARI LA GUIDA.

non so che pesci pigliare... cosa posso provare?

Offline maraggos

  • Appassionato
  • ***
  • Post: 280
  • Sesso: Maschio
    • Mostra profilo
    • maraggos
avevo il problema: in Firefox andava tutto bene, mentre in IE .... era tutto sballato ...

... ma grazie alla tua guida ... FUNZIONA TUTTOOOO !!!!! ;D ;D ;D

GRAZIE GRAZIE !
Alberto

Offline felixfabry

  • Esploratore
  • **
  • Post: 83
  • Sesso: Maschio
    • Mostra profilo
    • LA VOCE DEL PAESE
Citazione
EDIT: Oggi sostituisco il pdf. C'era una imprecisione. La stringa relativa all'header da inserire in calce al file globals.php, conteneva virgolette inglesi anziché le virgolette semplici per la qulificazione del testo.

Ho corretto finalmente anche questo problema...

ancora nulla...???? abbondano invece delle lettere accentate...

che faccio?

Offline sali40

  • Global Moderator
  • Instancabile
  • ********
  • Post: 4791
  • Sesso: Maschio
    • Mostra profilo
Citazione
EDIT: Oggi sostituisco il pdf. C'era una imprecisione. La stringa relativa all'header da inserire in calce al file globals.php, conteneva virgolette inglesi anziché le virgolette semplici per la qulificazione del testo.

Ho corretto finalmente anche questo problema...

ancora nulla...???? abbondano invece delle lettere accentate...

che faccio?
Senti, guardando questa pagina, vedo che il testo è a posto. ci sono lettere accentate che si vedono correttamente. Il commento contiene un "c'?".
Vuoi, per favore, verificare che i file del componente utilizzato per i commenti non abbiano riferimenti a iso 8859-1? Magari, che so, l'xml di installazione.
Tieni presente che, però, quello che è stato inserito in un database (ormai) utf-8, se preso come puni interrogativi, tali restano. Quelli te li devi, se inseriti dopo la conversione, modificare uno per uno

Offline felixfabry

  • Esploratore
  • **
  • Post: 83
  • Sesso: Maschio
    • Mostra profilo
    • LA VOCE DEL PAESE
Citazione
Vuoi, per favore, verificare che i file del componente utilizzato per i commenti non abbiano riferimenti a iso 8859-1?

Avevo verificato, ma nulla. Ho riverificato e forse non avevo prima salvato correttamente. Il problema era proprio quello.

Sperando di essere stati utili a molti...Grazie di cuore!

Offline felixfabry

  • Esploratore
  • **
  • Post: 83
  • Sesso: Maschio
    • Mostra profilo
    • LA VOCE DEL PAESE
Ci può essere un conflitto fra UTF-8 e RSS.

Nel mio sito non funzionano più ed esce uno strano errore.

Chi sa?

http://www.turiweb.it/


link all'RSS

http://www.turiweb.it/index.php?option=com_rss&feed=RSS2.0&no_html=1

E qui appare l'errore come potete vedere

Errore interpretazione XML: non well-formed
Indirizzo: http://www.turiweb.it/index.php?option=com_rss&feed=RSS2.0&no_html=1
Linea numero 1, colonna 2:<?xml version="1.0" encoding="utf-8"?>
-^

HELP...

Offline sali40

  • Global Moderator
  • Instancabile
  • ********
  • Post: 4791
  • Sesso: Maschio
    • Mostra profilo
controlla i file di com_rss (sia dalla parte administrator sia dalla parte pubblica) e verifica che non ci siano riferimenti all'iso8859-1
E' probabile che nella visualizzazione, com_rss tenti di far visualizzare in iso8859-1 e questo confliggerebbe con la codifica complessiva del sito

Offline andiyp

  • Nuovo arrivato
  • *
  • Post: 8
    • Mostra profilo
Salve ragazzi, dopo aver letto le varie guide sul problema non ho trovato nulla a riguardo di questo problema su joomla 1.5.
Mi spiego meglio, ho trasferito il mio sito versione 1.5 da locale a remoto su server windows 2003 con installato iss6 e php5.Allora tutto bene per quanto riguarda la visibilità ecc ecc. tranne quando vado a visualizzare le notizie dove si presenta appunto il problema degli accenti sfalsandomi tutti gli articoli.
Come posso risolvere il problema senza dover intervenire ad una correzione a mano di ogni articolo?Grazie per il consiglio che vorrete darmi!

 

Torna su