Autore Topic: Rendere Joomla! completamente UTF-8 e risolvere il problema delle accentate  (Letto 56239 volte)

Offline crystalsoft

  • Esploratore
  • **
  • Post: 62
    • Mostra profilo
Grazie per l'interessamento.

La versione è la Joomla! 1.0.15 Stable.
Il problema non si è presentato in nessuno dei contenuti che avevo sul sito(un problemino l'ho avuto solo con una voce di menu' che presentava un'accentata sia frontend che backend).
Il grosso problema l'ho avuto sul forum( fireboard) poichè in tutti i testi che presentavano parole con l'accento, le lettere sono state sostituite con la A con una tilde sopra.
Volevo sottolineare il fatto che ieri sera ho provveduto all'installazione di Docman, disinstallato oggi appena resomi conto del problema. Il risultato è che mentre i problemi continuano con i messaggi scritti sul forum prima di stamattina, se utilizzo adesso lettere accentate begli interventi queste vengono correttamente visualizzate.
Potrebbe essere stato DocMan il problema?

Grazie

Offline crystalsoft

  • Esploratore
  • **
  • Post: 62
    • Mostra profilo
Se puo' esserti di aiuto in qualche modo alla comprensione del problema ti informo del fatto che in tutte le mail di notifica che mi arrivano per ogni intervento fatto sul forum, le lettere accentate sono sostituite da altri caratteri.
Il forum pero' ha sempre funzionato perfettamente fino a stamattina.

Offline sali40

  • Global Moderator
  • Instancabile
  • ********
  • Post: 4791
  • Sesso: Maschio
    • Mostra profilo
hai mai cambiato la codifica del tuo sito?

posteresti un link?

Offline crystalsoft

  • Esploratore
  • **
  • Post: 62
    • Mostra profilo
non ha fatto nulla in fatto di codifiche...arriva il link
Per una visualizzazione ottimale usa firefox(il TranMenu' non è granchè con explorer)
www.maintrendanalysis.com

Serve la registrazione per l'accesso al forum.

Offline sali40

  • Global Moderator
  • Instancabile
  • ********
  • Post: 4791
  • Sesso: Maschio
    • Mostra profilo
potrebbe essere stato docman, il problema, se docman ha impostato qualche tabella in utf-8. Joomla 1.0 utilizza la codifica iso8859-1 e quindi questo può aver causato il problema delle accentate. Certo, adesso che hai un "sistema misto" non puoi far altro che editare a mano tutto e ripristinare lo status quo ante

Offline crystalsoft

  • Esploratore
  • **
  • Post: 62
    • Mostra profilo
Ho disinstallato DocMan...perchè parli di sistema misto???

Grazie


P.s.
Ho fatto una domanda del kaiser...il sistema misto è rappresentato
dalla presenza contemporanea delle tabelle UTF-8 modificate da DocMan e le nuove standard in ISO.
« Ultima modifica: 28 Gen 2009, 22:32:06 da crystalsoft »

Offline crystalsoft

  • Esploratore
  • **
  • Post: 62
    • Mostra profilo
buonasera...ancora io, i problemi continuano.
Ci eravamo lasciati con il problema sulle accentate risolto.
Il fatto è che adesso se nel forum aprono un post con una qualsiasi accentata, la visualizzazione viene affettuata senza problemi, ma se cerco di accedere il cms mi restituisce questo:

"(http://www.maintrendanalysis.com/joomla/STATISTICHE/606-Attendibilit%C3%A0-segnali-MT-su-titoli-italiani.html)
404: Not Found
Sorry, but the content you requested could not be found"

Grazie anticipatamente a chi mi vorrà aiutare.

Offline sali40

  • Global Moderator
  • Instancabile
  • ********
  • Post: 4791
  • Sesso: Maschio
    • Mostra profilo
che forum è? accertati che il forum abbia la stessa codifrica del cms.

Offline crystalsoft

  • Esploratore
  • **
  • Post: 62
    • Mostra profilo
fireboard...dove ne verifico la codifica???

Offline sali40

  • Global Moderator
  • Instancabile
  • ********
  • Post: 4791
  • Sesso: Maschio
    • Mostra profilo
hai il pacchetto di installazione? scompattalo in locale e da una occhiata alle prime righe del file con estensione xml

Offline pieralli

  • Nuovo arrivato
  • *
  • Post: 32
    • Mostra profilo
Scusate se intervengo.
Alla fine io ho risolto inserendo come prima riga all'interno del file index.php, che si trova nella directory principale la stringa:
<?php header("Content-Type: text/html; charset=UTF-8", true); ?>

Attenzione a non metterlo nell'index.php del template perchè non funziona.
L'idea l'ho presa da un postato nel forum.


Offline crystalsoft

  • Esploratore
  • **
  • Post: 62
    • Mostra profilo
Provo e vi faccio sapere, grazie mille per la considerazione.

Offline sgs

  • Appassionato
  • ***
  • Post: 641
    • Mostra profilo
ciao ragazzi, io uso phpmyadmin 2.11.9.4 ...però non riesco a trovare la voce per la collazione. Qualcuno sa dov'è? Oppure mi suggerite un'alternativa????

Offline Wollie

  • Nuovo arrivato
  • *
  • Post: 25
  • Sesso: Maschio
    • Mostra profilo
    • Eyedea
Ciao a tutti,
premetto che ho usato la funziona "ricerca" un casino, e non solo su Google e sto ancora ad impazzire. Vi spiego brevemente il problema:

sto facendo un sito che più avanti dovrà avere anche altre lingue, ed attualmente ho il problema delle accentate.

La guida quindi che è allegata all'inizio del post l'ho letta tutta, ma non l'ho applicata pari pari proprio perchè non andando ad usare Joomfish (già provato ma mi ha solo creato problemi), ma duplicando il template tot volte (con lingue differenti).

Alchè che ho fatto?

a)Ho inserito dapprima in configurazione globale, sotto locale it_IT.UTF-8;
b)Ho inserito nell'index.php del template questo codice:

Codice: [Seleziona]
<?php defined"_VALID_MOS" ) or die( "Direct Access to this location is not allowed." );?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<?php $iso split'='_ISO );
echo 
'<?xml version="1.0" encoding="'$iso[1] .'"?' .'>';
?>

<html xmlns="http://www.w3.org/1999/xhtml">

<head>

<?php mosShowHead(); ?>
<?php
if ( $my->id ) {
initEditor();
}
?>

<meta http-equiv="Content-Type" content="text/html; <?php echo _ISO?>" />
;

c) sono andato a modificare il file italian.php, alla riga 420 inserendo:

Codice: [Seleziona]
DEFINE('_ISO','charset=utf-8');;

d) la prima riga del file templateDetails.xml è settata su charset UTF-8;

e) sono entrato nel DB con myphpadmin, e ho eseguito la procedura (con i milioni di backup precedenti) di collazione a utf8_general_ci. E su questo mi sono rimasti dei dubbi, nel senso che andando sulle variabili e parametri del server mi sono trovato questi dati:

character set client     utf8
(Valore globale)    latin1
character set connection    utf8
(Valore globale)    latin1
character set database    latin1
character set filesystem    binary
character set results    utf8
(Valore globale)    latin1
character set server    latin1
character set system    utf8
character sets dir    /usr/share/mysql/charsets/
collation connection    utf8_general_ci
(Valore globale)    latin1_swedish_ci
collation database    latin1_swedish_ci
collation server    latin1_swedish_ci

e su queste ultime 3 righe mi si è inarcato un sopracciglio (e non solo quello). Dopo tutto questo ambaradan di cose, pensate che sia questo il motivo per cui vedo ancora le accentate sbagliate?
Quando entro nel sito e guardo il sorgente mi indica che il charset utilizzato è utf-8, indi mi veniva il dubbio che il problema fosse proprio il DB. Mi potete confermare il dubbio per cortesia?

(per avvalorare la tesi che sia questo il problema ho notato che tutte le tabelle del DB _jos hanno una collazione latin1_swedish_ci... è qui il problema?!?!  :'()

Grazie in anticipo a chi saprà darmi la soluzione (gli pago una birra!)


Offline sali40

  • Global Moderator
  • Instancabile
  • ********
  • Post: 4791
  • Sesso: Maschio
    • Mostra profilo
Il procedimento indicato nella guida serve a rendere joomla 1.0 (che nasceva in iso 8859-1) totalmente utf-8.

Non ci sono, quindi, parti totalmente dedicate a joomfish.
Certo, joomfish si trova, poi, a gestire le accentate in modo corretto, ma come qualsiasi altro sistema per la gestione multilingua.

Premesso questo, ti consiglio di rivedere il tutto e di applicare tutte le modifiche indicate.

In altro topic un altro utente aveva avuto il tuo stesso problema con la lingua russa a causa di qualche imprecisione nel procedimento. Ti indico i post di riferimento:
http://forum.joomla.it/index.php/topic,65817.msg287343.html#msg287343
http://forum.joomla.it/index.php/topic,65817.msg290704.html#msg290704

ricordati di inserire le stringhe "locale" in tutti i file lingua.

Nel tuo caso, credo tu abbia modificato le stringhe relative al charset senza modificare la collazione generale (latin1_swedish_ci).

Anche se, poi, i valori globali del server (quelli indicati con valore globale) rimangono latin1, l'importante è che i valori del database sovrascrivano correttamente i valori globali stessi.

Ti raccomando di fare attenzione all'editor che usi. Io ho testato con successo solo babelpad e notepad++ con plugin di conversione (rispetto al tempo in cui ho scritto la guida, ho trovato migliore notepad++ con il plugin, ma babelpad continua a fare il suo lavoro con estrema dignità :) )

Spero di esserti stato di aiuto

Offline Wollie

  • Nuovo arrivato
  • *
  • Post: 25
  • Sesso: Maschio
    • Mostra profilo
    • Eyedea
Ti ringrazio per la pronta risposta,
oggi verifico la procedura daccapo e vediamo se ci salto fuori  :P

Grazie ancora  ;)

P.s. notepad++ rulez  ;D

Offline Wollie

  • Nuovo arrivato
  • *
  • Post: 25
  • Sesso: Maschio
    • Mostra profilo
    • Eyedea
Niente... ho provato tutta la procedura, ma alcuni componenti mi danno errori, ed ora tutti gli articoli  mi si troncano in corrispondenza della prima lettera accentata o di un apostrofo.
Non so che pesci pescare....  :-\

Offline crow

  • Nuovo arrivato
  • *
  • Post: 1
    • Mostra profilo
Ciao a tutti,
Ma Joomla 1.5 non ha già il supporto nativo per l'utf8?
o sbaglio?

Offline albertot

  • Nuovo arrivato
  • *
  • Post: 17
    • Mostra profilo
ciao a tutto il thread: ho anche io il problema di un sito preparato con Joomla! 1.5 che presenta lettere a caso al posto delle accentate.
Ho provato a esportare il database e reimportarlo con il set di caratteri corretto, ma ottengo questo gradevole commento
Codice: [Seleziona]
#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1
qualcuno mi puo' aiutare?

Offline solaria62

  • Esploratore
  • **
  • Post: 185
  • Sesso: Maschio
  • L'arte di vivere
    • Mostra profilo
    • promoziona iltuo sito
salve,
ho letto tutti i post ma nessuna che ha il mio stesso problema.
il mio problema è che le accentate si presentano solo se faccio il refresh della pagina.

un link di esempio:

http://www.hollywood-video.it/index.php?option=com_content&view=article&id=57%3Ai-sogni-di-holywood&catid=40%3Arecensioni&lang=it

questo accade solo agli articoli e alle intestazioni dei moduli. i quali sono coinvolti nella traduzione joomfish.

la sezione virtuemart non è conivolta.

quale soluzione ??
grazie.
<a href="http://www.marasweb.it alt="promoziona il tuo sito"/">promozione su motori di ricerca[/url] ti
aiuta!

 

Torna su