Autore Topic: Rendere Joomla! completamente UTF-8 e risolvere il problema delle accentate  (Letto 60248 volte)

Offline minnoleo

  • Nuovo arrivato
  • *
  • Post: 2
    • Mostra profilo
Scusate, qualcuno sa dove trovare questa guida per risolvere i problemi di lettere accentate???
Grazie anticipatamente

Offline sali40

  • Global Moderator
  • Instancabile
  • ********
  • Post: 4791
  • Sesso: Maschio
    • Mostra profilo
eccole: http://www.joowiki.com/index.php?option=com_openwiki&Itemid=2&id=utf8

Bada che è stata costruita per joomla 1.0.x.

Joomla 1.5.x ha già il supporto per utf-8, quindi devi verificare solo la parte relativa al database.

Ti raccomando di utilizzare uno degli strumenti indicati nella guida, per editare il database (notepad++ con il plugin convertext oppure babelpad)

Offline minnoleo

  • Nuovo arrivato
  • *
  • Post: 2
    • Mostra profilo
Grazie mille molto gentile..

Offline berlati@tiscali.it

  • Esploratore
  • **
  • Post: 58
  • Sesso: Maschio
    • Mostra profilo
    • www.fabrizioberlati.com
Salve,
stesso problema per il mio sito, ma stranamente non è sempre visibile, a volte effettuando un refresh appaiono gli accenti giusti, al secondo ritorna come prima.
joomla 1.5.14

grazie anticipatamente per chiunque possa aiutarmi

Fabrizio

Offline Nescio

  • Esploratore
  • **
  • Post: 67
    • Mostra profilo
Salve,
stesso problema per il mio sito, ma stranamente non è sempre visibile, a volte effettuando un refresh appaiono gli accenti giusti, al secondo ritorna come prima.
joomla 1.5.14

grazie anticipatamente per chiunque possa aiutarmi

Ho lo stesso identico problema.
Ho seguito la parte della guida che si riferisce al DB, ma le uniche stringhe che trovo all'inizio che riguardano il set di caratteri sono:
Codice: [Seleziona]
/*!40101 SET @OLD_CHARACTER_SET_CLIENT=@@CHARACTER_SET_CLIENT */;
/*!40101 SET @OLD_CHARACTER_SET_RESULTS=@@CHARACTER_SET_RESULTS */;
/*!40101 SET @OLD_COLLATION_CONNECTION=@@COLLATION_CONNECTION */;
/*!40101 SET NAMES utf8 */;

Da nessuna parte, all'interno del db, trovo né "atin1_swedish_ci" né "latin" né "utf8_unicode_ci".
Se all'interno del db cerco "CHARSET" Trovo pressocché dappertutto: charset=utf-8; oppure charset:1/ (ma credo che si riferisca alla formattazione degli articoli).

Se all'interno del DB cerco la parola "Collate" trovo
Codice: [Seleziona]
/tabelle relative al forum phpbb/
ENGINE=InnoDB DEFAULT CHARSET=utf8 COLLATE=utf8_bin;

Tempo fa, quando migrai dalla 1.0 alla 1.5, utilizzai wordpad (eh.. lo so..) per aprire il db. Ho provato a convertirlo con notepad++ e riupparlo ma non cambia nulla. Con notepad++, in basso a sinistra appare: UNIX | ANSI as UTF-8.

In PhpMyAdmin, nel db incrimanto dove sono installate sia Joomla che Phpbb, ho selezionato la collation utf-8 general (prima era stranamente impostata su Latin swdish etc) ma, il problema persiste.
Dato che non posso riscrivere uno ad uno ogni articolo in una nuova installazione.. come posso fare?

edit: mi è sorto un dubbio. Per le pagine php del template etc utilizzo spesso il notepad di windows. Può essere questo?
Però non mi ha mai dato problemi, infatti tra le varie installazioni di joomla 1.5.x solo su questa si presenta l'errore.
« Ultima modifica: 24 Nov 2009, 17:37:42 da Nescio »

Offline gigig

  • Appassionato
  • ***
  • Post: 276
    • Mostra profilo
Qualcuno può fornirmi le guide di cui si parla in questo articolo? ho un sito fatto anni fa, e tutti i giorni della settimana hanno caratteri strani!
Purtroppo non riesco ad accedere ai vari link segnalati in questo post.
Grazie

mau_develop

  • Visitatore
sarà perchè non esiste più joomla 1.0.xx ?

M.

Offline Cs3v3n

  • Nuovo arrivato
  • *
  • Post: 37
    • Mostra profilo
Salve, su Joomla 2.5.x ho lo stesso problema, infatti svuotando la cache, cioè se vado in


Sito->Manutenzione->Pulisci cache


la elimino , una voce che si chiama, Page, torna tutto come prima, ma se provo a navigare nel sito, oppure solo aggiornare la pagina, tornano quei caratteri strani, e non saprei come risolvere questo problemino...


Si tratta di questo tipo di caratteri -->>>>> Â


Che cosa posso fare?


grazie,


Claudio

 

Torna su