Autore Topic: [risolto] Problema in amministrazione  (Letto 2124 volte)

Offline pakag

  • Nuovo arrivato
  • *
  • Post: 3
    • Mostra profilo
[risolto] Problema in amministrazione
« il: 27 Feb 2008, 13:49:46 »
Ciao a tutti ho appena istallato joomla 1.5 e in apparenza tutto è andato a buon fine, ma ...
Basta entrare in amministrazione e compare un errore javascript, che si trascina in tutte le pagine di amministrazione.
L'errore javascript che compare è il seguente (letto nella console di firefox) :
Errore: missing ; before statement
File sorgente:

http://www.miodminio.it/joomla/includes/js/joomla.javascript.js
Riga: 2, Colonna: 9
Codice sorgente:
Parse error:  syntax error, unexpected T_STRING in /home/glftpd/site/mioaccount/public_html/joomla/includes/js/joomla.javascript.js on line 1


non ho idea di cosa possa generare questo errore, potete aiutarmi?
« Ultima modifica: 29 Feb 2008, 09:57:40 da pakag »

Offline Febrisio

  • Esploratore
  • **
  • Post: 73
  • Sesso: Maschio
  • Non sforzarti di capirlo, devi solo immaginarlo!
    • Mostra profilo
Re: Problea in amministrazione
« Risposta #1 il: 27 Feb 2008, 20:37:14 »
Hai modificato in un qualche modo il file? o solamente aperto e avvertitamente modificato?

io posto il mio joomla.javascript.js, queste le prime righe di cui le prime commentate:

(Occhio ai punti e virgola, guardando su google il problema sembra più in file php che js)

Codice: [Seleziona]
// <?php !! This fools phpdocumentor into parsing this file
/**
* @version $Id: joomla.javascript.js 9765 2007-12-30 08:21:02Z ircmaxell $
* @package Joomla
* @copyright Copyright (C) 2005 - 2008 Open Source Matters. All rights reserved.
* @license GNU/GPL
* Joomla! is Free Software
*/

/**
 * Overlib Styling Declarations to allow CSS class override of styles
 *
 */
var ol_fgclass='ol-foreground';
var 
ol_bgclass='ol-background';

Offline pakag

  • Nuovo arrivato
  • *
  • Post: 3
    • Mostra profilo
Re: Problema in amministrazione
« Risposta #2 il: 28 Feb 2008, 09:13:30 »
Si, ho controllato il file in questione più volte, l'ho ricaricato, e sono stato attento che il trasferimento del file tramite ftp avvenisse in modalità binaria e non ascii.

ora sono riuscito a eliminare l'errore, ma non so se tutto funzionerà in quanto ho eliminato la prima lineaa che compare nel file
joomla.javascript.js

la linea in questione è :

// <?php !! This fools phpdocumentor into parsing this file


 

Torna su