Autore Topic: Joomfish problemi lato admin con pił di 50 elementi  (Letto 2506 volte)

Offline Cat

  • Nuovo arrivato
  • *
  • Post: 18
  • Sesso: Maschio
    • Mostra profilo
Ciao ragazzi, ho un problema con Joomfish 1.7RC istallato su Joomla 1.08:
ho pił di 50 elementi da tradurre ma il pannello di JoomFish ha un bug nella navigazione quindi non riesco ad andare alla pgina 2 (in sostanza il navigatore pagine non va).
Ho cercato ovunque ma non ho trovato la soluzione :-[
Anche nel sito ufficiale del progetto lo nominano come bug riscontrato ma non ce ombra della soluzione!!

Sapete come fare?

Ho individuato il pezzo di codice colpevole ma non so modificarlo!!:
adimistrator/components/com_joomfish/amin.joomfish.php

// Build up the rows for the table
   $rows=null;
   $total=0;
   $filterHTML=array();
   if( isset($catid) && $catid!="" ) {
      $contentElement = $joomFishManager->getContentElement( $catid );
      $tranFilters = getTranslationFilters($catid,$contentElement);
      $database->setQuery( $contentElement->createContentSQL( $language_id, null, $limitstart, $limit, $tranFilters ) );
      $rows = $database->loadObjectList();
      if ($database->getErrorNum()) {
         echo $database->stderr();
         return false;
      }
      
      /*
      $database->setQuery( $contentElement->countContentSQL($language_id) );
      $result = $database->loadObjectList();
      echo $database->getErrorMsg();      
      $total = count( $result );
      */
      $total = count($rows);
      
      // Manipulation of result based on further information
      for( $i=0; $i<count($rows); $i++ ) {
         $contentObject = new ContentObject( $language_id, $contentElement );
         $contentObject->readFromRow( $rows[$i] );
         $rows[$i] = $contentObject;
      }

      foreach ($tranFilters as $tranFilter){
         $afilterHTML=$tranFilter->_createFilterHTML();
         if (isset($afilterHTML)) $filterHTML[] = $afilterHTML;
      }

   }
   
   require_once("includes/pageNavigation.php");
   $pageNav = new mosPageNav( $total, $limitstart, $limit );
Joomla Rocks! OSC BAD!

Offline ste

  • Moderator
  • Instancabile
  • *****
  • Post: 8774
  • Sesso: Femmina
    • Mostra profilo
Re: Joomfish problemi lato admin con pił di 50 elementi
« Risposta #1 il: 06 Giu 2006, 11:44:42 »
Ciao, hai provato con la versione stabile di Joomfish 1.7?
TTI - Team Traduzione Italiano di Joomla.it - Guide su Joomla

 

Torna su