Autore Topic: poll visualizza i menu non correttamente  (Letto 2596 volte)

Offline graffio

  • Nuovo arrivato
  • *
  • Post: 1
    • Mostra profilo
poll visualizza i menu non correttamente
« il: 07 Ott 2005, 18:21:34 »
Salve.
versione: joomla! 1.0.2 Stable-ita [ Sunset ] 02-oct-2005 16:00 UTC
E' un caso particolare ma mi e' capitato, e magari e' capitato anche ad altri.
In una installazione (sia on-line che in locale) non ho voci di menu' (moduli) assegnati a tutte le pagine.
In questo caso ho riscontrato che i risultati del sondaggio o la pagina di ringraziamento per il voto non visualizzano nessun menu a sinistra.
io l'ho risolto modificando:
  * mod_poll.php
    linea 98 aggiunto: &Itemid=$Itemid
    che quindi e' diventata:
    <input type="button" name="option" class="button" value="<?php echo _BUTTON_RESULTS; ?>" onclick="document.location.href='<?php echo sefRelToAbs("index.php?option=com_poll&amp;task=results&amp;id=$poll->id&amp;Itemid=$Itemid"); ?>';" />

  * poll.php
    linea 106 aggiunto: .'&Itemid='.$Itemid
    che quindi e' diventata cosi:
    mosRedirect( sefRelToAbs('index.php?option=com_poll&task=results&id='. $uid .'&Itemid='.$Itemid ), _THANKS );
 
    linea 110 aggiunto: .'&Itemid='.$Itemid
    diventata:
    echo '<input class="button" type="button" value="'. _BUTTON_RESULTS .'" onClick="window.location=\''. sefRelToAbs( 'index.php?option=com_poll&task=results&id='. $uid .'&Itemid='.$Itemid ) .'\'">';

Spero di essere stato utile.

complimenti per il lavoro

 

Torna su